• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Robohelp 2017/2019 Printed Documentation fail: nothing happens

New Here ,
Jan 27, 2021 Jan 27, 2021

Copy link to clipboard

Copied

When I click "Save and Generate" for printed documentation for my project, nothing happens. I don't get an error message as others have mentioned; it just doesn't do anything, though it had always worked before.

It started with RH 2017, and today I tried again after updating to RH 2019 Classic. I'm using Word via Microsoft 365 Enterprise, so I assume I have a compatible version.

I tried it with one of the sample projects, and that worked fine. 

It first happened a few months ago, but I didn't really need it, so I didn't deal with it then.

Views

146

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 27, 2021 Jan 27, 2021

Copy link to clipboard

Copied

Are you generating PDF or Word output or both?

 

Are you generating to a network location or to your C drive?

 

Do you have all the patches installed? You can check under the File > Help menu.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 27, 2021 Jan 27, 2021

Copy link to clipboard

Copied

Also, has generating printed documentation ever worked with this project?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2021 Jan 27, 2021

Copy link to clipboard

Copied

I am generating Word output to my desktop. 

I have all patches installed. 

I was able to generate printed documentation with this project for years until the fall.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 28, 2021 Jan 28, 2021

Copy link to clipboard

Copied

Given it works with the sample project, it sounds like something specific to your project. And something that changed in Sept-Oct-ish.

 

Can you think of anything major that happened in that timeframe? Moving the project to a different location? Restructuring the content? Rebranding? IT rolled out OneDrive or similar? If you can think of anything, that might help narrow down what's wrong - e.g. maybe work rolled out OneDrive and that has caused some sort of issue.

 

A few other things to try to narrow down where the problem is:

  • Create a temporary TOC with just a couple of topics in. Try generating using that instead of your normal one.
  • If that generates, try taking a copy of your TOC and delete half the TOC. Does that generate? Repeat with the other half of the TOC. If one does generates and the other doesn't, repeat the division with the half that doesn't work, to find the topic causing the problem. If both don't generate, something else is the issue.
  • Create a new Printed Documentation output - create it fresh, rather than duplicating your existing one - and set all the settings the same as the sample project. Does that generate? If it does, change your settings one by one to batch your printed doc and generate after each change until you find the thing that breaks it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 28, 2021 Jan 28, 2021

Copy link to clipboard

Copied

Just one thing to add to Amber's comprehensive list.

 

Grab a clean default.css from a new project and copy that into your project. Apply that to a master page and select that master page when you generate. Obviously if it does generate it will look wrong but what it will do is tell us the issue is somewhere in your CSS.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

I remember having a problem with generating Word with RH2017, and I found the issue after doing some digging in this community. It turned out to be a Word macro security setting. In Word Options, open the Trust Center tab, click Trust Center Setting button, and under Macro Settings, select Enable All Macros. Then open RH and try to generate the Word output again. It fixed the problem for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 06, 2021 Feb 06, 2021

Copy link to clipboard

Copied

@Mike.Walsh.0 I doubt that is the issue in this case as the problem is project specific. That issue affects all projects.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I had to let this issue drop for a while for various reasons. Recently, I updated to RH 2020, and in the process, was able to successfully generate printed documentation in Word with no master page. I only use the printed documentation to send updated topics to reviewers, so I don't need it to look polished. If I ever do, I will try Peter's suggestions with the clean default.css to see if that is the problem (although since the problem affects all the projects, even the samples, I'm not sure if one bad .css could be responsible). 

In any case, thank you everyone!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

LATEST

You can right click an open topic or a topic in the Contents panel and select Save As PDF or there is the Reviewing feature.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp