Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Robohelp 2017 Adding RH URLs from RHTML5 into Word or Excel do not work

Participant ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

I upgraded our Charcoal_Grey Screen Layout to the latest version (that contains the predictive searching) and now when we put a link to a topic in a Word or Excel file the link doesn't work. If we locate the topic and then do a right-click and choose Create Shortcut and add this to our Word or Excel file we get an 404 page not found error. If we copy/paste the topic URL from the URL bar, the link displays the correct topic but it is unformatted and displays without the Screen Layout. We've also experienced the link going to our home page and not the topic we copied the URL for. Is there a way to copy/paste a topic URL into a Word or Excel document so when you click on it, it opens the topic from the TOC and includes the correct formatting. We had no problem with copying/pasting topic URLs before upgrading our Screen Layout to include the predictive search, but now these links no longer work.

TOPICS
HTML5 layout

Views

235

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 21, 2018 Dec 21, 2018

Copy link to clipboard

Copied

Looks like you might be running into the changes in CSH calls for HTML5 output. I just played around with one layout from RH2019 and found that URLs that included the "topic.htm#t=xxx" type links don't link to the individual topic, but just launch the index page. However, if I locate the topic in the ToC and right click on it to "Copy link address" and then paste that URL, I see that it's a direct path down to the actual topic htm page.

Was this method of linking working before in RH2017?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 21, 2018 Dec 21, 2018

Copy link to clipboard

Copied

This worked in 2015 using the IE Copy Shortcut option from the browser's right-click popup menu. After we upgraded to RH2017 we couldn't use this method anymore because of the changes to the URL. We had to copy/paste the topic's URL from the URL bar in the IE browser and this worked. Now none of this works for us. Just a specific point to mention, it is our Corp requirement to use IE. Also I don't have the menu option you mention of Copy Link Address you mention so I wonder if you are referring to Chrome or Firefox?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 21, 2018 Dec 21, 2018

Copy link to clipboard

Copied

Yes, that was using Chrome as my default browser. So I just did a quick test with IE set as the default. I found that the "topic.htm#t=xxx" link works fine; as does the "Copy Shortcut" right-click action on the TOC. The first one launches with a TOC visible, but on the correct topic; the latter launches the topic full-width (no TOC), but has a "Click here to see this page in full context" link that will give you the TOC and all the other stuff that displays using the #t= URL.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 27, 2018 Dec 27, 2018

Copy link to clipboard

Copied

LATEST

After doing a little digging it looks like both methods of this copy/paste function works for some members on my team, but not others. I don't know if it is a browser issue or what. I checked browser versions and updates and we all have the same. I guess i'll just have to compare all of our browser settings because I can't think of what else it is. The URLs being copy/pasted are exactly the same.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp