• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Locked

Where are the pre-formatted tables? How to customize Table formatting.

Community Beginner ,
Jan 20, 2023 Jan 20, 2023

Copy link to clipboard

Copied

Tables - Adobe RoboHelp comes with a number of pre-formatted tables that can be edited to suit your own requirements or you can create your own from scratch.

I'm using RoboHelp 2022 and I don't see any pre-formatted tables. If I Insert Table from the toolbar, I just get to select the number of rows/columns and a simple plain table is inserted.

If I select a table and right-click, I don't see Table Properties. I do see Content Properties.

 

I created a custom Table Style but I'm having trouble with the look. I already add a TableHeader style.

We are also going to import Markdown files - some have tables - so I want the <table> to have the custom table style. I noticed the .htm topics from imported .md files have a <thead> and my old tables have just <tbody> and rows the color/padding in the rows that are the heading.

 

I don't want to edit all my old tables either. Suggestions?

 

Views

169

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jan 29, 2023 Jan 29, 2023

Here's what I did.

 

1. Set up a table with green borders, orange background on the first row.

2. Insert a table in the topic.

Amebr_0-1675033009762.png

3. Click inside the table and select the table using the tag breadcrumbs.

Amebr_1-1675033119726.png

4. Click the Clear Formatting button and select 'Clear Inline Formatting'.

Amebr_2-1675033203030.png

5. Now the table looks like this

Amebr_3-1675033238917.png

6. Apply my ugly table.

Amebr_4-1675033268209.png

 

Here are the settings I made for my table:

Amebr_5-1675033347143.pngAmebr_6-1675033403420.png

 

Hopefully that helps.

Likes

Translate

Translate
Community Expert ,
Jan 20, 2023 Jan 20, 2023

Copy link to clipboard

Copied

Start here. RH2022 Tables (grainge.org)

 

<TH> is not currently supported but is expected in an upcoming update.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 20, 2023 Jan 20, 2023

Copy link to clipboard

Copied

Ok, so there are no current pre-formatted tables like this article states? 

https://www.grainge.org/pages/authoring/rh_tour/rh2022/authoring/tables.htm

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 20, 2023 Jan 20, 2023

Copy link to clipboard

Copied

It's late night for Peter, but the answer is no, there are, but that tablehead element you talk about isn't supported yet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 21, 2023 Jan 21, 2023

Copy link to clipboard

Copied

Insert a table using the top toolbar. Click the Table breadcrumb and you will then see the templates.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2023 Jan 23, 2023

Copy link to clipboard

Copied

The only thing I see when I select Insert Table is this:

deniseh47762385_0-1674508673807.png

No other dropdown or window.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2023 Jan 23, 2023

Copy link to clipboard

Copied

OK, I "found" Table Properties in the right pane after I selected the table (not a right-click like in the old days). These are the only templates I see.

deniseh47762385_0-1674509064513.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 23, 2023 Jan 23, 2023

Copy link to clipboard

Copied

Is your question "how can I change what appears in that list"? If so, I think the answer is you can't. 

 

However, once you've applied one of those styles to a table it should appear in your stylesheet and you can customise it there, or duplicate it if you want to create your own style name.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Your other option is to create the table you want in the CSS editor. It will not appear in Templates pane but you can apply it from the CSS. How is described in the page I pointed you to.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 25, 2023 Jan 25, 2023

Copy link to clipboard

Copied

I've been trying to customize a very simple table layout with little success. The custom TableTernion Style settings are not reflected on my topic table. I Insert Table into a test topic, selected table, select Table Properties, Clear both formatting, selected S and my new Style, and it doesn't look like I expected.

The html shows:

<table border="1" cellpadding="1" cellspacing="1" class="TableTernion" style="border-collapse:collapse; width:100%">

but I set the border to separate, padded to 4px...

Here's the TableTernion Style Preview:

deniseh47762385_0-1674679832595.png

Here's the table in my topic:

deniseh47762385_1-1674680178807.png

 

I also want to add the first row with a different font color/weight and background. I already had a TableHeader style from long ago (that's in my current topics) but when applied to first row of this new table, it looks wrong; I want the background to consume the whole cell:

deniseh47762385_2-1674680328741.png

I keep going around in circles so can you help?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2023 Jan 26, 2023

Copy link to clipboard

Copied

You may need to click Clear Formatting a couple of times. The first time was probably only clearing the td formatting for the current table cell. You should be able to see what tag is selected at the top of the General panel. Use the tag breadcrumbs at the top of the topic to select the table tag, then click Clear Formatting and that should remove all inline formatting from the table.

 

For the table border, I think you've set the outside border of the table (darker grey). However, because of the way CSS works, you also need to set cell borders.  (The RH interface will show table lines even if you haven't set a border style, so I think that's why you can see light grey cell "borders" in the editor - they are fake borders, not real ones.  I could be wrong though as I'm just going off what I can see in the screenshots.)

 

The following instructions are for an earlier version of RH, but the principles should be the same, even if some of the interface is a little different.

 

In Apply formatting to, select 'Whole Table'. Then expand the CELLS section and set the border to the same as you set in the BORDER section.

 

To set styling for a header row, you don't need to use a separate style. Instead, in Apply formatting to, select 'First Row'. Then set the background colour, font size and colour etc to the desired values.

 

Does that help?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2023 Jan 27, 2023

Copy link to clipboard

Copied

I removed the formatting and reapplied it and no change.

I do have Table and Cell Border Color of #c0c0c0, Cell Padding 6x, and General Border Collapse of 'separate' but the cells do not "separate" like the Preview.

 

If I look at the table in html/source, I see this:

<table border="1" cellpadding="1" cellspacing="1" class="TableTernion" style="border-collapse:collapse; width:100%">

If I change the border-collapse:collapse to border-collapse:separate, I do now see the cell "padding" in the table.

No matter if I select the Style General Border Collapse is 'separate' or 'collapse', it shows the same border-collapse:collapse (unless I change it in html).

This looks like a bug.

I just want to create a table as needed (or have a basic one created from an imported .md file), then apply the TableTernion Style to the table without changing the html code.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2023 Jan 27, 2023

Copy link to clipboard

Copied

I also have the change the cellpadding in html to cellpadding="4" cellspacing="4" manually since it doesn't use the 

deniseh47762385_0-1674853789281.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2023 Jan 27, 2023

Copy link to clipboard

Copied

I did figure out how to do the first row so that's nice. I also changed the border colors to be darker than the 1st row border, which is similar to my current topics.

But a newly inserted table, apply my table Style does not add the padding/separate. See before and after I manually update the html from 1 to 4 and collapse to separate:

deniseh47762385_0-1674854496263.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 29, 2023 Jan 29, 2023

Copy link to clipboard

Copied

Here's what I did.

 

1. Set up a table with green borders, orange background on the first row.

2. Insert a table in the topic.

Amebr_0-1675033009762.png

3. Click inside the table and select the table using the tag breadcrumbs.

Amebr_1-1675033119726.png

4. Click the Clear Formatting button and select 'Clear Inline Formatting'.

Amebr_2-1675033203030.png

5. Now the table looks like this

Amebr_3-1675033238917.png

6. Apply my ugly table.

Amebr_4-1675033268209.png

 

Here are the settings I made for my table:

Amebr_5-1675033347143.pngAmebr_6-1675033403420.png

 

Hopefully that helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 30, 2023 Jan 30, 2023

Copy link to clipboard

Copied

Thank you so much! I guess the breadcrumb | table selection works differently than me just selecting the table and clearing the format since the formats weren't the same.

 

I've got my table 99% the way I want it; would prefer just a little more cell border spacing (space between the individual cells) but not padding inside the cell, and can't figure that out. If I do Border spacing that's just on the outside table border.

deniseh47762385_0-1675100597380.png

 

Also, how can I add some line spacing right after the table so the next text/Subheading is not right under the table?

 

FYI: Since the <thead> is not supported right now for table Styles (imported .md files have 1st row in <thead>), my workaround is to change the <th> in the <thead> <tr> <th> rows to <td>, cut/paste the <tr> <td> rows into the <tbody> section, then remove the <thead> section before I add the custom Style or else the 1st row is applied to the 2nd row.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 30, 2023 Jan 30, 2023

Copy link to clipboard

Copied

The cell spacing is under the General section when you have Whole Table in Apply formatting to selected.

 

For the space below the table, try setting padding-bottom or margin-bottom. Click the padlock so you can set it separately.

 

I'm not sure what you mean for the last paragraph. I'm not sure where a separate style comes in to it. You should be able to set all the settings in the table style.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
4 hours ago 4 hours ago

Copy link to clipboard

Copied

LATEST

Ok, thanks. The bottom margin worked great. 

Thanks for all your help! You can close this out now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp