Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Why does RoboHelp mysteriously rearrange topics?

New Here ,
Nov 09, 2009 Nov 09, 2009

Copy link to clipboard

Copied

Hello fellow RoboHelp users,

In my RoboHelp 8 project, the projects periodically rearrange themselves in the Project Manager. Has anyone run into this problem and found a solution?

Views

1.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 09, 2009 Nov 09, 2009

Copy link to clipboard

Copied

Hi Barbara.

Are you inadvertantly sorting or filtering the files that are displayed in the pod. try using on of the pod's toolbar icons to see if that is the answer. If not, post back with some more detail.


  • Read the RoboColum(n) for a tips, tricks and musings on the Technical Communication Suite products.
  • Follow the RoboColum(n) on Twitter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2009 Nov 09, 2009

Copy link to clipboard

Copied

Colum, we're not sorting or filtering. When we open the project, the files are simply rearranged. This happens sporadically.

RoboHelp hasn't crashed, so I don't think it's a corrupt project file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 09, 2009 Nov 09, 2009

Copy link to clipboard

Copied

Hi there

Colum is referring to this icon:

tmp1.png

If the icon is clicked, it has an orange square surrounding it. This also changes the way RoboHelp displays the files in the Project Manager.

So if your icon is orange, try clicking it to turn it off.

Cheers... Rick

Helpful and Handy Links

RoboHelp Wish Form/Bug Reporting Form

Begin learning RoboHelp HTML 7 or 8 within the day - $24.95!

Adobe Certified RoboHelp HTML Training

SorcerStone Blog

RoboHelp eBooks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2009 Nov 12, 2009

Copy link to clipboard

Copied

My filter button doesn't have an orange box around it. My coworker says RoboHelp has crashed several times, so we're thinking that's the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 12, 2009 Nov 12, 2009

Copy link to clipboard

Copied

Hi Barbara.

Can you clarify exactly what you mean by "files" not being sorted? Are you referring to topics, images, baggage files, etc? If so, RH sorts by these before sorting by file name if the icon Rick highlighted is not selected.


  • Read the RoboColum(n) for a tips, tricks and musings on the Technical Communication Suite products.
  • Follow the RoboColum(n) on Twitter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 12, 2009 Nov 12, 2009

Copy link to clipboard

Copied

Are the folders and files being rearranged or are some of them missing? Look in Tools > Reports > Unused Files and see if that is showing a whole bunch of your topics. If it does, see the announcement on the RoboHelp HTML forum.


See www.grainge.org for RoboHelp and Authoring tips

Follow me @petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 16, 2009 Nov 16, 2009

Copy link to clipboard

Copied

I think I know what Barbara is talking about, as I've experienced it several times in the last few weeks and I think it relates to the announcement that Peter posted.

Opening RH as normal, sometimes not after a crash, moves several folders or topics from the bottom of the list in the project manager view to the top. No matter what you do, they will not move back to where you want. They were not sorted using the A/Z filter, just sorted manually based on how I wanted the TOC to apepar,  I found that if I closed the project again and opened it the topics and folder would be gone, with a load of broken links created (hence the relationship to Peters post)

I also found it doing this with individual topics in folders. Example, I had a glossary folders with each letter represetning a topic, obviously it was sorted A-Z (26 topics in total) sometimes the topics would be completely rearranged and wouldnt let me move them, the only way I could was to create several new topics and move the current topics inbetween them. It was extremely annoying......I found no cause, or fix for it (haven't tried the new DLLs yet)

I just got hit with this today in fact, it moved 2 folder, each with about 20 topics, then the folders were gone and I had a load of dead links, had to re-create the folders and restore the links. waste of 30mins that was. Will see how the new DLLs help.

Nick.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 16, 2009 Nov 16, 2009

Copy link to clipboard

Copied

Nick

You don't whether this is before or after applying the new DLLs.


See www.grainge.org for RoboHelp and Authoring tips

Follow me @petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 16, 2009 Nov 16, 2009

Copy link to clipboard

Copied

For me, this is happening before the new DLLs, and before and after the 8.0.1 update. not sure if Barbara has applied either of these so can't comment on her own projects.

I will post here if the issue comes up again after applying the new DLLs.

Nick.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2009 Nov 18, 2009

Copy link to clipboard

Copied

Thanks, Nick. I'm going to apply the RH update and see if that fixes the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2011 Apr 08, 2011

Copy link to clipboard

Copied

I am running into the same issue, and I'm running version 8.02.208.

For the last two days, topics in a folder keep jumping from the last topics to the first. Yesterday it was the last two topics, today it was the last three. RoboHelp has not crashed and I do not have an orange square next to the "double arrow AZ button" to sort topics.

I also experience a similar problem when I delete or add topics thru the Project Manager. I'll combine text from two topics into one, and then delete the one I don't need through the Program Manager. The next time I start RoboHelp, I get error messages saying topics have been deleted and next time to do that thru the Project Manager. That's what I did!

When I add a topic, the next time I open RoboHelp, it's missing from the Project Manager and has to be imported (the HTML file still exists, it's just not in the Project).

I've tried clicking the Save All button each time before I close RoboHelp, but that didn't resolve the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 08, 2011 Apr 08, 2011

Copy link to clipboard

Copied

Is your project on a local drive or on a network?

Are you using source control?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 11, 2011 Apr 11, 2011

Copy link to clipboard

Copied

Peter, the project is on a network drive so that it will get backed up every night.

Since I don't know what source control is, I'm guessing I'm not using it.

thank you, Debbie from Tronia Systems Ltd.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 11, 2011 Apr 11, 2011

Copy link to clipboard

Copied

RoboHelp projects cannot be on a network drive other than under source control, end of story.

I know all the arguments that IT will raise. See Snippet 120 on my site. They can argue until they are blue in the face but it will not make RoboHelp work with network projects. The snippet explains what to do.

The alternative is to use source control and check back in at the end of the day.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 11, 2011 Apr 11, 2011

Copy link to clipboard

Copied

Thank you so much, Peter, for clearing up that mystery! I will be moving the project to a local drive or figuring out how to properly use source control before I made any more edits.

-Debbie

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2015 Oct 26, 2015

Copy link to clipboard

Copied

Has anyone found a more definitive answer to the original question posted? I am experiencing exactly the same thing Barbara describes, but I am running RoboHelp 2015.

I have not used any sorting/filtering, am not using the Sort by Name feature, am the sole creator and manager of all RH projects, and have built and maintained everything locally on my hard drive.

I simply open up a project I have been working on and find that the topics have been rearranged.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 27, 2015 Oct 27, 2015

Copy link to clipboard

Copied

I haven't seen any other threads about this issue so all that is known is here.

Have you tried deleting the CPD file and seeing if it happens after that?

Are topics missing or just rearranged? Do you mean into different folders or just into a different order within the correct folder?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2015 Oct 27, 2015

Copy link to clipboard

Copied

LATEST

I haven't tried deleting the CPD file. I will if this happens again.

I dragged all of the topics back into their proper order (they are all in the same folder, none are missing), and so far so good.

Thanks,

Shoshana

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp