Highlighted

RoboHelp 2019 new UI - Glossary tab is blank after generating CHM.

New Here ,
Feb 28, 2019

Copy link to clipboard

Copied

In the new RoboHelp 2019, on the Author tab | Glossary, I have several terms and descriptions. On the Output tab | MS HTML Help | Content | Glossary, the name of my Glossary is selected. When I Generate Preset then preview the CHM, the Glossary is blank.

I tried generating the preset with "None" selected for the Glossary to see if the tab would just not display and do without the Glossary. But the Glossary tab still displayed.

Why is the Glossary blank or as another option, can I hide the Glossary tab from view in the CHM file?

Topics

HTML help, New UI

Views

612

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RoboHelp 2019 new UI - Glossary tab is blank after generating CHM.

New Here ,
Feb 28, 2019

Copy link to clipboard

Copied

In the new RoboHelp 2019, on the Author tab | Glossary, I have several terms and descriptions. On the Output tab | MS HTML Help | Content | Glossary, the name of my Glossary is selected. When I Generate Preset then preview the CHM, the Glossary is blank.

I tried generating the preset with "None" selected for the Glossary to see if the tab would just not display and do without the Glossary. But the Glossary tab still displayed.

Why is the Glossary blank or as another option, can I hide the Glossary tab from view in the CHM file?

Topics

HTML help, New UI

Views

613

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Feb 28, 2019

Copy link to clipboard

Copied

Hi there

Are you using the "new and improved" version 2019 or the 2019 "classic" version?

I suppose it really doesn't matter either way. Because a CHM is a CHM.

The functionality of the Glossary tab in a CHM file is entirely dependent upon a file named HHActiveX.DLL. There are now two different versions of this file. One is used when the 32 bit CHM viewer is opened and the other is used when the 64 bit version of the CHM viewer is opened.

Have you tried opening the CHM by simply finding it and double-clicking it? If not, I'd suggest that.

You may discover you need to register the HHActiveX.DLL file.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Feb 28, 2019

Copy link to clipboard

Copied

The video below may help as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 28, 2019

Copy link to clipboard

Copied

Thank you! That video was helpful and registering the dll(s) worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Dec 02, 2019

Copy link to clipboard

Copied

Rick, I tried to follow the instructions in the video, but when I right-click the Robohelp shortcut for Robohelp 19 Classic, I don't get a "Properties" option. So I went looking for HHActivex.dll in File Explorer, and couldn't find it anywhere. I did a Search in the Robohelp directory, and nothing came up. I've already made sure I can view hidden files, but I'm not seeing it anywhere.  

This project is old - it's been updated from several previous Robohelp versions, so it's already generated (if that's when the file appears). Whenever I generate it, I get the Glossary tab, but nothing displays. All the settings within the project window are in place. See the image below.

 

I tried creating a Glossary window (didn't work) then removing it (didn't work). I think the problem is that file. How do I get a copy of it to add to the project?

glossary1.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Captiv8r LATEST
LEGEND ,
Dec 02, 2019

Copy link to clipboard

Copied

Hi there

 

I just looked at my own machine. I found the HHActiveX.dll in this location:

C:\Program Files\Adobe\Adobe RoboHelp 2019\RoboHTML

 

I suppose it could vary, depending on what you have. You might begin by looking in that location on your own PC.

 

Cheers... Rick 🙂 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...