Highlighted

Sizing a popup

New Here ,
Mar 04, 2020

Copy link to clipboard

Copied

Hi have many, many graphics of toolbar icons set to 26 x 26 px. In my text, I want to link the text that identifies each icon so that a popup opens and the user sees the icon in the popup. When I add a hyperlink  to the text and then select custom-sized popup, I set the height and width of the popup to 30px, BUT, this works only for the height - the width refuses to budge below some pre-defined value that I cannot figure out for the life of me what it is even though my code view shows 30 px. I have attached a picture to demonstrate this. This is driving me buggy because (1) it shows the popup borders, which I don't and (2) it looks like crap in the output. I just want the icon to be displayed in what appears to the user's eye to be just the icon - i.e., not in any container that shows borders. Any thoughts of how to deal w/ this?

 

Moderator: Image added to body.

image.png

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

A solution was found to this problem thanks to some CSS3 definitions from Adobe.

 

See Item 12 on my site at http://www.grainge.org/pages/authoring/rh2019/using_rh2019.htm

 

TOPICS
New UI

Views

341

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Sizing a popup

New Here ,
Mar 04, 2020

Copy link to clipboard

Copied

Hi have many, many graphics of toolbar icons set to 26 x 26 px. In my text, I want to link the text that identifies each icon so that a popup opens and the user sees the icon in the popup. When I add a hyperlink  to the text and then select custom-sized popup, I set the height and width of the popup to 30px, BUT, this works only for the height - the width refuses to budge below some pre-defined value that I cannot figure out for the life of me what it is even though my code view shows 30 px. I have attached a picture to demonstrate this. This is driving me buggy because (1) it shows the popup borders, which I don't and (2) it looks like crap in the output. I just want the icon to be displayed in what appears to the user's eye to be just the icon - i.e., not in any container that shows borders. Any thoughts of how to deal w/ this?

 

Moderator: Image added to body.

image.png

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

A solution was found to this problem thanks to some CSS3 definitions from Adobe.

 

See Item 12 on my site at http://www.grainge.org/pages/authoring/rh2019/using_rh2019.htm

 

TOPICS
New UI

Views

342

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 04, 2020 0
New Here ,
Mar 04, 2020

Copy link to clipboard

Copied

Forgot to add - RH2019, Version 11

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 0
Adobe Community Professional ,
Mar 04, 2020

Copy link to clipboard

Copied

There's no way I can find to do that in RH, nor with the "User Assets" feature of the skins.

 

I can get the box to resize smaller by editing an output css file, but the content still doesn't display properly. I think changes are needed to content inside an iframe, which can't be done through regular css. Possibly you could edit the output javascript files each time you generate, if you know what you're doing, but I wouldn't recommend it.

 

You can report issues here: https://tracker.adobe.com/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 0
New Here ,
Mar 05, 2020

Copy link to clipboard

Copied

Thank you Amber!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 05, 2020 0
New Here ,
Mar 06, 2020

Copy link to clipboard

Copied

So, this is the reply that I received from Adobe: 

 

You can add the following CSS text in your CSS (Stylesheet) file being used in the topics:  

{code:java}

.rh-popover

{ min-width: 0 !important;

}{code}

It will fix the width issue with popovers in the output. 

 

I have added this to my css and it does NOT seem to make a difference but I cannot confirm completely because here is my issue - If a custom popup contains just text, then after I generate my project and preview it or actually open the output in a browser such as Chrome, the popup displays the text as expected. If a custom popup contains an icon, then in the Preview mode w/in Robohelp, it looks as I described above, but when I try to view the output in a browser such as Chrome or Mozilla, then the popup is absolutely blank - no image is displayed. The only way that I can get a custom popup to display an image is to have it in an auto-size popup or a frame, which is NOT a solution.

 

Thoughts?

 

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 06, 2020 0
New Here ,
Mar 06, 2020

Copy link to clipboard

Copied

And yet another issue that I have confirmed - 

 

Add a hyperlink to text in a topic and have that hyperlink point to another topic that also contains hyperlinks. The popup opens as expected and displays the correct topic, but the links inside the popup do NOT work - they are dead even though in the preview they work just fine. In the actual output that is displayed in a browser, they are dead.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 06, 2020 0
Adobe Community Professional ,
Mar 07, 2020

Copy link to clipboard

Copied

Re the dead links, is this what you want to achieve? If I have understood what you want correctly, then as you can see it is working for me. Tested in Edge and Firefox.

 

image.png

 

That was done in Azure Blue.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2020 0
New Here ,
Mar 07, 2020

Copy link to clipboard

Copied

Hi Peter no what I'm saying is this if I have text in a pop up and that text contains a hyperlink  Whether that hyperlink is to another topic or designed as a pop up to an icon so basically a pop up within a pop up, the hyperlink is dead in my popups I cannot get them to work if the popup contains only an icon and nothing else then I cannot get the pop up to display the icon the icon is not shown.  I will have to put a detailed list together and show you what I'm scene but hopefully this makes sense

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2020 0