Highlighted

The search string you typed is not valid.

New Here ,
Feb 01, 2018

Copy link to clipboard

Copied

I noticed some odd behaviour with the search recently. Any time you first search for a string containing a stop word, it doesn't return any result and instead displays the error message "The search string you typed is not valid."

If I then refresh the page or hit Enter again, the search results come up as expected.

I've tried creating a new project with only 2 topics and the same thing happens there. Even removing the stop words from the "Stop Words" list doesn't seem to do anything.

Any suggestions?

Thanks,

Simon

TOPICS
HTML5 layout

Views

466

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

The search string you typed is not valid.

New Here ,
Feb 01, 2018

Copy link to clipboard

Copied

I noticed some odd behaviour with the search recently. Any time you first search for a string containing a stop word, it doesn't return any result and instead displays the error message "The search string you typed is not valid."

If I then refresh the page or hit Enter again, the search results come up as expected.

I've tried creating a new project with only 2 topics and the same thing happens there. Even removing the stop words from the "Stop Words" list doesn't seem to do anything.

Any suggestions?

Thanks,

Simon

TOPICS
HTML5 layout

Views

467

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 01, 2018 0
Adobe Community Professional ,
Feb 01, 2018

Copy link to clipboard

Copied

Created with what version of RH and which layout? IIRC there have been issues with search stuff.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
New Here ,
Feb 01, 2018

Copy link to clipboard

Copied

I'm using RoboHelp 2017 version 13.0.1.279.

I tried outputting with both Indigo and Azure_Blue layouts and the same thing happens.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Adobe Community Professional ,
Feb 01, 2018

Copy link to clipboard

Copied

I think you're missing a patch - try updating and regenerating your test.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
New Here ,
Feb 01, 2018

Copy link to clipboard

Copied

We had the 13.0.2 patch installed and that's when we first noticed the problem. We thought it might have been an issue with the new patch so we rolled back to 13.0.1 but it wasn't the case.

I have no easy way to reupdate to the newer patch to make further tests unfortunately.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Adobe Community Professional ,
Feb 01, 2018

Copy link to clipboard

Copied

Well, I guess you could try rolling it back to the release version, but I suspect that it wouldn't make any difference anyway. So going forward is probably your best bet - here's the direct download link - Adobe - Support : RoboHelp Support Center : Service Releases

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
New Here ,
Feb 01, 2018

Copy link to clipboard

Copied

I don't have permissions to install anything on my work computer so that's why I said it's complicated to update the software.

Regardless, it seems to happen on other projects I was able to find online. For example, if I search for "code of conduct" on "Peter Grainge's Adobe RoboHelp Tour", I get the same error message.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Adobe Community Professional ,
Feb 01, 2018

Copy link to clipboard

Copied

The link broke so it is RoboHelp Tour

Are you getting exactly the same message in the RoboHelp Tour? The first time I searched I got a different error and then it worked. I'll be looking into that.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
New Here ,
Feb 01, 2018

Copy link to clipboard

Copied

Thanks.

Yes, I see the search string error:

Yeah, it only seems to give the error the first time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Adobe Community Professional ,
Feb 01, 2018

Copy link to clipboard

Copied

What browser are you using?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
New Here ,
Feb 01, 2018

Copy link to clipboard

Copied

I get the same thing in Chrome 63.0.32239.132 and IE 11.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Adobe Community Professional ,
Feb 01, 2018

Copy link to clipboard

Copied

OK. I see that in Chrome. Different message in Firefox.

I'll see if I can find out the issue with the tour tomorrow. I'm using RoboHelp 2017 though.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
New Here ,
Feb 01, 2018

Copy link to clipboard

Copied

Ah, ok.

I'm also using RoboHelp 2017.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Adobe Community Professional ,
Feb 01, 2018

Copy link to clipboard

Copied

Oops. Yes you said that. I had just been looking at a different thread and

had that in mind.

If you close the browser and go back later, do you still see the problem?

I have asked an Adobe contact to see if this a known problem. Also I'll

poke around some more tomorrow.

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
New Here ,
Feb 01, 2018

Copy link to clipboard

Copied

If I copy the URL with the search parameters and open it in a new browser, I don't see the error. Otherwise it happens every time I search for that term for the first time. Not sure if that makes sense.

Great, thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Adobe Community Professional ,
Feb 01, 2018

Copy link to clipboard

Copied

Yes I follow.

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Adobe Community Professional ,
Feb 01, 2018

Copy link to clipboard

Copied

The project I'm working on encountered this (RH11, Multiscreen HTML5 output).

The documentation I was left by the previous writer states:

"I have removed all 'stop' words from the project because they interfere with the 'Show results that include all search words' function on the search results page. e.g.

Test 1: 'of' in stop word list

1. In the search box type recency of practice.

2. Click Search. The search results include any topics that include either recency OR practice.

3. Tick the Show results that include all search words checkbox.

4. Click Search. No results are found.

Test 2: 'of' removed from stop word list

1. In the search box type recency of practice.

2. Click Search. The search results include any topics that include either recency OR practice.

3. Tick the Show results that include all search words checkbox.

4. Click Search. The search finds any topic that contains the exact phrase 'recency of practice'.

I'm not sure that helps, but at least you're not alone.

(I also haven't tried copy/pasting a link or searching multiple times to see if that makes a difference. I'll try to make some time shortly.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Adobe Community Professional ,
Feb 02, 2018

Copy link to clipboard

Copied

i have logged a bug as Tracker 1348.

Anyone else seeing this should add their vote to help prioritise it.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2018 0
LEGEND ,
Feb 02, 2018

Copy link to clipboard

Copied

But as I've seen elsewhere:

It's not who votes that counts. It's who counts the votes!

tdlhead.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2018 0
New Here ,
May 25, 2018

Copy link to clipboard

Copied

I'm having the same issue. I've just voted too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2018 0
New Here ,
Aug 08, 2019

Copy link to clipboard

Copied

I am running into the same issue using NOT. For example, if I type "link not working" i get the "The search string you typed is not valid." error message. It seems quite strange that this bug is not fixed. People use NOT a lot when looking at a help guide. It must be one of the top searched words...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2019 0
Adobe Community Professional ,
Aug 08, 2019

Copy link to clipboard

Copied

According to the Tracker, it's working in RH2019.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2019 0