• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

I am at my wits end with Stager

Contributor ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

I am going to have no hair soon from pulling it out by the root, trying to get Stager to work. I am pretty upset right now, so I take a deep breathe and attempt to lay this out as calmly as possible. Please know that I have been very patient for months now (since July?) as I have tried to make this application work.

 

this is what I have spent 4-5 hours in the last day trying to do. very simple: create a plane or thin box, add a glass material and apply a 4000 x 4000 psd decal to it, add a background and render. sounds super easy, right?

 

hours of render later and the decal looks to be 40 dpi...

 

- flatten the decal file and save as a png hoping that will change things. same super low resolution decal after hours of rendering. 

 

- remove glass material and try rendering again, same issue.

- resize decal to smaller and re-apply to object: same issue

- create new file, add 10" x 10": box with default material and apply decal: same issue  add a different decal: same issue

 

though out this process, I have also run into these issues: 

-switch to Render Mode and render button is not available. switch back to Design mode and the viewport is totally empty (like flat grey). click back on render mode and it will not switch. go to quit stager and selecting Quit Stager does nothing... have ot force quite (not an isolated time I have had to do this)

 

I was upset when Dimensions was discontinued because I had excitingly been using Dimensions since the very beginning, it had jumpstarted my use of 3d product "photography" and I was waiting, like all of us, for dimensions to mature into a full product. instead Adobe cancelled Dimensions and announced Stager (that looked suspiciously like Dimensions 2.0...)

 

I was upset at the totally separate (major) cost of the Substance 3d package as I mostly neeeded Stager, I shook it off and convinced myself that the investment would mean that I would have more control and there would be more focus on the development. I invested a lot of money in a full year of Substance... I just need Stager to work!

 

I have had nothing but problems trying to do the exact same things I did in Dimensions. In fact, I have not been able to complete one project in stager. I always have to revert back to Dimensions to redo what I had tried to do in Stager. and guess what? Dimensions doesnt really have an issue with the exact same things.

 

I had really hoped that MAX would bring relief for what I now consider a very early beta application in Stager, everyone knows that adobe updates everything at MAX... and nada.

 

I have yet to be able to apply one decal to an object in Stager and have it come out. ..Mocking up wine bottles with labels is one of the main things I use Dimensions/Stager for. Yes, I had to jump through hoops with Dimensions as it is really finicky about resolution of decals, but at least with trial and error, I can get around those bugs.

 

I have not had one session with stager that it didnt stop responding or the render stops at "estimating" for days, or the render button is not available or like today I have to force quite because there is nothing in the viewport. I have yet to be able to bring any dimensions file into Stager without it at some point telling me "A problem caused the application to stop working correctly" at which point the file is useless to work on even if rebooting. I have even removed the app and reinstalled with no difference.

 

As you all might be able to tell, I am very frustrated. If this was a beta program for an app that was covered under my CC fee, I would be a little frustrated, but understanding because BETA. But I have paid A LOT OF MONEY for what I was told was a full release application that has been only headaches. This should not be this bad.

 

I have given up on any of the many dream features I had wanted (like AMD GPU support) anytime soon,... but is there any hope of a major update coming soon that will alieve the bugs so we can actually any work? I am desperate at this point and yet again have to rebuild another project in Dimensions just ot get the project done after a 4-5 hour of unbillable time.

 

iMac 5k 27" 10-core i9, 128 DDR4, MacOS Big Sur, AMD Radeon Pro 5700 8 GB

Views

469

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

A year later and absolutly no resolution. No comment from Adobe. nothing. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 02, 2024 Jan 02, 2024

Copy link to clipboard

Copied

Bump! I'd like a comment from the Adobe team. I have these same problems with Stager. I'm using the latest version. Just updated today. It hasn't fixed the problems I have. I create models in Shapr3D CAD program... I can import them into Stager, I can apply materials, manipulate and position these models with no issues. HOWEVER... I try to add labels and what I get looks like something from out of Dr. Strange's Mirror Dimension... the label is popping in and out of the multiverse on the surface of the model with no rhyme or reason or way to fix it. And believe me, I've explored everything regarding settings. When I try to go another route and export the selected model's UV's... the map I get is indecipherable and I cannot for the life of me alter the label art to make the UV map function. You guys MUST make Stager more like Dimension... back when labels worked. You've had two years almost. WHAT'S YOUR BOGGLE?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 09, 2024 Jan 09, 2024

Copy link to clipboard

Copied

Hi Erik, Hello David (and sorry we missed your message back then),

 

To answer David first, I understand the frustration. I have been pulling my hair out too with Substance Stager, trust me. I think we can all agree Stager was tough to handle, especially in 2021. But to be fair, it is now a lot more easy to work with. Yes, there still are known bugs we're working on, but that's definitely not the same as in 2021. The mentioned decal issue is now solved, the render button is available, and quitting Stager should quit Stager.

However, I agree Stager is still not where we hoped it would be, and I understand that we lost the trust of many users.

 

Regarding your problem Erik, what do you mean by "when I add labels"? What are the labels you're mentioning? Do you have maybe a video or gif to share to understand the issue better? I'd also love to have one of your problematic 3D model file, so I can try to reproduce on my end.

Let me know.

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 09, 2024 Jan 09, 2024

Copy link to clipboard

Copied

I work for distributor of vaping products that occasionally sells its own house brands of disposable vape devices. On a few occasions, I've had to recreate the device in Shapr3D because the manufacturer sometimes wouldn't share their 3D model files. But I've had to be creative when applying label artwork on the models to match the real product. I'd double click on the mesh in stager to select the surface... and attempt to apply a graphic (label). I generally don't have an issue if the model came from the vendor... labels usually work on their models. (NOT ALWAYS!) But the meshes I export to OBJ or FBX from Shapr3D and bring into STager generates really weird UV files that are unworkable... or if I apply the label directly to the surface, I get that mirror-dimension effect I mentioned earlier... really weird results. I could try to assemble a demonstration for you and take some screen grabs.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 09, 2024 Jan 09, 2024

Copy link to clipboard

Copied

LATEST

So just to be clear, you're using the auto-unwrap feature? If so, an auto-unwrap heavily depends on the mesh topolgy. If it is really Low Poly, or doesn't have a quad workflow, the auto-unwrap can start having trouble. If the UVs are messy/overlapping, the decal system will obviously not work properly.

 

I don't know Sharpr3D, but it looks like an engineering tool, which usually build very not compliant topology for engines. Therefore, can we have a screenshot of the mesh's topology?

 

Regards,

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources