Questions
Recently active
I have the following working code but need to sort the list by a field (sortID) from my database (not a value from the directory)- How do I add this?- I tried adding "sortID" in below, but it doesn't have any effect?- sortID is a 3 digit varchar field in MySQL <div data-role="collapsible" data-collapsed="true"> <h3 align="center">Board</h3> <ul data-role="listview" data-theme="d" data-inset="true"> <cfset DirList = "C:\Inetpub\wwwroot\CRM\CCC\attachments\board\"> <cfset site = ("https://crm.domain.com/crm/ccc/attachments/board/")> <cfdirectory directory="#DirList#" name="qDir" action="list" sort="sortID DESC"> <cfquery dbtype="query" name="dirsOtherOnly"> SELECT * FROM qDir ORDER BY sortID DESC </cfquery> <cfoutput> &
Hi,We are using Enterprise version of Coldfusion10 with 3 instance.A maximum of 100 users is able to access the application with a little bit of slowness after which either the subsequent request hangs or becomes very slow until the requests of the first 100 users is completed and then the page loads.I would like to know how to increase the maximum number of simultaneous concurrent requests for a 64-bit coldfusion10 instance with a hardware specification of 8 virtual cores and 16GB RAM with 6GB RAM allocated for the JVM Heap size.Thanks,Karthikeyan K
Hi all,This is my code to download an excel file. <cfspreadsheet action="write" filename="#local.location#\#local.fileName#" query="local.qryResultset" overwrite="false" /> <cfheader name="Content-Disposition" value="inline; filename=#local.fileName#;" /> <cfcontent file="#local.location#\#local.fileName#" type="application/msexcel" reset="no" deletefile="yes" /> All my variables are passing fine. The process worked fine in firefox but in IE i have an issue (http or https), it shows an error at the time of saving the file: LOCALNAME20150922153304.xls might have been moved or deleted. It looks like IE is caching the name somewhere?Any ideas?We are using Coldfusion 10.Best,
I want to migrate and deploy an existing ColdFusion 9 application to ColdFusion 11 application. This application was developed in ColdFusion9 in Windows environment and we are trying to migrate to Linux environment to ColdFusion11. Initially we used IIS as web server but now I am using WebSphere as a web server. My Concern is in Windows we use to place the .cfm files (ColdFusion app) in wwwroot or inetpub root. But here I was not able to understand where to place the code. I installed ColdFusion in the following format: /opt/apps/apa/coldfusion11. Can any one suggest me with a link or step by step process. In Short Installing ColdFusion 11 in Linux Environment with WebSphere application server. In which folder do we need o place the code as I am very new to this Linux Environment I was really confused
The CFINPUT with the VALIDATE="integer" is not working properly at all. The user can enter 23,950 as the number. We would think this is OK but it won't work properly without stripping the ","The field:<CFINPUT TYPE="text" NAME="mynumber" VALIDATE="integer" MESSAGE="mynumber must be an integer">Then, when the value is passed to the SQL INSERT<CFQUERY....>INSERT INTO mytable(name, mynumber)VALUES(#'form.name#',#form.mynumber#)</CFQUERY>Coldfusion will take the value 23,950 and think that 23 is one field and 950 is another because of the "," Therefore it is trying to put 3 values into 2 fields and throw an error. Am I doing something wrong here or is this Coldfusion bug?p.s. in the MySql database, the "mynumber" field is defined as integer.
I have this weird thing happened to cfcontent. <cfheader name="Content-Disposition" value="attachment;filename=#LSDateFormat(now(),"mm.dd.yy")#.txt"><cfcontent type="text/plain"><cfoutput>test_1,test_2,test_3,timestamp#chr(10)#</cfoutput>This is what generated in the txt file. It generated the output which I want but also generated the default cfide scripts. How would I suppress and generate only the output stuff? Thanks.<script type="text/javascript" src="/CFIDE/scripts/cfform.js"></script><script type="text/javascript" src="/CFIDE/scripts/masks.js"></script><script type="text/javascript"><!-- _CF_checkheader_search = function(_CF_this) { //reset on submit _CF_error_exists = false; _CF_error_messages = new Array(); &n
Hello, all,I've got a page that contains an iFrame. When loading the parent via HTTP, the page loading in the iframe via HTTP can see session variables with no problem.However, when I load that same parent page HTTPS _and_ the iFrame via HTTPS, the iFrame src page does NOT see session variables set in the parent page.Both are loading HTTPS, both same domain, same port.Parent: https://www.domain.com/dbw/tt/index.cfmiFrame: https://www.domain.com/dbw/tt/contactus.cfmI'll check CFID and CFTOKEN on both, but I suspect they are the same. UPDATE: I can confirm that in my DEV environment, CFID and CFTOKEN are the same for both parent page and iFrame page.What could be causing this?V/r,^_^
After upgrading from ColdFusion 10 to ColdFusion 11, vertical scrollbars are now showing up in cflayoutarea.We use ColdFusion.Navigate to submit data and refresh a cfdiv that is inside cflayoutarea. Upon submission, the cfdiv shows the new data as expected, but the user must scroll down within the tab to view the data.I have tried setting the style height:100% on both cflayout and cflayoutarea. I have also tried overflow: visible. I also tried the overflow attribute of cflayoutarea, but this is ignored.Any help would be appreciated.Thanks,Ron
Earlier versions of CF didn't let a comma slip through to mess up SQL statements. This version does. Not only that, but the javascript code in cfform.js, if extracted and run separately against a <form..>..</form> rather than a <cfform..>..</cfform> does trap and reject commas. By the way this is true of validate="date", and validate="float" also. I submitted a bug report on 9/14/15 and have had no response so far. I notice that there were reports of this on this forum back in 2014. Any thoughts other than abandon cfform?
I mistakenly installed 32 bit version. Can I just rerun install with 64 bit version?
Hi there Does any one have a fool-proof document for creating and proving a 2 server ColdFusion 10 cluster? Most of the documents I have found are missing something. More specifically, what is the difference between HTTP Port and Admin Component Port in the remote instance manager?Should the Cluster Manager show anything on the remote node?Is there a cluster monitor that show's its state? Is the there a simple test to prove it works. If this is in the remote node server.xml <Engine jvmRoute="cfusion" name="Catalina" defaultHost="localhost">should the jvmRoute value in the Instance Manager should be set to cfusion?Thanks for your helpRichard
Hello, all,I'm fairly confident that this is related to my recent posts about SESSION and iFrame. I'm just not sure how to fix it.I have been working for several months on this project; but I only recently discovered that there are differences in CFAdmin between our dev and production environments. Production is much more restrictive.SO.. I bit the bullet, and set J2EE sessions to enabled; I set setDomainCookies to 'yes'; and enabled "Use UUID for cftoken" (that is what we have in production.)Suddenly, the forms that I've been working on for months (that submit form data via jQuery AJaX) are breaking. All of them. FireBug says that "JSESSIONID has changed". Well, duh, that's supposed to be a security feature.Is there a way to submit form data via AJaX without undoing any of the settings I outlined, above?Vr,^_^
Is there a alternative to using IP Addresses for Debugging in CF Admin?Our IP Addresses are changed regularly, so can I use computer name?
After installing ColdFusion 11 Enterprise Evaluation then upgrading that installed version to a paid licensed version, we cannot get the Web Server Configuration Tool to work. This is on Windows Server 2012 R2. All updates are installed on everything.This tool was just fine before we upgraded. It opens but it is empty. We cannot see any sites associated with it so we cannot active new sites.When any .cfm file other than the default document is run on the new site (and the new site not updated with the Web Server Configuration Tool), we received this error:"HTTP Error 404.2 - Not FoundThe page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server."This seems as though it is because we upgraded from the trial version to the licensed version (In CF Administrator, New License).The 'Instance Manager' in CF Admin has the 'Name" still set to 'cfusion' and it is the only instance. We changed nothing here, in face, nothing has been ch
I have a page table that includes navigation IDs, catID, subcatID, I use an inner join for the tables.Tables:pagescategoriessubcatI have added subSubID for a third level on the nav menu. How do I add the fourth table to the cfquery?I want to add: inner join subSubcat on pages.subSubID = subSubcat.subSubID to the table below.<cfquery name="getPages" datasource="#application.database#">select *from (pages INNER JOIN catagories ON pages.cat_id = catagories.cat_id)inner join subcat on pages.subID = subcat.subIDWhere catagory = '#title#'order by pages.subID asc, pages.ordID asc</cfquery>
We installed ColdFusion 11 Enterprise Evaluation (Trial) but would like to buy ColdFusion 11 Standard to use on the same Windows Server 2012.Will we need to reinstall ColdFusion 11 Standard or will the license key/serial number work on the currently installed ColdFusion 11 Enterprise?I assume all we'll need do is enter the purchased CF 11 Standard key into the CF Admin"New License" box want to be sure first. Can't seem to reach Adobe to answer this.
Hi All,Arabic charaters are not displaying correct when migrate data to oracle DBit is showing correct when inserted from formplease let me know any settings needed for arabic display????Server info : ColdFusion 11 entDB : Oracle*** pls find screen attachedThanks in Advance
Coludfusion9からColudfusion11へのマイグレーション評価で、OS Redhat 6.5にColudfusion11評価版をインストールしました。 インストールは、特に問題はありませんでしたが、起動すると、下記のログが出力されて正しく起動しません。 何方か原因と対応をご存知でしたら、教えて頂けますと助かります。---------------------------------------------------9 8, 2015 19:24:58 午後 Information [localhost-startStop-1] - logging を開始しています...9 8, 2015 19:24:58 午後 Information [localhost-startStop-1] - license を開始しています...9 8, 2015 19:24:59 午後 Fatal [localhost-startStop-1] - tmiph-web2:tmiph-web2: unknown error9 8, 2015 19:24:59 午後 Error [localhost-startStop-1] - License サービスを初期化できません : coldfusion.server.ServiceException: tmiph-web2:tmiph-web2: unknown error9 8, 2015 19:24:59 午後 Information [localhost-startStop-1] - crypto を開始しています...9 8, 2015 19:24:59 午後 Error [localhost-startStop-1] - Cryptograpicサービスを初期化できません : java.lang.NullPointerException9 8, 2015 19:24:59 午後 Information [localhost-startStop-1] - securityを開始しています...09/08 19:24:59 [localhost-startStop-1] ERROR Unable to set localhost.This prevents creation of a GUID. Cause was: t
I'm currently in the progress of moving from a CF9 server to a CF11 server, but have run into a huge performance difference between the two, when sending e-mails.Our application generates approximately 40,000 e-mails nightly, and spools the messages to disk, for delivery to out mail server.On the CF9 server, it will spool approximately 20,000 messages in an hour to our mail server, but on the CF11 server, the best I can getis approximately 800 messages an hour. Are they any hidden parameters that I can configure to increase the speed of sending mail onCF11?Thanks,Evan
I have an object that I use to process address information. Currently I'm instantiating per request, however, I'd like to move that into an application scope. My concern is that somehow this will adversely affect the my request or session level scope or that somehow if multiple requests occur that the request/session will crosswires somehow.
Hello, I have been trying to get websockets working in our CF 11 update 6/IIS8 server to no success. I would love to use SSL, but as part of my testing I have even tried non-ssl with no luck. The instructions I have followed are these, Using WebSocket with ColdFusion 11 | Adobe Developer Connection.Using Chrome I see that I receive this for standard proxy configuration on a non-SSL connection, "Error during WebSocket handshake: Unexpected response code: 200." This does show as a ws connection. If I configure the builtin server and use SSL the error is WebSocket connection to 'wss://name.of.server:8543/cfusion/cfusion' failed: Error in connection establishment: net::ERR_TIMED_OUT." The name of server is correct just removed here since I've been testing at times without firewall to eliminate that problem. I don't get where the cfusion/cfusion is derived from however. I am not sure why it isn't using cfws there that the non-ssl ones do. Port 8543 is open (even when the firewal
Good day. Installed coldfusion10 on suse linux13.1 running apache 2.4.6. When I created the web server connection using ,/wsconfig everything worked. However after restarting apache I know get an error with /wsconfig /1/mod_jk.so :undefined sysmbol : ap_log_error. I am not able to get apache running (rsapache2 start). Any help would be great. John
Hi,I need to install Coldfusion 10 developer edition for my project, please share the download link.Thanks in advance.Regards,Ankit
Hi,I recently installed Update 17 on our Coldfusion 10 development server. Since this server is behind a firewall the auto updater won't work and we need to download the jar file and run it manually. Usually we also end up having to temporarily rename coldfusion.exe in the bin folder. In the past this has worked fine and then when we do the production server the updater works as it should.For Update 17 however, the coldfusion application server service would not start after the update installation. However, if I swap out the newer coldfusion.exe (8/27/2015 8:08am 426k) for the previous version (4/9/2015 6:29AM 533k) then I can start the service and the site seems to run fine.My questions are 1) Why does it not work with the newer coldfusion.exe, 2) is this a valid installation which addresses the issue the update was meant to address if I'm using the older .exe or does it not matter?Anyone else have a similar experience?Thanks!
hi, i have run into an unusual behavior when invoking web services.i am calling a web service that returns an XML like this:<children> <child> <firstname>john</firstname> <lastname>doe</lastname> </child></children>when invoking this web service from CF10, it works just fine. However, when invoking from CF11, i only get this: <child> <firstname>john</firstname> <lastname>doe</lastname> </child>no <children>? for some reason, CF11 ignores/hides the topmost XML level. this doesn't happen on previous versions. why? the server that hosts the web service is CF11 too.
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.