Questions
Recently active
is there only one CD for ColdFusion for both 32 and 64-bit?
Hello, everyone,Another developer that I am working with is working with a form that has start and end dates. He'd like to be able to use custom JavaScript validation to make sure that not only are the dates in proper format (that part of the JS is working fine), but that it will also check to make sure that the start date will always be prior to (or equal to) the end date, and will throw an alert if the end date is before the start date.I've Googled for this, and am finding informative suggestions on just making sure the date is in the right format, or falls within a certain range, but nothing on how to make sure that one date is before (or less than) another.I'm guessing that data binding might be a part of it. Can anyone suggest how to set these fields so that each has a validateat="onblur" that will check both values?Also, as a related issue, he has the CF datepicker working as far as entering the dates, but since the field doesn't get/lose focus on this, how do we trig
I don't expect much luck at getting a reply here but here goes.. After having problems with one of the CF10 updates running under IIS 7 there was a 'Service Unavailable' (503) error message from the Tomcat server showing on all the sites we run. What we want to do is set up a system where IIS takes over if CF goes down and shows a nice error message which is different on each site. Alternatively a way to easilly switch IIS from using CF to point each site to another local site while the CF server is down.Any suggestions?
We have conytracted a company to build our company a mobile app. They want me to create a web service that will authenticate users. They will pass a username and password via URL. They arte expecting me to return either:HTTP/1.1 403 ForbiddenConnection: closeif the credentials are invalid orHTTP/1.1 204 No Contentif the credentials are valid.How can I do this after performing a CFquery on my user's database?
Here are the details:I have a Chef CF11 cookbook, and a site cookbook that uses it.If I use this site cookbook on a Ubuntu VM, CF11 runs ver quickly after install.However, if I run this site cookbook in a Docker ubuntu instance, CF11 it takes about 12 minutes to actually fully boot. I tailed the colfusion-out log (it started at 3:38 and ended at 3:50)Any ideas?
Just about every 2 - 3 days, we'll get a blank page instead of our index.cfm. At this point, we cannot reach any .cfm page, even by typing in the direct URL. The only thing that will bring it back is a restart of the server. We are running ColdFusion 10 Update 12 with IIS v. 8.5 in Windows Server 2012. We had updated to 14, but we couldn't get it to work. Nothing but 500 errors. Uninstalling 14 was impossible so we uninstalled CF entirely and reinstalled up to update 12. However, the "blank page" issue still exists. One other thing. When the "blank page" appeared this last weekend, and we didn't have time to restart right-away, ColdFusion began working again, on it's own, within a few hours. We found absolutely nothing in the CF logs or the server logs. Any guidance, opinions or sympathy is welcome. Thanks!- Shawn
Just like the title asks... is there a simple way to download the hotfixes and updates for CF11?I visited the adobe site, click link after link which led to a broken URL for a blog. Isn't there just a list and a download link available? I need to use them for a Chef script to apply via terminal.
So, I used the updater in CF Admin to apply the latest patch (14) to CF10. Afterwards, I rebuilt my web server connections. This is a process I've done dozens of times. However, this time around I've lost the ability to get to my CF Administrator....but all my sites are running just fine! I just can't access the Administrator! I've removed/recreated the connectors and restarted IIS/CF 3 times. Same thing.Everything about this server was running fine up to now. It is Win 2008/IIS7I'm getting the dreaded IIS HTTP Error 500.0 - Internal Server Error:ModuleIsapiModuleNotificationExecuteRequestHandlerHandlerISAPI-dllError Code0x00000000Requested URLhttp://mywebsite:80/jakarta/isapi_redirect.dllPhysical PathD:\My_Web_Sites\config\wsconfig\2\isapi_redirect.dllLogon MethodAnonymousLogon UserAnonymousI have 2 other identical servers that I have yet to update so they continue to run fine. I've been referencing each of them to see if the
I got an update message from ColdFusion 10.I got failed error message to download "failed signature verification"Can you please advise where to check it?Your help and information is great appreciated,Regards,Iccsi,
We tried installing the update to CF10 update 14 to our live server today after it worked ok on the dev server.The update killed the server, which seems to be because of permissions problems and not being able to overwrite the files....So we rolled back the files in the Coldfusion10 folder back to the prvious nights backup and the server sprung back to life....Except that the CFHTTP tags all fail with the following message. org.apache.http.impl.client.DefaultHttpClient.execute(Lorg/apache/http/client/methods/HttpUriRequest;)Lorg/apache/http/client/methods/CloseableHttpResponse; null Anyone got any idea how to get it wokring again?
I have created a chart in coldfusion 11 and when clicking on it I want to send the value $ ITEMLABEL $ to another page but sent only as a label anyone knows how to send the values ?
We're seeing a large number of SEVERE errors in the logs since updating to CF11,0,02,291725. Always in the following pairs. CF is now crashing about every 10-15 minutes.We're running on Ubuntu, with external JRE. I reviewed all of SEVERE: The web application [/] created a ThreadLocal - but the errors are slightly different, and notably, a new version of Coldfusion.Nov 03, 2014 1:52:41 PM org.apache.catalina.loader.WebappClassLoader checkThreadLocalMapForLeaksSEVERE: The web application [/] created a ThreadLocal with key of type [com.sun.xml.bind.v2.ClassFactory$1] (value [com.sun.xml.bind.v2.ClassFactory$1@30124fd9]) and a value of type [java.util.WeakHashMap] (value [{class javax.xml.bind.annotation.W3CDomHandler=public javax.xml.bind.annotation.W3CDomHandler()}]) but failed to remove it when the web application was stopped. Threads are going to be renewed over time to try and avoid a probable memory leak.Nov 03, 2014 1:52:41 PM org.apache.catalina.loader.WebappClassLoader checkThread
Is there a way to insert a hidden field using cfform, cfgrid, and cfgridupdate?
My question, using coldfusion 11 enterprise datasource gui,how do you connect to oracle 12c multitenant database,when you need to log into a pluggable database, beneaththe container database?What's the connection string, or is it even possible to connect(?) because earlier versions of oracledidn't use multitenant architecture, you just make a user/password,grant connect privileges, and connect.Using Oracle Linux 6.5 64bit.This is assuming I can connect to the oracle CDB (container database) and PDB (pluggable database) from the shell using sqlplus.<!------------------------ I can tsnping the pluggable database name pdb1 ---------------------------------------------->[oracle@localhost ~]$ tnsping pdb1TNS Ping Utility for Linux: Version 12.1.0.1.0 - Production on 27-JUN-2014 12:13:12Copyright (c) 1997, 2013, Oracle. All rights reserved.Used parameter files:/u01/app/oracle/product/12.1.0/dbhome_1/network/admin/sqlnet.oraUsed TNSNAMES adapter to resolve the aliasAttempting to c
For some reason Adobe is no longer supporting ColdFusion in the new Dreamweaver CC 2014. CF comments are no longer are highlighted in the code view. In fact CF is not listed among applications, although PHP is. Is Adobe planning on abandoning CF?
I am creating my first RESTful cfc which will allow a legacy system to interact with a more current system. There are some "configuration" variables that need to be available to a couple of functions in the cfc. These variables are mainly for disk paths and an API key. What is the best practice for setting these variables in my RESTful cfc? Should I just declare them at the beginning of the component outside the functions in the variables scope? Do I need an init function? If I use an init function how does it get called when the other functions are only called via REST?
I installed coldfusion 10 , at the end of insatallation process , it said coldfusion installed with errors and said to check coldfusion log file for error and didn't launch administrator.Here's the content of C:\ColdFusion10\cfusion\logs\coldfusion-error.log :3 Nov, 2014 5:15:46 PM org.apache.catalina.core.AprLifecycleListener initINFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\\ColdFusion10\\cfusion\lib;C:\\ColdFusion10\\cfusion\jintegra\bin;C:\\ColdFusion10\\cfusion\jintegra\bin\international;C:\\ColdFusion10\\cfusion\lib\oosdk\classes\win3 Nov, 2014 5:15:47 PM org.apache.coyote.AbstractProtocol initINFO: Initializing ProtocolHandler ["http-bio-8500"]3 Nov, 2014 5:15:47 PM org.apache.coyote.AbstractProtocol initINFO: Initializing ProtocolHandler ["ajp-bio-8012"]3 Nov, 2014 5:15:47 PM org.apache.catalina.core.StandardService startInternalINFO: Starting service Catalina3 Nov, 2014 5:
We installed a new CF11 server on a win2008 with iis7. the .Net ver is v2.0.50727We have this code :<cfobject type="dotnet" class="System.DirectoryServices.DirectoryEntry" assembly="#dllPath#" name="site">to allow us to contact to the IIS directory to later create a Virtual Directory on it.On the prev CF9/2008/iis7 /.net v2.0.50727 this worked great.ON the new server I get this error :Ensure that the DotNet agent is running and you have provided the correct host and port information-DotNet Side does not seem to be running.We made several checks to make sure that the .NET integration with CF works - and it seem to be installed and running ANY suggestions will be highly appreciated Thanks
I think the helpx.adobe.com tutorials can potentially be very helpful, but I can't find the accompanying files that the trainer keeps referring to. Where are they??
I have been reading about gateways and want to build a new CF11 application to use it. What I want is that my application can comunicate with operators in the field, two ways, realtime, so that every operator has his own personal postbox. Is this possible?
Hi,I went through the install of ColdFusion 11 with no issues, but when I try to go to the admin nothing! The problem was there was no CFIDE folder in /Library/WebServer/Documents. I choose the developer version of the install. I tried to use the uninstaller application, but it does not launch and doesn't work. So now I am stuck with ColdFusion being half installed. Also nothing was written to the httpd.conf. I did make the change so index.cfm to work. I tried (even though I didn't think that it would work) copied the CFIDE folder from cfusion/webroot and put it in /Library/WebServer/Documents, but it just downloads the index.fm file.So another problem I have, what do I have to manually write to the httpd.conf file?Also, what I am trying to do is to make a host on my Mac, I have the license for ColdFusion 11. I went with the developer option as I am learning and want RDS. The only reason I am doing this is so my classmates can see my applications.Thanks so much for any help!Johnny
So our credit card processing started generating an error out of the blue on October 28th between 3pm and 10pm ET. Last successful transaction 3:14pm then failure from 10:50pm onward. We deal with Chase Paymentech and apparently 4 other merchants experienced the same problem, same error, same time frame. This is the error:An error occured while Parsing an XML document. Content is not allowed in prolog. The error occurred on line 66For us on line 66 is: <cfset myXMLDocument = XmlParse(#objGet.filecontent#)> We do some filtering beforehand:<cfscript>function stripHTML(str) {return REReplaceNoCase(str,"<[^>]*>","","ALL");}</cfscript>This has been working since 2009 no problem, and we haven't changed a thing. We host on Black Iron/Rogers in Canada. I'm not sure where the other merchants host.Paymentech is saying it's a Coldfusion problem, Rogers is saying it's an XML problem. We're caught in the middle. Reaching out here for some help.Has Coldfusion pushed an upd
Hi folks...I'm being driven crazy by this seemingly simple task.I have 4 selectboxes, each AJAX-driven, grabbing items from a database, and then populating the next box in turn. Once a submit button is clicked next to the set of dropdowns, the information in the boxes are sent to a processing script where session variables are set and returned.They all preload by default. They all properly load the next dropdown as you'd expect.The problem is, I've found that if none of the boxes are touched and the default values are left, an error occurs when the submit button is clicked, and after dismissing the error popup, the 4th box becomes empty. This only happens if the 4th (last) dropdown is left to its default value. Once any other value other than the default one is selected, everything works as expected.The error:Bind failed for select box Transact, value and/or display attributes must be specified on the cfselect tag when binding to a query.The form:<tr><t
Do you have experience changing your application from CF8 and Flash/Flex to only CF? If so, how do you replace the Flash/Flex part? Any experiences to share?
So I've been fighting this for days. I dont have the slightest idea where I can go from here. I have your standard coldfusion insert queries set up to insert new data into the database. Something along the lines of:Select * from table where tableuniqueID = Form.UniqueID Cfif databasecheck.recordcount EQ 0, then insert new row with form.uniqueID as the uniqueID. Well recently, its been throwing the generic Violation of PRIMARY KEY constraint 'PK__OLMS_Dat__9C04DA075F0A3F61'. Cannot insert duplicate key in object 'dbo.table'.I dont understand that in the slightest, the only way it inserts is if the query right above it is defined and equal to 0 recordcount.I did some tooling around, and found someone suggesting to insert into my SQL "IF NOT EXISTS" to have SQL do the actual check to see if data exists. Well we put that in place, and just recently, ANOTHER duplicate happened, same error, cannot insert duplicate showing the new S
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.