Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Acrobat scrolling is incredibly laggy and slow

Community Beginner ,
Oct 06, 2019 Oct 06, 2019

Copy link to clipboard

Copied

Hello,

 

For the last two years I have had consistent problems with Acrobat Pro DC being extremely slow/stuttery while scrolling, highlighting, commenting on a document. This happens no matter what the size of the PDF is from less than 1 MB to 10+ MB. It appears to be very poorly optimized compared to other professional software titles which all run smoothly on macOS: Word, Excel, Pages, Numbers, etc. I have tried deleting the prefernce files outlined in other topics, which did nothing to alleviate the issue at all.

 

My computer is a relatively powerful: 2016 15-inch MacBook Pro connected to an eGPU with Radeon RX 580 and an LG 4K monitor (more than enough power to edit PDFs). I am running the latest version of Adobe Acrobat Pro DC and macOS Mojave and have never seen these issues alleviated by two years of updates.

 

Given the cost of this software, I would really appreciate some help from Adobe's support team, as well as an indication that they are planning on doing something about what is clearly an egregious lack of concern over glaring optimization issues. Having spoken with other macOS users (I work in I.T.), this is not merely an individual user issue but a broader problem plaguing Adobe Acrobat in general.

 

P. S. I have disabled the Show Online storage while opening and saving files, as suggested in other threads to no avail.

TOPICS
General troubleshooting

Views

36.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , May 04, 2020 May 04, 2020
Here's what finally worked for me:  Switch to Read Mode (Ctrl-H).  It scrolls the way you expect it to in this mode.  But it gets better... hit  Ctrl-H again to get back to the normal view, and like magic, scrolling is now fixed!!

Likes

Translate

Translate
Adobe Employee ,
Oct 07, 2019 Oct 07, 2019

Copy link to clipboard

Copied

Hi There,

 

Thanks for reaching out. As described above, you are experiencing issues with Adobe Acrobat DC while scrolling, correct?

 

What is the version of the application? To check the version please use the help link  - https://helpx.adobe.com/acrobat/kb/identify-product-version.html

 

Check for any pending updates and try updating the application to the latest version 19.12.20040. Go to Help > Check for Updates. To know more about the latest version please use the link  - https://www.adobe.com/devnet-docs/acrobatetk/tools/ReleaseNotesDC/index.html

 

Is this a behavior with a particular file or with any PDF file you try to scroll?

 

Please try the following preference settings and see if that works for you:

 

  • Go to Edit (Windows), Adobe Reader / Adobe Acrobat DC (Mac) > Preferences > Page Display >Select Single Page Continuous under page layout.
  • Go to Edit (Windows), Adobe Reader / Adobe Acrobat DC (Mac) > Preferences > General > Select Auto-detect for Touch Mode and Scale for screen resolution.

 

 

Let us know how it goes

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 07, 2019 Oct 07, 2019

Copy link to clipboard

Copied

As I stated in my original post, I'm using the latest version which is 2019.012.20040 and this happens with all PDFs files regardless of size.

 

I do see a slight improvement using Single Page Continuous, however I don't see this as a solution as Enable Scrolling is more much intuitive when trying to read dense scholarly journals. For example, trying to scroll down to the end of a page without it jumping to the next page is near impossible with your interface. More importantly, paragraphs that are spliced by page breaks make it impossible to reference what was said a few sentence ago, if the paragraph is divided by said page break. In layman's terms, I cannot see the end of one page and beginning of the next in this mode, which makes the difficult subject matter of what I'm reading even more arduous.

 

Do you have a more practical solution? Maybe Adobe could address the core functionality of the Enable Scrolling feature so that it is viable? Perhaps an update that addresses the general performance of Acrobat, since almost every other PDF annotator on the market seems to run smoothly by comparison. Adobe Acrobat offers some core features that make switching to other software impractical, so it would be nice if that $15/month ($180 annually) actually went to optimizing such an expensive product.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2019 Oct 26, 2019

Copy link to clipboard

Copied

Well, through my own research I've managed to surmise what the issue is with Adobe Acrobat Pro DC for macOS. In 2006, Adobe added 2D Graphics Acceleration for the Windows version of Acrobat, as outlined by this article. https://techreport.com/news/11433/adobe-reader-gets-gpu-acceleration/

 

More than 13 years later, Adobe still has not implimented this for macOS, as seen in this user guide:

https://helpx.adobe.com/acrobat/using/viewing-pdfs-viewing-preferences.html

 

As I stated before, using an annotated PDF in Adobe Acrobat Pro DC causes lag and delays sometimes in excess of 10 seconds, while the document catches up to the input from keyboard and mouse activity. This happens with scrolling, searching, and commenting/hightlighting documents on an almost constant basis. It happens at all document sizes from less than 1 MB all the way up 10 MB PDFs. While watching Activity Monitor in macOS, CPU History shows massive activity, while all of the GPUs in my machine (both internal and eGPU) remain idle.

 

I can then open that same document in competitive software like PDF Expert and experience perfectly smooth scrolling, commenting, and searching, interacting with the document with ease. While doing this, Activity Monitor confirms the programs utilization of both CPU and GPU functionality, confirming the complete lack of GPU ultilization in Adobe Acrobat.

 

This is wholely unacceptable for Adobe's flagship product, and I suspect Adobe knows full-well about this but don't want to devote the resources to modernizing Acrobat. They do so while continuing to charge $15 per month for the privledge of their software... far more than there competitors.

 

Should I even assume these optimizations are coming some day, or should I just switch to competitor? Your blatant disrespect for your customers is to be quite honest, appalling to say the least.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2019 Oct 26, 2019

Copy link to clipboard

Copied

Hi,

 

I noticed that at the time of your prior post you mentioned that you updated your Acrobat to the latest.

 

Yet, during this same month three more updated has been published since 15th of October.

 

There were security fixes and a lot of bugs fixed , to include support for the latest Catalina version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2019 Oct 26, 2019

Copy link to clipboard

Copied

Thank you, but I always check for updates and can confirm I am again using the latest version again, 2019.021.20049. As well, this is by no means a new issue, but one that has persisted for the entire time I have used Acrobat for mac. It has become more noticeable as PDFs have become a large part of my workflow, where as before they were used only on occassion and mostly for reading purposes only.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2019 Oct 26, 2019

Copy link to clipboard

Copied

Create an issue in tracker.adobe.com

 

Or utilize user voice instead of these user forums to report a bug:

https://helpx.adobe.com/x-productkb/global/how-to-user-voice.html 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2020 May 02, 2020

Copy link to clipboard

Copied

I am (and seemingly tons of other people) are having this problem still. I seriously can't believe that this issue hasn't been addressed. Now I prefer to open all my PDFs in Mac's Preview! Thanks, Adobe for helping me want to use another product.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2020 May 02, 2020

Copy link to clipboard

Copied

Hi,

 

I think this may be resolved by modifying a registry or Plist (lockable preference) for the  rendering speed during scrolling or zooming.  See note taken from the Enterprise Toolkit Preferences Reference:

.
bSuperFastDrawing - Specifies whether to use fast, low resolution intermediate representation during scrolling, zooming, etc.

 

This is found in this link: https://www.adobe.com/devnet-docs/acrobatetk/tools/PrefRef/Windows/AVGeneral.html?zoom_highlight=scr...

 

See in my slide below an important observation though:

 

superfast.png

 

The other issue with non-lockable preferences is that, even if you manage to customize a deployment of Acrobat like this, it may be possible that with every future update this preference will revert to its Superfast Drawing default state, which is always enabled. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2020 May 02, 2020

Copy link to clipboard

Copied

Correction to the information highlighted in my slide above.

 

Non-Lockable means that this preference can be modifiied by the current user. So that Adobe Acrobat customization wizard idea may or may not work if this is the case.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Here's what finally worked for me:  Switch to Read Mode (Ctrl-H).  It scrolls the way you expect it to in this mode.  But it gets better... hit  Ctrl-H again to get back to the normal view, and like magic, scrolling is now fixed!!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Hey that's great! Thanks for sharing your feedback.

 

Don't forget to mark your answer as correct answer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Now that you mentioned that, check this other discussion:

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2021 Jan 31, 2021

Copy link to clipboard

Copied

Wow! Can't believe that worked!

Scrolls wonderfully now, at least by comparison. Plenty good enough to work with. I have a $2,000 ThinkPad (forgive my ignorance, I don't know anything about computer hardware) and a samsung ~31" monitor and this ctrl+h trick worked the same for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 14, 2021 Aug 14, 2021

Copy link to clipboard

Copied

Nice hack. But doesn't completely solve the problem on my Acrobat Pro DC on Windows 10, unfortunately.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
11 hours ago 11 hours ago

Copy link to clipboard

Copied

LATEST

I love you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 22, 2020 Jul 22, 2020

Copy link to clipboard

Copied

Hi All, 

 

Thank you for reporting this issue.

 

We see that this has been an ongoing issue and long-tailed.

We have tried to replicate this issue on our end. However, the issue cannot be reproduced in-house. That is why we need a few details for further investigation on this. It would be helpful if you can share the following information:

- Please share any sample PDF on which the issue can be reproduced.

- If possible, share the screen recording of the issue occurring on your end.

- Application (https://helpx.adobe.com/acrobat/kb/identify-product-version.html) and OS version used on the machine.

- If you are using the Windows machine, please collect the Process Monitor logs. Download the Process monitor tool from this link: https://labs.adobe.com/downloads/acrobatmonitor.html on your machine and run it. Then reproduce the issue and save the logs. Share the logs with us.

 

We will be waiting for your response.

 

Regards,

Meenakshi

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2020 Sep 18, 2020

Copy link to clipboard

Copied

I also am having this issue. I am a lawyer and often have 3 or 4 large PDFs open on the screen. I often highlight a few lines/ paragraphs. I've noticed recently that laggy scrolling is becoming a really big problem - sometimes several seconds pass between moving the wheel on my mouse and the screen finally juddering down to where it's supposed to be on the PDF. 

Very surprising that Adob cannot replicate this problem in-house. I'd have thought all you need to do is get any PC and start opening a few big PDFs and highlighting etc. 

I have wondered if the issue is caused in part by high-def screens. My laptop has a 2560x1440 screen, so the processor has a fair bit of work to do to keep PDFs sharp when they're moving around. But I think really the issue is with Adobe Acrobat, not the computer - it is a fairly recent i7, with 16GB Ram.  

I think Adobe need to look into this problem in more detail. I have already become so frustrated that I am trying alternative PDF readers. They do not seem to render PDFs quite as sharply - but they certainly scroll more smoothly. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2020 Jul 24, 2020

Copy link to clipboard

Copied

No, on Mac it is NOT FIXED! I am a CC-subscriber, but for reading PDFs I am using Apple Preview because the stuttering choppy scrolling of PDFs is unbearable on an iMac with a Radeon Pro Vega graphic card. Latest version, all accessibility features turned off… 

In Preview scrolling through pages is smooth as butter, in Acrobat the page jumps in 40 pixel jumps or more…

It's rididulous. ADOBE, show some love to the Adobe Acrobat on MAC!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 14, 2020 Aug 14, 2020

Copy link to clipboard

Copied

Same here. I'm not hoping this will be fixed soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 27, 2020 Sep 27, 2020

Copy link to clipboard

Copied

Same here, on a Macbook Pro 2019... On my five year old Windows computer it runs smooth.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 05, 2020 Oct 05, 2020

Copy link to clipboard

Copied

I'm on a 2016 Macbook Pro, but same issue - just trying to scoll and navigate a relatively short pdf is a misery. Scrolling is very difficult, jumpy.

The same pdf opened in 'preview' can be smoothly navigated. Also Acrobat Pro DC on Windows works fine too.

For me acrobat reader DC is unusable on macbook, which is quite astounding when it attracts a premium price.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 25, 2020 Nov 25, 2020

Copy link to clipboard

Copied

My solution might work for you too!

 

Context - Very slow PDF scrolling, whick become Painfully slow when screensharing over videoconferencing.  

Hardware - MacBook Pro 16 (top specs)

Software - Adobe Acrobat Pro 2017 (version 2017.011.30180) on macOS Catalina (version 10.15.7)

Solution - which work for my configuration...

 Under Acrobat preference;

 Categories: choose display (left scrolling pane)

 1. On the right side of the pane Resolution offers two choices (system OR customized resolution)

 2. CHOOSE: customized resolution and in the FIELD for Pixels/inch (or mm) you need to increase this...

 3. I took the proposed system default (133 pixels/inch) and multiplied it by 2 or 4.

 4. For my system, the increase in scrolling speed was dramatic by doubling the pixels/inch,.

       (above 4 x system default pixels/inch had a small speed gain for me). 

 5. GOOD LUCK !

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

I have been suffering from this issue for sometime and have tried several of the "fixes" posted on this board.  My 2014 Mac Mini running MacOS Big Sur and Adobe Acrobat Pro DC Version 2020.013.20074 is scrolling very, very slowly.  Essentially unsable.  But, thankfully, I finally found a sure fire solution.  I cancelled my 14.99/month Adobe account in favor of a free PDF reader that actually works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 25, 2021 Sep 25, 2021

Copy link to clipboard

Copied

Having this same problem on my iMac (24-inch, M1, 2021)

The scrolling, stuttering, Lagginess and chopiness is UNBEARABLE.  

 

I tried the a couple of the solutions on here but nothing 😞

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2