• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
5

Can't save: "The file may be read-only, or another user may have it open. Please save the document with a different name or in a different folder."

New Here ,
Jan 06, 2017 Jan 06, 2017

Copy link to clipboard

Copied

I've seen this issue all over the internet when I've searched for an answer. And it looks like it has been around for years. The only solution I've seen is to close the window pane in Windows. But what about for Mac users?

I just bought a new macbook pro. I had a 2011 macbook pro previously, with Acrobat Pro X. I backed up my computer in time machine, started up the new computer, and restored the old computer's data to the new one. Everything is the same and works fine except that I cannot save PDFs when I edit them. The only workaround I've found is to open a new folder, which  I can "save as" to the new location, but then I can't save future edits there unless I send them to yet another new folder.

The error message is: "The file may be read-only, or another user may have it open. Please save the document with a different name or in a different folder."

This is driving me crazy. Someone please help.

TOPICS
Create PDFs

Views

216.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

New Here , Aug 10, 2017 Aug 10, 2017

Thank you Michael, and I would like to just map out these instructions for windows users,  as it worked superbly!

1. Click on File Explorer

2. At the top of the page, go to the far left pull down menu call "View" (it's the last in the row of File_Home_Share_View)

3. Click on View

4. To the right, the first box is the "Panes" box and gives you 3 icons to choose from. Click once on the "Preview Pane" option.

5. Like Michael said above, you can also use ALT P to toggle this choice on and off.

This worked

...

Votes

Translate

Translate
New Here , Feb 28, 2018 Feb 28, 2018

This worked for me

If your file/asset is in a folder that is synced with Google Drive, Drop Box, One drive or the like simply quit the backup/sync utility and then hit save on the file. Note: "Pausing" the sync may not allow a file save. You must quit the sync app.

Votes

Translate

Translate
Explorer ,
Sep 10, 2021 Sep 10, 2021

Copy link to clipboard

Copied

I wasn't using any cloud-based file shares or network shares, so I kept looking in this thread for something close to my problem. I got a clue from the entry by cheyennew74060576 and based on that message, I figured out that the cause of my issue was Windows (SHOCKER!). Their ransomeware protection is a bit overzealous...

 

Here are the steps that worked for me...I'm running Windows 10, version 21H1 (Build 19043.1202):

  • First, open Acrobat and attempt to save. It is critical to actually try to save a file and see that it fail - the failure needs to be recent so it shows up later in these steps.
  • Click the Windows button
  • In the "type here to search" box, enter "controlled folder access"
  • Click on "Allow an app through Controlled folder access"
  • If prompted to allow changes to your computer, click [Yes]
  • Click the [ + Add an allowed app ] button
  • Click "Recently blocked apps"
    In the "Recently blocked apps" pop-up window, you should see an entry for Acrobat.exe near the top of the list. To allow Acrobat to save, click the big "+" to the left of the Acrobat.exe entry.
    • If you do not see Acrobat.exe, you may need to click the link to "Browse all apps". This will open a standard Windows "Open" dialog. Navigate to where Acrobat.exe is located (the default for Acrobat DC is C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\Acrobat.exe"). Select it and click [Open].
  • Close out of any open dialogs, making sure that Acrobat.exe is now listed in the "Allow an app through Controlled folder access" dialog.

 

I hope this helps others!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 27, 2022 Sep 27, 2022

Copy link to clipboard

Copied

Thanks! That worked like a charm.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 18, 2023 Apr 18, 2023

Copy link to clipboard

Copied

This was the only solution that worked for me. Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

Disable the preview pane in file explorer and it worked for me.

Adobe seem to register the file as being open when you click on it without opening it and it shows the preview.

Just disable preview pane or select a different file and that should help.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Another Solution is to open your Antivirus program and check the allowed and blocked apps and make sure to place the illustrator.exe file in the allowed apps so that the Antivirus program doesn't automatically stop it from making changes to your files

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 27, 2021 Dec 27, 2021

Copy link to clipboard

Copied

I did what was said here, but none of them worked. I saved the last file as untitled-1 without giving any name. And so I was able to save it. then my file name I changed it in my folder. I wanted to share it in case there is a solution.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 27, 2021 Dec 27, 2021

Copy link to clipboard

Copied

Did you try disabling the preview file option in File Explorer? That was the only thing that allowed me to save my document. Once I turned that option off, I was able to save it.

 

Good luck.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

A lot of people commented that turning off preview pane in file explorer fixes the problem and I confirmed that it works, especially for shared folders or network drive locations, but what if preview pane was required by a user?  I  realize a user can simply toggle preview on and off but if a person's role is to edit PDF documents all day, this would not be efficient.  There must be a real fix and not just a workaround.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 11, 2022 Aug 11, 2022

Copy link to clipboard

Copied

I agree.  Mine worked for a bit, but then there was an update and now it is back to saving with an "a" after everything and then deleting the original invoice, then deleting the "a" after the original name.  Frustrating.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 28, 2022 Aug 28, 2022

Copy link to clipboard

Copied

I have this issue with at Macbook Pro.  I have looked everywhere for an answer.  I just switched from a windows computer to Macbook so I am just learning and trying to get everything set up.  So please help me figure out what to do.   I need this for school.  I can not seem to save PDF files.  I tried on my external hard drive that I used with my windows computer and I tried saving it to icloud.  I know it has to be a setting that I am missing.  Any help will be so appreciated.

 

Thank you so much.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2022 Sep 17, 2022

Copy link to clipboard

Copied

Thanks for your help , really worked with me 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

This helped. It will also help to uncheck the file while it's open. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

Hi, I need to enable preview pane and modify a lot of pdf file from map drive directly. I received the same error all time.

The error message is: "The file may be read-only, or another user may have it open. Please save the document with a different name or in a different folder."

Someone please help. Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 24, 2023 Apr 24, 2023

Copy link to clipboard

Copied

Mac user here (Ventura 13.3.1). This has been happening to me fairly regularly lately, and it's maddening. I've tried resetting all permissions to read & write and paused all my backups (CrashPlan & Time Machine), but still no love. Once you get this message, all of your changes are toast. Fortunately, I can export the comments and then reimport them into the reopened file, and from that point, I can save. Just dropping that here so it might save someone some grief down the road. I've made it a habit to just export comments every so many changes when I'm working on a proof so that I don't lose more time. Adobe needs to fix this bug, whatever it is.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 17, 2023 Nov 17, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2023 Dec 20, 2023

Copy link to clipboard

Copied

This does not appear to work at this time.  There is no option to turn off the Preview under the View menu, nor does Alt P work.  Please provide an updated answer to this same problem.  Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 04, 2024 Feb 04, 2024

Copy link to clipboard

Copied

LATEST

If you have BitDefender Antivirus for mac installed and in the Bitdefender dashbord you have 'Safe File protection' selected on, that will generate the error message "The file may be read-only, or another user may have it open. Please save the document with a different name or in a different folder". Uncheck the safe file protection and Adobe Acrobat will save files now with no issues. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines