• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

Digital Cert Signature with No Prompt

Community Beginner ,
Nov 11, 2020 Nov 11, 2020

Copy link to clipboard

Copied

When I add a digital certification signature to a file, I am prompted to choose which Digital ID I want to use and then a couple more clicks before it's signed. I went through the Manage Digital IDs in preferences and made my only ID the default for both signing and certifiying. It is still prompting me to choose a digital ID.

 

How do I skip this prompt to choose which ID and have it use the only ID available?

TOPICS
General troubleshooting , How to , Security digital signatures and esignatures

Views

373

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2020 Nov 11, 2020

Copy link to clipboard

Copied

In which version of Adobe Acrobat Pro is this happening?

 

And what type of self-signed certificate did you choose:

 

A  PKCS#12 digital ID file or a digital ID stored in the Windows Certificate Store?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 12, 2020 Nov 12, 2020

Copy link to clipboard

Copied

@ls_rbls 

 

I am using Adobe Acrobat Pro DC Version 2020.013.20064

 

I am using a Windows Certificate Store.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 12, 2020 Nov 12, 2020

Copy link to clipboard

Copied

When you have a digital ID that was created using the Windows Certificate Store option you can't remove this type of digital ID (also known as "Windows Digital IDs") from Acrobat directly.

 

Usually this is done by going to "Edit"--->>> "Preferences"--->>>"Signatures"--->> See the "Identities & Trusted Certificates" section and click on the "More" button.  In the next dialogue window that will open there's an option "RemoveID". 

 

But if you already tried this method and it didn't work, you'll notice that  this method only applies to digital ID's that were created as PKCS#12 signing certificates.

 

This is due to the Acrobat and Micrososft Windows integration (specifically the Internet Explorer 11 file browsing integration) through which you can access the Windows Certificate Store directly from.

 

In any case, before you try the next step below, leave this window opened because we have to come back and finalize the process in Acrobat in order to reflect the change(s) in the digital IDs certificate list.

 

So, to successfully remove other unwanted, old, or expired Windows Digital IDs you have to do this through the Internet Explorer web browser. 

 

Go to Internet Options --->>> click on the "Content" tab, then click on the "Certificates" button. 

 

The next dialogue window  will open by default in the "Personal" tab dialogue window, which is where you'll be able to remove  the undesired digital ID certificate(s).

 

To do so, click once to select the digital ID that you want to remove, and then click once on the "remove" button.

 

That's it.

 

All you have to do now is go back to the window that we left opened in Acrobat and click on the "Refresh" button to update the list with the current choices.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 12, 2020 Nov 12, 2020

Copy link to clipboard

Copied

I'm sorry , I believe that I misunderstood your question completely.

 

I missed the point when you mentioned about the prompt opening up.

 

I don't think that this is manages in Acrobat through a built-in feature that you can turn on and off at will.

 

This is done through JavaScript and the scripting is a little complicated, but I think is possible.

 

If I understood you right, you want to be able to digitally sign a signature field silently, with no prompt., Correct?  

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 13, 2020 Nov 13, 2020

Copy link to clipboard

Copied

@ls_rbls Yes, that's correct. I would like to sign silently, with no prompt. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 25, 2020 Dec 25, 2020

Copy link to clipboard

Copied

Hey George, 

 

I hope you're doing fine and I apologize for taking so long to reply back to you.

 

I did tried a few things and nothing worked on my end with my current knowledge of Acrobat JavaScript, but I did find an old topic here that may address your inquiry:

 

 

See the various responses that Adobe Community Professional, Thom Parker, provided to the posting user in that thread.

 

It appears that there is no such uncomplicated or simple way to suppress the Save As dialogue box.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 28, 2022 Nov 28, 2022

Copy link to clipboard

Copied

LATEST

Have the same problem with Acrobat Reader. 

There is only on ceretificate in windows store and this is set as default in Reader.

Nevertheless Reader ignors it and every time I want to sign a document Reader prompt me to select the one and only available certificate

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines