Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


word table borders displaying erratically in PDF

New Here ,
Mar 20, 2018 Mar 20, 2018

Copy link to clipboard

Copied

I am having some issues with Table borders in the finished PDF.

OS:  Win10

Word--Office 365 ProPlus

Acrobat 11.0.23

Have a file with a table. The table has borders. When I PDF the doc and open the PDF, random horizontal borders are missing.  They print properly, though.

Same result with using the PDF printer and the Word Save as PDF plugin.

There are multiple posts with similar issues, but I haven't seen any solutions.

Here's how the table looks in Word:

Table 1.png

Here's how it looks in Acrobat (And Reader, and MS Edge):

Table 2.png

Any suggestions?

TOPICS
Create PDFs, Windows

Views

30.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mar 20, 2018 Mar 20, 2018

Copy link to clipboard

Copied

Unfortunately, by the time either Acrobat's PDFMaker, the Adobe PDF PostScript printer driver instance, or even Microsoft's built-in “save as PDF” gets the content, the formatting is already baked-in. In all cases, Word (and for that matter Excel and PowerPoint) create a Windows EMF stream from the original contents which is then used for print or PDF creation.

What can you try?

(1)     One long-shot solution would be to adjust the setting for the current / default printer within Word to a significantly higher resolution. This may cause Office to allow a thinner line specification in the output. But I something think that this might not work.

(2)     Byte the bullet and increase the width of the table border lines.

          - Dov

- Dov Isaacs, former Adobe Principal Scientist (April 30, 1990 - May 30, 2021)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2018 Mar 21, 2018

Copy link to clipboard

Copied

Whatever the problem is, it has to do with how the file is displayed rather than the content of the file.  As I mentioned, the "missing" borders are present; they just don't display when the file is viewed at 100%.  They show up when the file is printed, and if you adjust the zoom to 200% or higher.

I ended up increasing the border size to 1.5 points, and that more or less fixed the problem.  The borders display, but there are some minor variances--some appear to be 1.5 points, some appear to be 1 point. I'll have to live with that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 21, 2018 Mar 21, 2018

Copy link to clipboard

Copied

I believe this is a symptom of an issue that has existed in PDF files for a long time, where thin lines are displayed incorrectly at higher zoom levels.

Try this to fix it: Go to Edit - Preferences - Page Display and tick the "Enhance thin lines" box.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mar 21, 2018 Mar 21, 2018

Copy link to clipboard

Copied

Of course, this introduces other issues for files that don't really need that artificial enhancement! 

          - Dov

- Dov Isaacs, former Adobe Principal Scientist (April 30, 1990 - May 30, 2021)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 03, 2018 Jul 03, 2018

Copy link to clipboard

Copied

If you save the word document with the problematic table borders as a .pdf, and then export the .pdf to a .tiff at a resolution suitable for your purposes (I export using Mac Preview at 600 ppi), and then export the .tiff back again to a pdf, the whacked table borders look to me to be entirely corrected.  I am not an expert so "entirely corrected" should be taken with a grain of salt, but maybe this workaround can nonetheless still help someone experiencing the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 21, 2018 Aug 21, 2018

Copy link to clipboard

Copied

Thanks for this tip. In my case "Enhance thin lines" was already checked in Adobe Reader (is this the default state for this setting?), and unchecking the box fixed the display issue with my table borders.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 19, 2019 May 19, 2019

Copy link to clipboard

Copied

I had this issue as well. Bloody annoying. Adobe doesn't care. They never have and they never will. Customer service is not a priority to them. Only money is.

But I do have a solution that might work - it worked for me. It looks like you have top and bottom padding set on the cells. Try setting that to 0pt and instead using line spacing (Paragraph > Spacing (Before / After) to create the padding effect. This immediately solved my problem. Having said that I'm also using thick borders - 1 1/2 pt.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2019 Sep 25, 2019

Copy link to clipboard

Copied

That solved my problem - thanks for posting that!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 03, 2020 Apr 03, 2020

Copy link to clipboard

Copied

This (setting cell padding to zero and using paragraph spacing instead) fixed my issue of row banding colors bleeding into other cells. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

Without entering a rant against Adobe, I agree this ought to be solved in Word only, therefore acknowledging Luke's approach. You can frequently observe such issues with borders appearing with no apparent reason just sticking to MS Word's interface, without ever exporting to PDF. So I think there's little to do with Acrobat and the PDF format there, and the border/padding settings are indeed a possibility.

 

Besides, I'd like to add a strange behavior I observed regarding borders, and I hope my experience will be of help to you guys.

It looks like setting no borders at all on a specific cell can sometimes do more "harm".

To make unwanted lines (borders?) disappear on a specific cell, you can try what follows:

  • Use the color white (or any color which is your background's) as border color
  • Use the "box" setting, i.e. select all borders, rather than none
  • Apply these borders on your cell (or set of cells)

 

Admittedly quite counterintuitive, this method proved to do the job.

Yet I can't explain what exact circumstances / settings lead to these borders appearing while none are selected.

 

So I'd be glad to know if this works as well on your side,

 

Sébastien

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2020 Oct 22, 2020

Copy link to clipboard

Copied

This worked!  Set cell margins to zero and used paragraph spacing to provide the white space needed.  Brilliant.  Thank you Luke - this problem has been plaguing me for years.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

This worked for me! Thank you. It didn't just add back in the missing lines (which were still missing no matter my adobe settings), but also fixed some of my borders that were showing at erratic weights (some 1.5, some at .5, etc).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

Awesome, I have been making sure I save my pdf in acrobat so the settings
stay when the document is opened by another user :))

Kind regards

Lisa O'Meara
Director
www.*lokate*design.co.uk
m +44 774 840 2158
t +44 (0) 20 8354 4813
Skype: lomeara69

See our references
See our client list

Lokate Design Ltd is a company registered in England and Wales with company
number 09368840 & VAT number GB207427718.
This email and any attachments are intended solely for the person to whom
they’re addressed. If you're not that person please tell the
sender immediately, and delete the message fully. Emails cannot be
guaranteed to be secure or error-free. Lokate Design Ltd does not accept
liability for damage caused by this email or any attachments and may
monitor email traffic.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

Thanks a lot. 

It works and solved my problem.

Great Job.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

Me as well . . . I thought it was maybe a Macintosh issue, but when I looked up the problem, I noticed MANY posts about this—one in particular noting that the problem has existed since 2004 (I'm sure before, but maybe he's referencing it being an issue noted on the forum). Any many of the people were Windows users. The two strings I followed for assistance/suggestions:

As it is really a presentation/screen problem which I'm assuming Adobe cannot control and does not know how to address so they stay quiet hoping people figure out a work-around, or realize it's not an *actual* problem (PDF and Word Doc I have print out just fine), merely visual. What I did do to help some of the border inconsistencies go away leaving only the most minute, barely noticeable issues on the onscreen viewed PDF, was to recreate the tables fresh and type the content back in myself. As I had many tables that were similar, I did this once, and then used the upper left corner selection icon, when hovering over that part of the table, to copy the entire thing and then manually make content adjustments. I did this because I realize that when you copy and paste in MS docs, it copies much formatting in the background which the user is not intending to paste. This did result in many border issues when we had copied the content of a top header row, into the cells of a secondary header row to make one row (in an effort to pass accessibility, which likes one header row, one header column!). When I recreated these tables and typed in directly rather than copy/pasting data, much of the border problems ceased to subsist.  I also set that one table that was copied (different than copy/pasting data from within table cells), to border width of .75 points, which wasn't too big and ugly, but made the borders look more solid. Just my 2 cents! Hope it helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

I had a similar issue while converting word document to pdf. I tried different options, it dint work as the word doc looked fine but pdf had issues. So I used the table tools for border and selected all the cells facong this line/border issue and selected the option of all all borders under the dropdown of Borders. This made all the cells bordered witht the default border. U can now change the border specs using a format painer. Dont know how and why it works internally, but it does. Hope it helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 27, 2020 Nov 27, 2020

Copy link to clipboard

Copied

This is an adobe issue - if you go to Acrobat Preferences, Page Display and then UNCHECK Enhance thin lines this will force acrobat to display the lines properly - so your pdfs from word, powerpoint etc should look correct.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Great - thanks  - this one worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

LATEST

This is an easy fix, thanks for this!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines