Multi-Frame Rendering is here! (AKA The multithreading you’ve been asking for)

Adobe Employee ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Multi-frame Rendering is here for After Effects beta users. Right now, you will have access to Multi-Frame Rendering for export only. Keep your eye on this forum, as we will be rolling out new features until we launch.

 

Internally, we have been testing a representative sample of projects with a suite of hardware configurations, and we are excited to finally put this feature in your hands and get your feedback. Test your unique projects on your own hardware so we can ensure that our performance updates benefit all of our customers and meet speed and quality metrics before we launch.

 

Beta testing of Multi-Frame Rendering will last a little longer than some of our other features because we currently do not support Multi-Frame Rendering in Preview, Motion Graphics templates, Dynamic Link, Adobe Media Encoder and AERender Command Line Interface.

 

Check out the blog and FAQ post to learn the following:

  • What is Multi-Frame Rendering?
  • What factors influence performance?
  • Which effects have been optimized for Multi-Frame Rendering?

 

Start Testing!
We want to hear from you! Share your thoughts and ideas in this forum.

  • How much faster is Multi-Frame Rendering compared to Single-Frame Rendering with your comps on your machine?
  • Does our benchmark project perform at the expected speed on your system?
  • If you run into specific speed or quality issues with your project, share your project with us at mfrbeta@adobe.com.

 

Test Your Comps
Test your comps in Multi-Frame Render mode vs. Single-Frame Render

  • Use Ae Render Queue to export your comp in Multi-Frame mode.
  • Purge both the disk and memory cache, then
  • Use Ae Render Queue to export your project in Single-Frame mode. Note: Use the same output module for Single-Frame and Multi-Frame mode. Go to Preferences -> Memory and Performance -> Enable Multi-Frame Rendering (beta) and uncheck the box to use Single-Frame Rendering Mode

 

Leave a comment and the following information in this forum:

  • Your hardware specs: # cores in your CPU, GB of memory, GPU model and amount of VRAM
  • Single-Frame render speed (Use “Render Time” noted in your status bar)
  • Multi-Frame render speed

 

If you detect any problems with render speed or quality, submit your projects

  • Open your After Effects project
  • File -> Dependencies -> Collect Files -> Collect -> Save As (Name Your Folder)
  • After Effects will store your .aep file, footage, and text report (file log)
  • Zip up your project and send it to us at mfrbeta@adobe.com (or send a link to it hosted on your creative cloud storage if it’s too large to email).

 

Share the following information in your comment:

  • Your hardware specs: # cores in your CPU, GB of memory, GPU model and amount of VRAM
  • Single-Frame render speed (Use “Render Time” noted in your status bar)
  • Multi-Frame render speed
  • Mercury CPU or GPU Mode used

 

Test our benchmark project and see how your hardware compares
We would love to know how your hardware compares to the results we have gathered from our test suite:

Benchmark Render Speed Improvements.png

 

To test the benchmark project on your machine:

  • Download the benchmark project
  • Use Ae Render Queue to export the benchmark project in Multi-Frame mode.
  • Purge both the disk and memory cache, then
  • Go to Preferences -> Memory and Performance -> Enable Multi-Frame Rendering (beta) and uncheck the box to use Single-Frame Rendering Mode
  • Use Ae Render Queue to export the benchmark project in Single-Frame mode. Note: Use the same output module for Single-Frame and Multi-Frame mode.

 

Share the following information in this forum:

  • Your hardware specs: # cores in your CPU, GB of memory, GPU model and amount of VRAM
  • Single-Frame render speed
  • Multi-Frame render speed
TOPICS
Performance

Views

52.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 448 Replies 448
Community Beginner ,
Oct 12, 2021 Oct 12, 2021

Copy link to clipboard

Copied

AMD Threadripper 3990x 64core, 256GB Mem, NVidia 3090 FE 24GB

 

Software Only:

Multi-Frame = 3:45

Single = 12:45

 

GPU Enabled:

Multi-Frame = 3:22

Single = 11:59

 

WOO HOO Great job Adobe!! This made my week. It's so nice to be able to finally stretch my CPU legs in AE. I'll try some of my other projects in this new version. Hopefully I'll have the same results.   

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

Mac Pro 7,1. 12 cores 96gb Ram Here , Radeon w5700x 16GB

Was excited to heard about this feature but AE only using only 13% of the cpu during the whole proccess...

 

Have you guys at Adobe thought about buying and implenting rendergarden from toolfarm as an standard render technology native to after effects?  If you havent you should since that solution really works. 

 

https://www.toolfarm.com/buy/rendergarden/

 

 

Screen Shot 2021-10-14 at 20.55.38.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

That doesn't seem right. We have 30,000 MFR renders happening in Beta per day with much improved performance. Can you a) confirm that MFR is enabled in Preferences -> Memory & Performance and b) tell me more about the project you were rendering? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

I get the same. All my footage and caches are on 3,500 mb/s NVMe drives, have 64GB ram and my 64 core 3950x maxes out at maybe 25-35% utilization. In app RAM preview does maybe 2-4 simul frames max.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

I'm only getting about 20% usage from my CPU in real world projects too, even though AE is concurrently rendering between 8 and 15 frames. I did do a comparison the other day, and having MFR turned on is indeed a big boost compared to switched off, but it still seems odd that AE isn't taking full advantage of my CPU.

 

Looking at the Render Time stats in my comp, CC Wide Time seems to be the culprit, taking 759ms per frame; all other layers/effects are 0ms - 2ms, with one other layer taking 38ms.

 

Specs:

AMD Ryzen 9 5950X 16-core

Nvidia RTX3090 24GB VRAM

128GB RAM

System, project & cache drives are all Samsung M.2 980 PRO or EVO.

Windows 10, updated yesterday, Nvidia drivers updated today

AE 22.1.0x36

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Having implemented parallel processing on projects before, the bottleneck comes from the BUS getting data to each thread. So for me UHD source and comps has to shove a lot of data into each frame/thread. I'm just guessing that's the bottleneck here. I'm not doing super heavy effects, either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Are there effects in your project not optimized for MFR? (Look for the yellow warning icon in the effects panel). If so MFR needs to wait for those effects for each frame to safely complete which impacts the performance of MFR. 

Also note that AE overall cannot address more than 64 cores so if you are using a CPU with 64 cores, meaning 128 with hyper threading, AE will only be able to utilize the first 64 cores but task manager is showing a percentage relative to 128 cores. So ~40% is effectively 55 or so cores. 

We are working on extending AE to be able to use more than 64 cores for a future update. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

The only non-MFR (yellow triangle) effect I'm using is Deep Glow (https://aescripts.com/deep-glow/), which actually claims (on the aescripts website) to be an MFR effect.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

If you click on the warning icon, it should tell you if it's MFR enabled or if the problem is that it doesn't support the bit depth you're working in. If it's the MFR issue, check to make sure you have the up to date version of it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

I get the non-MFR message:

"This effect may slow down Preview and Export as it is not optimized for Multi-Frame Rendering."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

I just saw your post on the aescripts. Looks like the last update to the effect was back in mid-March and we had to make a change in late March for MFR that meant all MFR effects needed to be rebuilt with a newer SDK. I'm going to guess that hasn't happened as yet which is why you're seeing the warning icon. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Thanks thats great to know. I'm running a 3990 threadripper and kept the stock AE setting "10%" reserved for other apps. From what your saying I can set to "0%" and have it run on all cores(aka 64 of the 128) and not have to worry about locking up other apps). If we are really limited to 64 cores and I get this much of a performance boost. I'm looking forward to the day when you open it up for all 128.

 

I LOVE the beta version. I ran the PugetSystems Bench and before the beta install I was getting scores of about 950 to 980 and now I'm getting bench scores of 1748 what an amazing boost. It's making me what to create more.  PugetBench Results.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Awesome, yes, set that to 0% and you should be just fine! 🙂 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Thanks you ROCK Jenkmeister!!! Looking forward to more to come. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

I was testing out one of my projects and noticed that Rendering was stalling at a particular point in my timeline. Using the Frame Render Time column I isolated the issue to a nested comp that had several text layers with animation expressions applied. Turning these text layers off changes the render time from several seconds down to a few miliseconds - quite dramatic.

 

Do you think there might be something going on with how expressions are being handled? Or maybe there's an issue with expression I'm using (I didn't write it)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Yes. I've found that text layers with expressions seem to cause dramatic slowdowns and non-redraws.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

It's frustrating because to do the text anmiations manually, although it would solve all the preview and render delay problems, would take significantly more time upfront and wouldn't be editable, as adjustable or as iterative - especially on multiple lines of text, and more signifanty if you wanted to try different fonts!

 

It would be nice to know if there are going to be any improvements to expression performance on text layers or if I just need to suck it up and accept the hit! 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Are you able to provide the project(s) to us? Given how much expressions can do, it's very hard to isolate what might be the issue without seeing either the expression or the project. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

I'll try to get a project over to you today.

On another note - if I've got some AE comps dynamically linked in a PPro timeline, will AE/PPro ever render those using MFR? I'm currenlty rendering out a timeline from PPro that's almost 100% DL comps, and my processor is sitting at around 5% usage (16 cores, varying between 1% and about 20%). I now have MFR turned on in AE (I turned it off earlier to avoid issues).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Thanks. 

 

RE: Dynamic Link w/ MFR. Yes, we are currently working on adding the support for dynamic link and motion graphic templates built in AE rendering with MFR when in Premiere Pro. Should be in to beta in the next week or two. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

is it possible for me to jump on the beta team? Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Yep, the beta builds are availabe in the Creative Cloud Desktop app. Just look for the "Beta" section on the left.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

Make sure you're running the latest version of the Creative Cloud app and you should see the beta apps section, as @jenkmeister says, on the left. Here's a screenshot:

beta apps.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

I ran into a new issue in the very latest beta version. Scrubbing the timeline has become awfully slow and sluggish. 

This is even in a completely empty timeline. Notice the lag of the playhead behind the cursor:

 

 

It never was great, but in the regular after effects release it's way better than that:

 

It might be worth noting that I'm on an Apple XDR display, and not a single Adobe App except maybe Lightroom CC seems to like this huge resolution when it comes to UI responsiveness. After effects, Premiere and Lightroom Classic have always been the worst, to the point that I have to run premiere in 1/2 res UI mode. 

 

But this super laggy scrolling behavior in the latest beta wasn't there before, so please look into that.

 

Ah one more thing, it also has become suuper slow to respond to a space bar press to stop a current playback! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Thanks for the reports. I'm not aware of any changes happening in AE itself that would be changing either the UI responsiveness or stopping playback in any of the recent beta updates. Can you confirm you're on 22.1x50? Have you made any changes to your OS or your hardware otherwise? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources