After Effects 22.2 is now available!

Adobe Employee ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

After Effects 22.2 is now available for download from the Creative Cloud desktop application. This release is recommended for all users.

 

What's fixed?

  • Fixed an issue that caused the Composition Profiler to crash certain compositions.
  • Fixed an issue that caused After Effects to crash when adding/removing dropdown menu items in the Essential Graphics panel.
  • Fixed an issue that caused Cineware to crash.
  • Fixed an issue causing the Render Queue items to be incorrectly marked as ready for rendering.
  • Fixed an issue for Windows that caused the memory usage to exceed the assigned threshold when rendering projects with 32-bit EXR files.
  • Fixed the Vegas effect generating flickering output when the Random Phase checkbox is enabled while rendering with Multi-Frame Rendering.
  • Fixed an issue with Draft 3D that caused composition tool cursors to appear in non-composition panels.
  • Fixed an issue with Draft 3D that caused RGBA values to not show up in the info panel.
  • Fixed an issue that caused the color picker to not work in Draft 3D.
  • Fixed an issue with 3D Transform Gizmo that resulted in in an error when using anchor point tool with layer at zero scale.
  • Fixed an issue with 3D Transform Gizmo that caused n-up view label size to change when interacting with the gizmo.
  • Fixed an issue that caused 3D Ground Plane to be able to be turned on/off during a preview if Draft 3D was on.
  • Fixed an issue that caused the cursor to flicker when trying to resize the panels inside After Effects.

 

To check out bug fixes for earlier versions, visit the Fixed Issues page.

 

How to update After Effects to version 22.2?

Open the Creative Cloud desktop application and click the Updates tab on the top-left. Find After Effects in the list and click Update.

ae 22.2.png

I don't see the update in my Creative Cloud desktop application. What should I do?

Click Help > Check for Updates from the Creative Cloud desktop application to refresh it.

TOPICS
Error or problem , FAQ , Resources

Views

3.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Multi Frame Rendering still does not work for me. Adobe tech tried to diagnose but ended up blaming it on the project itself.  If I turn MFR OFF, I'm able to preview and render the composition. Turn MFR ON and rendering stops, AE locks up and have to force quit AE. Running a 2020 mac m1 mini with 16gb ram and 1 TB SSD. Adobe tech did not want to address the simple question of MFR ON and OFF. Has to be something to that issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Hi stevek38849909,

 

I'm sorry to hear about this!

I need more details to help you.

quote

Turn MFR ON and rendering stops, AE locks up and have to force quit AE.

  • Which format are you rendering to? Are you using Media Encoder for rendering or the After Effects Render Queue?
  • What is your macOS version?

 

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Rameez

Rendering in the AE render queue using "High Quality" setting (422).

Mac OS is Monterey 12.2.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

Thanks for getting back! Can you provide the following info so that we can isolate the problem?

 

  • Does your project include any EXR files?
  • Do you have any 3rd-party plugins/extensions/scripts/panels in After Effects?
  • Do you experience the same behavior if you render to a different preset or format?


-Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

AE Isnt evening opening for me keeps giving error message

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

Hi melissa.khan,

 

Sorry about that!

What's the error message? Feel free to share a screenshot.

 

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Hi there,
AE 22.2.0 on M1 PRO with 16core+32GB
is very slow on opening, and 3D camera tracker is very very slow.

Adobe premiere pro instead is very fast!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Hey Luca23077923z7va,

 

Are you experincing the slowness after updating to v22.2? Was it working fine on v22.1.1?

I want to isolate if the problem is specific to the updated version.

 

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

With M1 Pro i'm using version 22.2.0.
I didn't have one previously installed on this Mac.
I have Monterey 12.1

AF 22.2.0 opening time (to Welcome page): 24s
PR 22.2.0 opening time (to Welcome page): 8s

PS 23.1.1 opening time (to Welcome page): 3.4s

AI 26.0.3 opening time (to Welcome page): 3.5s

DW 21.2 opening time (to Welcome page): 3.4s

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

That's unexpected!

If you don't have any customization, would you be able to reset After Effects preferences? If yes, here is how you can do that: https://www.youtube.com/watch?v=45VoFvSs-JI

 

Let me know how that goes.

Rameez

Resetting app preferences can solve strange glitches within After Effects and is a common solution for getting the software back on track. If you found this video helpful, leave us a comment and don't forget to give us a thumbs up 👍! To learn more about resetting your preferences, visit ...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

On Adobe Creative Cloud ver 5.6.5.58 with Option+Shift+Commnad and click on "Open", AE is opening without any alert of reset preferences.
So, i have uninstall AE from Creative Cloud with remove all preferences.
On reinstall AE 22.2.0 there is a info windows "You are using an Apple Silicon device. While you wait for a new version of this app to be developed for Apple Silicon ..."

Which version is developed for Apple Silicon?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

Hi Luca23077923z7va,

 

That's weird! When I press and hold the Command+Shift+Option keys and click "Open", I see a dialog (after 2-3 seconds) that asks me if I want to reset my preferences. I'm on an older MacBook, though. I'll check this with my colleague who has the M1-powered MacBook.

 

quoteWhich version is developed for Apple Silicon?

The After Effects team is working on native support for Apple Silicon. Right now, you have to use After Effects via Rosetta 2.

 

-Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

Rameez

The Adobe tech that navigated my mac did an AE preference reset so it wasn't that.

I deconstructed the problem comp and found it to be the CC Radial Fast Blur applied to several 3D animated vecter layers. Once I removed the CC Radial Fast Blur and applied a standard gaussian blur instead, things moved along (with MFR in ON position). That still doesn't explain why it rendered fine without MFR render on but I'm guessing these are kinks that will be worked out over time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

Wow! Excellent job troubleshooting that, stevek38849909.

quote

Once I removed the CC Radial Fast Blur and applied a standard gaussian blur instead, things moved along (with MFR in ON position).

This is super helpful! I'll share this with the After Effects team. Maybe there is a bug with CC Radial Fast Blur that needs to be ironed out. 🙂

 

Thanks again.

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

my after effects is running very slow now. I dont know what to do (Macbook Pro 2019 intel i5, MacOs Monterey

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

Hi Alex22699988szhe,

 

Where do you feel the slowness — playback, renders, or elsewhere?

 

Let's troubleshoot what's going on.

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

I'm on a iMac pro 10core with 64GB of RAM. After Effects is glitching all over the place when I move the playhead, even when it's fully cached. It evens happens with a fresh install and jast a circle shape layer with 2 position keys on it! Here's an example with a tiny png file with 2 keys on it! What is going on? I can't work like this!!! 

 

 https://www.youtube.com/watch?v=tOsDMxfDWm8

 

  Running OSX Catalina, macOS 10.15.7

  Model Name: iMac Pro

  Model Identifier: iMacPro1,1

  Processor Name: 10-Core Intel Xeon W

  Processor Speed: 3 GHz

  Number of Processors: 1

  Total Number of Cores: 10

  L2 Cache (per Core): 1 MB

  L3 Cache: 13,8 MB

  Hyper-Threading Technology: Enabled

  Memory: 64 GB

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

I downgraded to version 18.4.1 which runs fine. Version 22.x is a complete nightmare!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

So I found a fix. When I turn off "Hardware Accelerate Composition, Layer, and Footage Panels" the glitching and lagging stops.. Well, nice job at "accelerating" after effects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

Of course this isn't a fix because now hardware acceleration isn't working on my machine. Again, I'm on a perfectly normal professional workstation, this should be tested by you guys through and through! I want to know what is causing this issue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

Hi SiebeJanssen,

 

I'm sorry to hear about your issue. Thanks for sharing the video!

I'm glad that you're able to work around it. I'll reach out to someone on the After Effects team and see if I can get any quick answers to why this is happening.

 

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

I don't have a workaround.. If I disable hardware acceleration, audio isn't playing right. If I enable hardware acceleration, the display is glitching.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 18, 2022 Feb 18, 2022

Copy link to clipboard

Copied

Hi SiebeJanssen,

 

I checked with an engineer and here is what he said:

"That preference enables the GPU-acceleration for the viewers. If the GPU drivers are out of date or if the GPU is already overloaded with other tasks, switching back to the older software mode will remedy the problem."

 

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 18, 2022 Feb 18, 2022

Copy link to clipboard

Copied

I am on the latest generation iMac Pro, I haven't got anything to do with driver update issues, driver update issues are a windows problem. New adobe updates should work like a swiss clockwork on latest generation of mac's. There isn't even a newer version iMac Pro available, it's easy as 1,2,3 for you guys to test these updates on all latest mac models, because there are only like 6 professional models! This is essential basic functionality, I immediately saw the stuttering in the first second after booting this update.

 

The driver is fine, this update stinks and is full of bugs. Shouldn't even be available for us users in this crappy state. It's just like all these extremely buggy triple A games nowadays, let the user do the all testing and bug reports, saves us adobe lot's of money.

 

We get pre-mature releases and we get used like lab rats and get fed all these issues and bugs. Adobe should test these updates themselfs before even considering releasing it. Anyway, I'll just stick to version 18.4.1 which just works, maybe you should consider hiring those developers again, because these current people do not know what they are doing.

 

  Model Name: iMac Pro

  Processor Name: 10-Core Intel Xeon W

  Processor Speed: 3 GHz

  Number of Processors: 1

  Total Number of Cores: 10

  L2 Cache (per Core): 1 MB

  L3 Cache: 13,8 MB

  Hyper-Threading Technology: Enabled

  Memory: 64 GB

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines