• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

After Effects 22.6 is now live!

Adobe Employee ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

After Effects 22.6 is now available for download from the Creative Cloud desktop application. This release is recommended for all users.

 

What's new?

 

Keyframe Color Labels: 

Rameez_Khan_0-1661276640459.pngOne of the top-voted feature requests —colored keyframes— has been added to After Effects 22.6. Keyframe color labels allow you to assign colors to keyframes in the composition. Coloring your keyframes helps you to organize, identify, and quickly locate critical components of your composition. You can also use the color labels to quickly select keyframes with the same color group. Label colors can be seen even when the keyframes are selected. When the keyframes are selected, they have a blue outline to differentiate them from your assigned color labels.

 

For more details on how to use color labels, see the Keyframe Color Labels help page.

 

What's fixed?

  • Fixed an issue on macOS where files copied during a Collect Files operation may copy as 0-bytes in size.
  • Fixed an issue on macOS where Save/Open/Import dialogs would not show up when After Effects was disconnected from the network.
  • Fixed an issue that caused After Effects to hang when initializing required components
  • Fixed an issue where the Application menus on macOS may not work or act erratically if a dialog was displayed during application startup.
  • Fixed an issue where zero denominator errors would occur on project open. For example:- After effects error: zero denominator converting ratio denominators (17::18).
  • Fixed an issue that caused the composition interactive re-draw to slow down if multiple font styles of Apple SF symbols fonts were rendered in test layers. 
  • Fixed an issue that caused drop-down menus to be cut off on dual monitor workspaces with different resolutions. 
  • Fixed an issue that caused After Effects to crash on double-clicking in the Project panel after selecting a "Learn" tutorial from the Home screen.
  • Fixed an issue with the preview that sometimes caused After Effects to become unresponsive if caching frames when idle. 
  • Fixed an issue that caused an ‘Illegal Argument Flag: -reuse” error when running aerender with the -reuse flag. 
  • Fixed an issue that caused After Effects to crash on quit when the app was trying to save the workspace changes. 
  • Fixed an issue that caused After Effects to crash when opening certain CMYK Illustrator files. 
  • Fixed an issue with CC Libraries that caused the preview and thumbnail for some footage to break when dragged into the project panel. 
  • Fixed an issue with Stroke that caused the "Below Previous in Same Group" option to not show up in the Stroke settings. 
  • Fixed an issue with the Solid layer that caused the Lock Aspect Ratio to not stick. 
  • Fixed an issue where the 3D Camera Tracker and Warp Stabilizer would stop after analyzing the first frame of the footage.
  • Fixed an issue where After Effects would crash on shutdown if a third-party ScriptUI-based panel had been displayed.

 

How to update After Effects to version 22.6?

Open the Creative Cloud desktop application and click the Updates tab on the top-left. Find After Effects in the list and click Update.

AE 22.6.png

I don't see the update in my Creative Cloud desktop application. What should I do?

Click Help > Check for Updates from the Creative Cloud desktop application to refresh it.

TOPICS
Crash , Error or problem , Freeze or hang , Import and export , Performance , Preview , Resources , User interface or workspaces

Views

4.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

I reported an issue on another post, but the issues remain. In fact they have gotten worse with this update, now when i open a project i am often getting a crash with an error Last log message was: <433945> <CPInfoPane> <1> Error: 517

I can clear this error by resetting preferences, and the project loads. 

I can have 2 files in the render queue - one will render without issue but then the second always comes out like the attached.  Again i can clear this by quitting and reopening. Purging the cache doesn't fix this alone - it will continue either exporting like this - or it renders out, but the file doesn't open, amost isn't recognised by the OS. 

 

I'm using the most updated version of MacOS 12.5.1, MacPro 16core 192gb RAM ProVega II GPU

The issues are driving me mad.

Screenshot 2022-07-26 at 17.10.15.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

@DavidJackson, thanks for posting about these issues.

Also thank you for submitting a complete crash report (including your email address, which allowed us to correlate from your forum ID).

 

The crash you're seeing when opening projects is related to opening a project from the Home Screen in After Effects. The crash is happening in the Home Screen's underlying technology, UXP (an Adobe shared technology for building UI). Specifically, double-clicking the project name when the mouse pointer is in certain positions can cause this. The After Effects team is working with the UXP team on a fix.

 

Until the fix is available, you can avoid the bug by:

  • Only single-clicking on the project name to open it.
  • Not opening projects from the Home Screen. Use the File > Open Project or File > Open Recent menus instead.

 

Regarding the green render issue on export, can you DM me a project file that will reproduce this problem? This looks like something that our shared technology Formats team needs to look at.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 26, 2022 Aug 26, 2022

Copy link to clipboard

Copied

Hi @TimKurkoski, thanks so much for coming back to me so fast. Interesting bug, i did notice that a single click on the project name didn't do anything, so you're right it was a double click and i will stop doing that now - thanks for the suggested work around.

 

I can DM you a project link, but it's linking to quite a lot of external files as it's been a fairly big project so not sure that will work?

 

@warrenk the green/squashed issue is 99% when i export a 1080x1920 (9x16) format ProRes indeed from the same project. As i mentioned, it fixes when i quit the Application - then if i've rendered another file it does the same again.

 

cheers

David

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 26, 2022 Aug 26, 2022

Copy link to clipboard

Copied

@DavidJackson I passed your post along to our Formats team. They think that the green render bug you're encountering may already be fixed in the Beta releases. Could you please test your project in the latest build of After Effects Beta (v23.0, build 37) and let us know if the problem is still occurring there?

 

You can install After Effects Beta from the Creative Cloud desktop app. Click on the Beta Apps icon in the left navigation bar. Beta builds install alongside the official release builds and do not disrupt them; it's safe to have them both installed at the same time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 03, 2022 Nov 03, 2022

Copy link to clipboard

Copied

LATEST

Ooh, I see UXP get a mention in relation to After Effects. Does this mean that we all get to start writing UXP plugins for After Effects soon? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

Is the file that's exporting incorrectly coming from a 1080-by-1920 Composition being rendered at ProRes settings in the Render Queue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

Hi @DavidJackson,

 

The two issues you reported with After Effects 22.6 have been resolved in After Effects 23.0, which was released earlier today. 

 

Again, thanks for your patience and for reporting these issues.

 

Best,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

Oh that’s amazing. The ProRes exports with the green distortion issue has been driving me bonkers. Will be sure to update and let you know if there are any other issues. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Whilst the update has fixed some things it's also brought new issues.  

Loading AE is incredibly slow now, like 23 seconds from hitting the icon to it launching the application. The splash screen still can't launch recent projets either, and i've had 3 instances of the composition panel not being able to preview a simple mp4 on the timeline. Until i restarted the application. AGH.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Is your slow loading for 22.6 or the newly released 23.0 (aka 2023)? Bare in mind that any update can launch slower the first time. mp4's in the timeline are genrally discouraged, they are hard to scrub due to how they store frames internally, but shouldn't not play.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

yes all relating to the new release. I am aware of the slow load on first run after an update, but this is every time. Since the update both versions (last relese and latest) have slowed right down on the loading. Meanwhile photoshop, illustrator and indesign have all got faster in their loading.

 

Mp4's as much as they may be disocuraged, ofte that's now the format preffered by some clients. Never had the issue on the previous verison, so natrually when it becomes an issue of a newer release it causes issues.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 26, 2022 Aug 26, 2022

Copy link to clipboard

Copied

2022-08-26 14_27_23-.png

After Effects error: Attempt to remove an item from a position outside of list length (27:: 9).

 

After this exciting feature of labeling keyframe (a feature I had upvoted), I updated the after-effects. And now every time I move the keyframe, trim layer length, or move a layer in time, it shows me this error. For context, the same project was working fine previously.

 

Spec:

Intel i9 12900k

GTX 3060ti

64 GB DDR5  ram

And project and windows are separated in different ssds.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 26, 2022 Aug 26, 2022

Copy link to clipboard

Copied

Hi @Mayank - Motion

 

Sorry to hear about this, and thanks for upvoting the feature request!

Is it happening in all your projects or just this one?

Would it be possible for you to share a project file with us so that we can test it on our end?

 

Thanks,

Rameez 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 28, 2022 Aug 28, 2022

Copy link to clipboard

Copied

Hey,

 

Yes, the problem still continues. I switched back to version 22.4. I tried purging all memory and disk cache and things work but it needs constantly needs to be purged. like 4-5 times every hour. Also, overlord(plugin to transfer Illustrator shapes to After effects) is not working in version 22.6 which is working fine in version 22.4.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 28, 2022 Aug 28, 2022

Copy link to clipboard

Copied

I am working on a team project and tried local projects as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 30, 2022 Aug 30, 2022

Copy link to clipboard

Copied

Let me know if you can share the project file with us. 

For the Overlord issue, you should check with the plugin manufacturer and see if the plugin is compatible with After Effects 22.6. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 26, 2022 Aug 26, 2022

Copy link to clipboard

Copied

what's your display resolution and monitor name?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 28, 2022 Aug 28, 2022

Copy link to clipboard

Copied

4k at 125% scaling, its Wacom Cintiq pro

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 28, 2022 Aug 28, 2022

Copy link to clipboard

Copied

i bougt a new mac yesterday and strated downloding every program i need ps, ai but it wasnt able to instal After Effects, every time it said "instalation faield, error 183. I tryed what was told on the error list but id didnt help, but the od thig is that i have the program in my files and can start the application. but whle using it its a lil buggy and when i wont to 3d track the kamera it says "obtain dynamiclink server"

i bought the macbookair m1 2020 

need help asap 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 28, 2022 Aug 28, 2022

Copy link to clipboard

Copied

also i tryed downloding in desing just to try and it installed fine 

im getting a bit frustraded

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 30, 2022 Aug 30, 2022

Copy link to clipboard

Copied

Hi @Finn25843684z4xv

 

Sorry for your issue!

Can you try the suggestion given in this post? https://community.adobe.com/t5/after-effects-discussions/error-183-for-after-effect/td-p/13159177 

 

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 28, 2022 Aug 28, 2022

Copy link to clipboard

Copied

I was hoping this new update would support audio playback but, like the previous version it does not. When will Adobe fix audio playback in AE? In the meantine, is there a plugin that allows AE to play out audio? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 29, 2022 Aug 29, 2022

Copy link to clipboard

Copied

@Indie767 

Sorry to hear you're having trouble with audio.  Could you provide some more details?

After Effects should include audio in a Preview as long as as the following things are happening: it's enabled in the Preview panel; it's enabled in the Timeline for the Layer; the audio source is a supported file format; and the audio source is mono, stereo, or dual channel.

Include Audio enabled in the After Effects Preview panel.Include Audio enabled in the After Effects Preview panel.

 

And, of course, the Default Output must be set correctly under Preferences > Audio Hardware.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 30, 2022 Aug 30, 2022

Copy link to clipboard

Copied

After several saumersalts through the proverbial hoop, I got my audio working again. I made a huge mistake by updating. I'm going to finish my comp in 22.6 and then go back to version 18 which seems like the most stable version and live with it going foward. Updates are becoming useless with cute tweaks that are mostly useless to me and my performance grows worse with each iteration. Adobe should stop with these useless updates and focus on stabilty and what works. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines