• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

"Batch Rename" not working properly.

New Here ,
Feb 08, 2018 Feb 08, 2018

Copy link to clipboard

Copied

Hello. I have been using Adobe Bridge for two years now. It is a very helpful tool when in comes to working with a big batch of photos. Recently my "Batch Rename" function has stopped working the way it used to. Instead of marking my photos with a proper sequence number such as "IMG_001, IMG_002, IMG_003,etc." it renames them as "IMG_00 (1), IMG_00 (2), IMG_00 (3)." This has never happened before and I can't seem to figure out why it is doing this.. NOTE: I am running the software in Windows 10.

Views

6.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

People's Champ , Sep 01, 2018 Sep 01, 2018

Stupid question.

Can you copy the files to a folder on a lo hard drive and try renaming them there.

Likes

Translate

Translate
Community Expert ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

Perhaps try resetting Bridge preferences (item #2):

Troubleshoot Adobe Bridge for errors and freezes

You should be able to use batch rename to fix the files, this basic rename will fix it:

rename.png

(However I’d prefer to use a string substitution with regular expression if the file names were not so simple)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 10, 2018 Feb 10, 2018

Copy link to clipboard

Copied

One possible regular expression based string substitution, presuming 9 files or less:

Find: (?<=IMG_\d{2})\s\(|(?<=IMG_\d{2}\s\(\d)\)

Replace:

regex.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Feb 10, 2018 Feb 10, 2018

Copy link to clipboard

Copied

Also make sure you double check the Batch Rename settings (although I'm sure you've already done that), to ensure you don't have it set to create the same name for each file (I've added a screenshot below of how I'd have it set-up), and save a preset (click Save) so you don't have to remember the settings each time you batch rename files, and can select your rename settings from the Presets menu.

batch_rename.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 27, 2018 Aug 27, 2018

Copy link to clipboard

Copied

I have the same problem. I've tried all the suggestions but to no avail. Any further advice out there ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

Can you provide OS info, Bridge version info, exact steps applied to fix the issue and the exact steps required to reproduce this issue?

You may also wish to post over at (unlike this forum, Adobe employees seem to post with greater frequency over there):

Bridge | Photoshop Family Customer Community

Good luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
People's Champ ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

which version of Bridge are you using?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

Latest update. I have found that if I close the program after each name conversion and restate it, I can get a batch processed. It won’t do a second batch with out being restarted. I had to restart it several times on a few occasions but most of the time, once was enough.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
People's Champ ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

weird

Not happening here.

have you tried resetting your preference?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 29, 2018 Aug 29, 2018

Copy link to clipboard

Copied

No but I’ll give that a go over the weekend and see if it makes a difference. Thanks for following up.

Rod Cunich

M: 0438 136 118

E: rod@cunich.com.au<mailto:rod@cunich.com.au>

Sent from my iPhone

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 29, 2018 Aug 29, 2018

Copy link to clipboard

Copied

No but I’ll give that a go over the weekend and see if it makes a difference. Thanks for following up.

Rod Cunich

M: 0438 136 118

E:  rod@cunich.com.au<mailto:rod@cunich.com.au>

Sent from my iPhone

So even though my reply #1 at the top of the topic thread mentioned resetting preferences as the first thing to try… and you have “tried all the suggestions but to no avail” – you didn’t actually reset your preferences and therefore have not tried all of the suggestions. :]

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 01, 2018 Sep 01, 2018

Copy link to clipboard

Copied

I'm experiencing this very same thing. Worked perfectly for 3 years. No changes to my system whatsoever. Now can't select Rename in Same folder (see below). It's been ongoing for about 2 months now. Invested about 6 hours on the phone with Adobe support. Windows Explorer works fine. I've been through about seven Adobe help sessions. Thought we had it fixed last time (safely eject SD card reader). Now it's back to its old tricks. This is very frustrating when you have 500 images to rename. Adobe needs to address this - and soon. Not happy about this at all. Tried all recommended fixes (reset preferences; cleared cache, deleted and re-installed Bridge, etc, etc., etc.). In addition, the "Rename" option does not even appear (see below).

ceaa0645f3c4963b8449301567f00c7b.png

b56feb19920e0e5d8adbda0df0dd7575.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
People's Champ ,
Sep 01, 2018 Sep 01, 2018

Copy link to clipboard

Copied

Stupid question.

Can you copy the files to a folder on a lo hard drive and try renaming them there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 11, 2021 Oct 11, 2021

Copy link to clipboard

Copied

This did not work for me unfortunately. also tried on the computer and on our servers. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

This also did not work for me. Also why is this a stupid question? A function that used to work fine is not working any more.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 11, 2021 Oct 11, 2021

Copy link to clipboard

Copied

I have the same problem. I have been using this function in various versions of Bridge since 2008 and this is beyond frustrating. I have not been able to use batch rename since the last update. It's really hindering my ability to collate  images from different people, we used to just time sync, sort and rename in Bridge. I have tried moving it off the server, doesn't seem to make a difference. whyyyyyyyyyyy........ 🙂 Also using windows 10, updated adobe CC - seem to have had this problem for a couple of updates. 

 

thanks for anyone who can help or to Adobe if they fix this. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

There are alternative software renaming tools if you can't get this working in Bridge.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

I would certainly be interested in trying one at the moment, but it's incredibly disappointing to have have a really useful tool just stop working out of the blue like that. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Hi Megcb, just interested in whether you have found a solution? For months now I have only been able to rename my files with the bracketed numbers, which I dont want as I have to rename files according to customers requests. Now it wont rename files at all!? And how to you contact Adobe for help? There seems to be no way of asking for help! It takes me back to this forum, where everyone has the same problem but no one knows the answer!?

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

You get the brackets when the new filename already exists. Don't try renaming your files to an existing name.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Thank you for your reply, but this is actually not the case. I have tried to rename the files with many different and random names, the brackets always are added. Now I can not rename files at all. I have to rename, then force quit then relaunch, then I get this AdobeBridgeBatchRenameTemp120-900.jpg, then I have to rename again, but it comes with brackets. I have just updated the new version of Bridge, and the issue persits.

Almost as annoying, I can not find how to contact Adobe directly for help about this glitch.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

That's why it happens. Somewhere in the Batch Rename process, filenames are getting duplicated and that's how Bridge handles it. Its not a glitch, its not a bug, the help you need is to change your renaming so you don't get duplicate filenames.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

I am definitely not renaming the files with a name that i have already used, or am I knowingly duplicating the files. They do not rename at all. I do feel there is something wrong with Bridge as it is not an issue I have had in the last 10 years until recently.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

I've had the same thing happen. I use Bridge in production and have done so for a number of years. We can go round and round about this, or you can accept the technical explanation. Its DUPLICATE FILENAMES. You have to figure out how that is happening.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

I've used Bridge and Photoshop  since PS7 back in 2003, including working as a wedding photographer for a number of years. I've not had a single problem until the post above. It seems odd that I never ever had an issue with a  duplicate file before and yet now after an update according to you seemingly I do even though I'm giving them entirely new names....

 

OR maybe there's an issue with the update to bridge and that's why it's stop working? 

 

I will wait for a few more updates and see if the problem is resolved.... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines