• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

SmartShapes not showing in publish project

New Here ,
Jul 22, 2023 Jul 22, 2023

Copy link to clipboard

Copied

I am doing a project for school and having issues with my SmartShapes. When I publish my project to HTML, they are not there. I published to video, and they are there. 

 

There are simple SmartShape. They are not buttons; no fancy work going on. I did have an Enternce effect applied at one point, but I have removed it. Now they come in later on the slide, according to the narration. I have arrows pointing to what I am talking about on the screen.

 

Example of the arrow.

KMclavy99_0-1690068471874.png

 

Properties setting

KMclavy99_1-1690068514244.png

 

 

Timing

KMclavy99_2-1690068542173.png

 

Here is my timeline - SmartShape_35 is the one in the above image.

KMclavy99_3-1690068662662.png

 

So as you can see very simple. I am using Chrome, and yes I have made sure it is updated. I even tried it in Edge and it did the same thing.  

 

Any ideas on why they are not showing up only when I publish it to an HTML5? 

Thanks

Views

48

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Jul 22, 2023 Jul 22, 2023

Your timeline screenshot shows Smartshape_14 has been set to be a button and is pausing the timeline about 2.5 seconds into playback.  That's why your objects are not appearing in HTML output.  MP4 video does not have interactivity.  That's why the same buttons DO appear when you publish to video.

Votes

Translate

Translate
Community Expert , Jul 23, 2023 Jul 23, 2023

Please take some time to read this blog post, explaining what happens when you insert an interactive object with a pausing point at the wrong frame:

https://blog.lilybiri.com/pausing-captivates-timeline

Not only the shape you indicated but also SmartShape_56 will never appear in an interactive project until the playhead is released (probably by clicking the button, not sure which action it is triggering). You are confused by the fact that the slide audio will continue to play, because you need t

...

Votes

Translate

Translate
Community Expert ,
Jul 22, 2023 Jul 22, 2023

Copy link to clipboard

Copied

Your timeline screenshot shows Smartshape_14 has been set to be a button and is pausing the timeline about 2.5 seconds into playback.  That's why your objects are not appearing in HTML output.  MP4 video does not have interactivity.  That's why the same buttons DO appear when you publish to video.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 23, 2023 Jul 23, 2023

Copy link to clipboard

Copied

Please take some time to read this blog post, explaining what happens when you insert an interactive object with a pausing point at the wrong frame:

https://blog.lilybiri.com/pausing-captivates-timeline

Not only the shape you indicated but also SmartShape_56 will never appear in an interactive project until the playhead is released (probably by clicking the button, not sure which action it is triggering). You are confused by the fact that the slide audio will continue to play, because you need to edit the Properties of that button to pause it when the button pauses the Timeline.

You don't have that issue in a passive video because all interactivity is lost. Why would you publish to video if you use interactive objects is a mystery to me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2023 Jul 23, 2023

Copy link to clipboard

Copied

LATEST

Thank you both for your help. This gave me a starting point, and I could get my arrows while still having my buttons.

This will be published as HTML5 as required for my school project.

I did the video as a test run to see if they showed up there. I knew my buttons wouldn't work there, but it was more to see if the arrows were there. 

 

Thank you again! I got my project work with what is required in it. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Help resources