• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

macOS Catalina with eGPU - dimension does not meet minimum OpenGL version

New Here ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

I just installed the latest version of Dimension (Adobe Dimension Version 3.4.0, Build 3.4-20200908.r.2791-611127e) on my Mac Mini 2018.

This mac runs Catalina 10.15.7 on an integrated iGPU - Intel 630 1.5G and an external eGPU - AMD Radeon Pro 580. Both features OpenGL 4.1 engine, according to GLView.

 

However Dimension don't beleive the same, and refuse to launch "Does not meet minimum OpenGL version"

I disabled SideCar as instructed in the forums, no luck.

I see in the logs, just that my AMD eGPU is not detected... copied below.

 

Any advise?

 

 

 

gbl       Dbg        0ms>Start GPU Sniffer Run
gbl       Dbg        0ms>Build Commit Hash  = 611127eacd250f22943d21b3c2c9dbaa3a0ef9a2
gbl       Dbg        0ms>Build Compile Date = 2020-09-08 13:58:49.667230
gbl       Info       0ms>Tester="AdobeDimension"
gbl       Info       0ms>snifferStart="2020-12-15_12:03:39"
gbl       Info       0ms>AIFCoreInitialized=1
gbl       Info       0ms>AIFOGLInitialized=1
gbl       Info      28ms>OGLContextCreated=1
gbl       Dbg       28ms>../components/psgpu/psgpu/gpu/mac/GPUImplMac.cpp: 74: macNumRenderers=3, aifNumDevices=2
gbl       Dbg       28ms>../components/psgpu/psgpu/gpu/mac/GPUImplMac.cpp: 83: aifDeviceIndex=0, macRendererIndex=0
gbl       Dbg       28ms>../components/psgpu/psgpu/gpu/mac/GPUImplMac.cpp: 85: macDisplayID=b433282, macDisplayMask=4, rendererDisplayMask=ff, intersection=4
gbl       Dbg       35ms>../components/psgpu/psgpu/gpu/mac/GPUImplMac.cpp: 83: aifDeviceIndex=1, macRendererIndex=0
gbl       Dbg       35ms>../components/psgpu/psgpu/gpu/mac/GPUImplMac.cpp: 85: macDisplayID=3f0044, macDisplayMask=100, rendererDisplayMask=ff, intersection=0
gbl       Dbg       35ms>../components/psgpu/psgpu/gpu/mac/GPUImplMac.cpp: 83: aifDeviceIndex=1, macRendererIndex=1
gbl       Dbg       35ms>../components/psgpu/psgpu/gpu/mac/GPUImplMac.cpp: 85: macDisplayID=3f0044, macDisplayMask=100, rendererDisplayMask=3f00, intersection=100
gbl       Dbg       44ms>../components/psgpu/psgpu/gpu/mac/GPUImplMac.cpp: 114: found 2 GPUs
gbl       Info      44ms>NumGLGPUs=2
gbl       Info      44ms>glgpu[0].GLVersion="4.1"
gbl       Info      44ms>glgpu[1].GLVersion="4.1"
gbl       Info      44ms>glgpu[0].GLVendor="Intel Inc."
gbl       Info      44ms>glgpu[1].GLVendor="Intel Inc."
gbl       Info      44ms>glgpu[0].IsIntegratedGLGPU=0
gbl       Info      44ms>glgpu[1].IsIntegratedGLGPU=0
gbl       Info      44ms>glgpu[0].GLMemoryMB=1536
gbl       Info      44ms>glgpu[1].GLMemoryMB=8192
gbl       Info      44ms>glgpu[0].GLName="Intel(R) UHD Graphics 630"
gbl       Info      44ms>glgpu[1].GLName="Intel(R) UHD Graphics 630"
gbl       Info      45ms>glgpu[0].GLVendorID=32902
gbl       Info      45ms>glgpu[1].GLVendorID=4098
gbl       Info      45ms>glgpu[0].GLRectTextureSize=16384
gbl       Info      45ms>glgpu[1].GLRectTextureSize=16384
gbl       Info      45ms>glgpu[0].GLRenderer="Intel(R) UHD Graphics 630"
gbl       Info      45ms>glgpu[1].GLRenderer="Intel(R) UHD Graphics 630"
gbl       Info      45ms>glgpu[0].GLRendererID=16925961
gbl       Info      45ms>glgpu[1].GLRendererID=16915464
gbl       Info      45ms>glgpu[0].HasGLNPOTSupport=1
gbl       Info      45ms>glgpu[1].HasGLNPOTSupport=1
gbl       Info      57ms>glgpu[0].CanCompileProgramGLSL=1
gbl       Info      69ms>glgpu[1].CanCompileProgramGLSL=1
gbl       Info      69ms>glgpu[0].GLFrameBufferOK=1
gbl       Info      69ms>glgpu[1].GLFrameBufferOK=1
gbl       Info      70ms>NumNativeGPUs=0
gbl       Dbg       70ms>../components/psgpu/gpu-sniffer-core/app-specific/felix/FelixTester.cpp: 105: {
                         	"CPUAVX2Capable" : true,
                         	"CPUAVXCapable" : true,
                         	"CPUBrand" : "Intel(R) Core(TM) i7-8700B CPU @ 3.20GHz",
                         	"CPUMhzSpeed" : 3200,
                         	"CPUNumberofLogicalProcessors" : 12,
                         	"CPUNumberofPhysicalProcessors" : 6,
                         	"CPUSSE42Capable" : true,
                         	"TotalRAM" : 17179869184
                         }
gbl       Info      70ms>cpuinfo_json_hex_encoded="7b224350554156583243617061626c65223a747275652c2243505541565843617061626c65223a747275652c224350554272616e64223a22496e74656c28522920436f726528544d292069372d383730304220435055204020332e323047487a222c224350554d687a5370656564223a333230302c224350554e756d6265726f664c6f676963616c50726f636573736f7273223a31322c224350554e756d6265726f66506879736963616c50726f636573736f7273223a362c22435055535345343243617061626c65223a747275652c22546f74616c52414d223a31373137393836393138347d0a"
gbl       Info      70ms>snifferEnd="2020-12-15_12:03:39"

 

 

 

TOPICS
Hardware , Mac , Problem or error

Views

436

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Dec 15, 2020 Dec 15, 2020

thanks for the quick feedback, in the mean time I found a solution that worked for me:

I went to the application folder, open the "Get Info" window from the finder, and checked that "Prefer External GPU" option. Et Voila, dimension finaly opens !!!!

 

defaultfaixrvoc1x0c_1-1608037932611.png

 

 

I just wonder why there is just no mention of this solution in the FAQ or support....

 

Likes

Translate

Translate
LEGEND ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

No that is correct and using a eGpu doesn't meat the minimum standard because you also need software that understands what a eGpu is... Which Adobe doesn't have at this point

 

A Windows laptop or desktop will easily fix this issue with out busting your bank account or just wait until Apple and Adobe get around to it... Sorry but that's the bottom line

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

thanks for the quick feedback, in the mean time I found a solution that worked for me:

I went to the application folder, open the "Get Info" window from the finder, and checked that "Prefer External GPU" option. Et Voila, dimension finaly opens !!!!

 

defaultfaixrvoc1x0c_1-1608037932611.png

 

 

I just wonder why there is just no mention of this solution in the FAQ or support....

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

LATEST

thats a new option 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines