• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Artboard Rotation while using touchpad for zoom in Illustrator 25.3

New Here ,
Jun 12, 2021 Jun 12, 2021

Copy link to clipboard

Copied

Hi, recently I faced a new problem. When I use the trackpad for zoom-in/out the artboard keeps rotating. I don't know how can I fix this problem.Screenshot 2021-06-12 at 23.27.43.png

TOPICS
Bug , How to

Views

73.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 4 Correct answers

Adobe Employee , Jul 08, 2021 Jul 08, 2021

Hi all,

 

Sorry about the trouble this feature has caused. We are working on the feedback shared by all of you and will be sharing all the updates related to this issue on our UserVoice page ( https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/43637925-canvas-rotation-feature-is-obstructing-regular-pin ).

 

Till the time it is fixed, please try one of the workarounds already shared on this post, i.e.:

  • Press the Esc key.
  • Double click the Rotate View tool.
  • Press
...

Likes

Translate

Translate
Community Expert , Jul 27, 2021 Jul 27, 2021

Anyone reading this today may be glad to know that updating to Illustrator 25.4 introduces this option in preferences:

 

Screenshot 2021-07-27 164829.png

Likes

Translate

Translate
Adobe Employee , Aug 03, 2021 Aug 03, 2021

Hi all, 


We have tried to address this issue in our latest release. Update 25.4.1 is live for all the countries. Please update Illustrator to the latest version to get access to this option (Trackpad Gesture to Rotate View).

 

SrishtiBali_0-1628011831408.png

Please feel free to reach out if you run into any other questions or issues in the future, we'd be happy to help.

 

Regards!

 

Likes

Translate

Translate
New Here , Apr 10, 2022 Apr 10, 2022

Hi I solved this problem by going to macbook System Preferences> Track Pad >Scroll and Zoom > Rotate and uncheck rotate with two fingers .

 

Hope this helps if there isn't already another solution that i have missed. 

Jo 

 

Likes

Translate

Translate
replies 167 Replies 167
Community Expert ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

Staff are aware, but I would suggest anyone who wants this changed should go to the uservoice post to vote and comment:

 

https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/43637925-canvas...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

I have removed the shortcut to rotate view (shift +h) but holding shift and hitting space changes the hand to the rotate tool as well and I cannot find a place to turn this off.  Unforutnately I use shift + alt frequently to adjust my art and oftentimes my finger might hit the space key instead and my view starts moving which is really frustrating to me.  Would love a way to lock view or turn off this feature entirely to me as for my workflow its simply an annoyance.

Any assistance would be greatly appreciated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Is there a way to disable this feature?

I spend most of time in Illustrator and my workflow doesn't need it. It's annoying.

I couldn't find it on shortcuts keys menu to delete it.

windows 10

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Hi. Apparently, is not possible to disable the Rotation View feature.

Just for curiosity: why does that feature botter you? It doesn't seem to be intrusive.

 

Marlon Ceballos.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

While alternating from Ctrl + SPACE (zoom) to SPACE (move) usualy my second finger rest over SHIFT and sometimes is pressed.


if u press SHIFT + SPACE, BINGO! u have your artboard rotated.

 

it is probally muscle memory from MODO (3D software), but I can't help to avoid it, meanwhile I should be able to deactivate the rotation view shortcut.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

I agree! This is extremely frustrating when I am trying to select multiple things and wanting to pan scroll through my workspace. We should be able to edit the shortcut!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 27, 2021 Jun 27, 2021

Copy link to clipboard

Copied

This is also making me insane. I'm on my Macbook trying to resize something quickly, and I keep accidentally rotating the view when I use my trackpad. It's so much harder to work with my trackpad now, and I just barely figured out how to manually enter "0" in the bottom left corner after accidentally rotating the view. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Hi, for a workaround on mackbook u can disable the zoom pinch on the OS system preferences in the trackpad settings. 
For those who use mouse, there is no way yet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2021 Dec 29, 2021

Copy link to clipboard

Copied

Oh my god this feature is soooo annoying!  I work on the Cintiq Pro 24 and with my workflow and the remote control the canvas is constantly rotating and interrupting my workflow because I have to stop, View>Reset Rotate View.  It happens at least a dozen times an hour.  SO ANNOYING! They need to introduce a way to disable this feature.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Loved the idea of this for my iPad workflow (via Sidecar) but using Illustrator on Macbook Pro with the trackpad, I am constantntly rotating the view now and I am fully disrupted. Adobe, please enable a way to toggle this feature off for trackpad users!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 27, 2021 Jun 27, 2021

Copy link to clipboard

Copied

Hi there,

 

Does anyone know of a way to switch off the ability to rotate view completely? 

It's not just unecessary for me, it's also inconvenient as the gesture I usually use to zoom in is too similar to the new gesture for rotation in the update, so the view keeps rotating when I don't want it to!

 

Can I get rid of it? 

 

Any help would be much appreciated,

 

Thank you,

 

Kia

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 27, 2021 Jun 27, 2021

Copy link to clipboard

Copied

I meant to say I'm talking about Adobe Illustrator, not Photoshop

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Is there anyway to lock Rotate View on Illustrator while using a laptop / Mac?

 

I see why the new feature is useful, but every other zoom in or out on my trackpad, I'm accidentally rotating the display which is very frustrating. I just want it to stay at zero degrees of rotation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

The only way I can think of is to turn off the rotate gesture in your OS trackpad preferences. There is no way within Illustrator itself.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Thanks Doug! This works well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

Yo utlizo mi trackpad y si muebo mis dedos para hacer zoom hay ocasiones que me rota todo el lienzo por la nueva función que tiene illustrator y no quiero que rote!

Cómo bloqueo esta función o cómo puedo regresar a su angulo original?

Captura de Pantalla 2021-06-29 a la(s) 12.32.04.png


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

It doesn't appear there's a way to lock it. I saw that there is a feature request for a lock on the Illustrator Uservoice site. You could upvote it and add any comments there for the Illustrator team.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

This new option of rotating the view in Illustrator is probably great for some users but it's just awfull for me! It keeps rotate when I really don't want, it makes me mad!! How can I unable this option ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

Well, Rotate View tool doesn't start working spontaneously,  just don't call it (make sure to use the H shortcut for Hand, not Shift+H which is for Rotate View). You can also edit the Tools panel and delete the Rotate View tool from there. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

It may do if you're using touchpad gestures to zoom.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

ah, yes. My touchpad works for navigating, so I could not repeat the issue.

yes, then the best way is to report a bug. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

Albertine,

 

You can also follow the advice from pixxxelschubser here,

 

https://community.adobe.com/t5/illustrator/how-do-i-disable-rotate-view-with-trackpad/td-p/12147313

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 29, 2021 Dec 29, 2021

Copy link to clipboard

Copied

In the Preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

...i can't work like this

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines