Artboard Rotation while using touchpad for zoom in Illustrator 25.3

New Here ,
Jun 12, 2021 Jun 12, 2021

Copy link to clipboard

Copied

Hi, recently I faced a new problem. When I use the trackpad for zoom-in/out the artboard keeps rotating. I don't know how can I fix this problem.Screenshot 2021-06-12 at 23.27.43.png

TOPICS
Bug , How to

Views

71.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 4 Correct answers

Adobe Employee , Jul 08, 2021 Jul 08, 2021

Hi all,

 

Sorry about the trouble this feature has caused. We are working on the feedback shared by all of you and will be sharing all the updates related to this issue on our UserVoice page ( https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/43637925-canvas-rotation-feature-is-obstructing-regular-pin ).

 

Till the time it is fixed, please try one of the workarounds already shared on this post, i.e.:

  • Press the Esc key.
  • Double click the Rotate View tool.
  • Press
...

Likes

Translate

Translate
Community Expert , Jul 27, 2021 Jul 27, 2021

Anyone reading this today may be glad to know that updating to Illustrator 25.4 introduces this option in preferences:

 

Screenshot 2021-07-27 164829.png

Likes

Translate

Translate
Adobe Employee , Aug 03, 2021 Aug 03, 2021

Hi all, 


We have tried to address this issue in our latest release. Update 25.4.1 is live for all the countries. Please update Illustrator to the latest version to get access to this option (Trackpad Gesture to Rotate View).

 

SrishtiBali_0-1628011831408.png

Please feel free to reach out if you run into any other questions or issues in the future, we'd be happy to help.

 

Regards!

 

Likes

Translate

Translate
New Here , Apr 10, 2022 Apr 10, 2022

Hi I solved this problem by going to macbook System Preferences> Track Pad >Scroll and Zoom > Rotate and uncheck rotate with two fingers .

 

Hope this helps if there isn't already another solution that i have missed. 

Jo 

 

Likes

Translate

Translate
replies 167 Replies 167
Community Beginner ,
Jul 03, 2021 Jul 03, 2021

Copy link to clipboard

Copied

those are great reset tricks but yes I have been dealing with the same issue. If you are on a mac you can create a keyboard shortcut key too but Adobe needs to have a setting to turn that off.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

On my 2017 iMac with OS Big Sur with an Apple trackpad, when trying to zoom in and out there seems to be a problem identify between zooming/pinching and turning/rotating - while zooming at times it will go into rotation mode for a half-second and then will continue zooming in or out. But then I am unable to reimplement the rotate gesture with the trackpad - the result being that I can't presently use the canvas rotation feature at all. Can this be isolated to my system? - Mark

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 13, 2021 Jun 13, 2021

Copy link to clipboard

Copied

A new feature seems to have hit Illustrator, where you can turn the artboards with the 2-finger-turn on the trackpad of your laptop... but for the life of me I cannot get the artboards returned back to be vertically straight again. Can someone help me with this? there must be a drop-down menu for resettting the angle of the artboards in the sdropdown menu that I'm missing...?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 13, 2021 Jun 13, 2021

Copy link to clipboard

Copied

That menu is in the status bar at the bottom left of the document window.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

Or View > Reset Rotate View

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

How do I disable rotate view? It is a nightmare on a macbook

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

As long as you don't use it for anything else, you can disable the gesture in your system trackpad prefs. There isn't a way within Illustrator. The screenshot is from High Sierra, yours may differ somewhat:

Screen Shot 2021-06-21 at 17.24.05.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Is there a way to turn off the rotate view tool? I updated recently and I use my trackpad a lot and it's flimsy and rotates the entire rotation view, which is annoying to constantly reset. If there isn't a way, I think it'd be convenient to be able to turn this feature on/off when we want.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

As long as you don't use it for anything else, you can disable the gesture in your system trackpad prefs. There isn't a way within Illustrator. The screenshot is from High Sierra, yours may differ somewhat:

Screen Shot 2021-06-21 at 17.24.05.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Rotate view should be optional. With a key command.

It can be very useful, but only quite seldom.

 

Having it active all the time is extremely frustrating.

Disabling the computer by removing the rotation gesture is not a good solution at all.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Hello,

you can setup your own keyboard shorcuts for Rotate view

Screen Shot 2021-06-23 at 12.14.51 PM.png

Regards,

Mike

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Thanks, Mike. That helps.

I have a lot of work with triangular symmetry, so rotations at multples of 60 degrees help.

I'll use the keys though to come back to 0.

A lot of rotations are unwanted, accidental when the dragging fingers move a bit off.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

I just had to create a post for this because it's been driving me crazy. I use my Macbook Pro touch/trackpad almost exclusively when zooming in and out and it used to be no problem at all. Now, almost EVERY SINGLE TIME it will try to rotate the artboard instead of zooming. 

 

If it happened once or twice a session, no big deal I guess, just a mild aggrevation. This happens a couple of times A MINUTE when I'm working at my normal pace and it's extremely frustrating. 

 

No, I don't want to turn rotation off for my entire computer using the two-finger gesture because all my other applications don't have trouble distinguishing the pinch motions from the rotation motions. I want to be able to lock the orientation of the artboard so that it just won't rotate unless I unlock it. Or at least be able to tell Illustrator that I only want the artboard to rotate if I go to the Hand tool and specifically use the artboard rotation tool.

Please make it a priority to try and patch this soon because it's frustrating when it happens SO FREQUENTLY.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

There is a uservoice post on the issue, marked 'Under Review' by staff. I suggest you vote and comment there:

 

https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/43637925-canvas...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Hi there Adobe and fellow Adobe users,

I would like to recommend an idea to introduce a Rotate View Lock. As this new feature was introduced, I realized how I never needed it before and how frustrating it is that it gets accidentally activated every time I zoom in on trackpad (which I do most of my work on). This feature is quite annoying for me already, I'm not sure about everyone else's opinion, but I'd love to deactivate it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Staff appear to be aware; please vote on this topic and hopefully something will be implemented in the next few updates:

 

https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/43637925-canvas...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Hi,

 

You can request new features here: https://www.adobe.com/products/wishform.html 

 

Thanks,

Sim

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

Hi guys,
How can I turn off, Rotate View?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

In what way is it activating that you don't want? Via trackpad gestures?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

Exactly!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

The only way at the moment is to disable the rotate gesture in your system preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 08, 2021 Jul 08, 2021

Copy link to clipboard

Copied

Thanks Doug!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

hello everyone-

This might be easily solved, but as I could not find solution on YouTube, or anywhere else - please aid me in this. 

When zooming out, sometimes this happens - and I simply can't reverse it..

 

Screenshot 2021-06-28 at 18.29.31.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Try to double click the Rotate View Tool (in a "tool group" with the Hand tool)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

Thank you! Worked with the shift pressed together with the rotate view tool. Have a great day!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines