• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

GPU preview greyed out.

Community Beginner ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Hi,

I am having a problem with my gpu preview. It's greyed out and I can't enabled it. On the performance tab, it says gpu is compatible and available. I can check the box in gpu performance and animated zoom, but somehow I can't enabled it. This is not the 1st time that it happened. It happens every now and then and it happened again today. I decided to ask it here in the forum cause I'm really pissed that I can't use it again. My gpu drivers and illustrator are both updated.

I am using a dual screen. 1 is a monitor-tablet Huion gt-191 and the other 1 is just a normal 23" Samsung monitor.

Here's the specs of my pc:

CPU: Intel I5-6600

RAM: 8GB

GPU: Nvidia Gtx 1060 6gb

I hope you guys can help me. I really need to use my illustrator as I have work to do. I can't work without the GPU preview

Thanks!

PS. sorry for the bad english. Not my 1st language

Views

42.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 4 Correct answers

Explorer , Apr 03, 2019 Apr 03, 2019

This might be less of a solution and more of a workaround... but I have the same problem too and I figured out that this only happens when I open Illustrator by opening an illustrator file. So when Illustrator is not open and I open an illustrator file, GPU preview is not available. If I then close the file and open it again while Illustrator stays open, GPU preview works normally.

Hope that helps!

Votes

Translate

Translate
Participant , Apr 20, 2021 Apr 20, 2021

Similar issue in Illustrator 2021 (25.2.1) on macOS. In my case, the only workaround that is working for me so far is to only work with linked images. As soon as I embed an image 'View Using GPU' is greyed out and everything gets clunky and slow.

 

If I hit undo after embedding an image it doesn't fix the bug. Quitting or restarting the computer doesn't necessarily help either. All I need to do is save the file with linked images and re-open it for View Using GPU to work correctly.

Votes

Translate

Translate
Adobe Employee , Aug 08, 2022 Aug 08, 2022

Hi @Nick Wilcox-Brown,

 

Thanks for getting back to me. Illustrator supports all Macs & the GPUs that come preinstalled and the eGPU, which is supplied by Apple for Mac Pro. I have seen creating a new user profile has resolved the issue for some users. Just for testing, please Create a new admin user account. If it works, then we can further troubleshoot the issue. It can be a different cause for everyone. Generally, the user profile gets corrupted after macOS and CCDA updates. A fresh, clean install

...

Votes

Translate

Translate
Participant , Mar 23, 2023 Mar 23, 2023

Anshul, I noticed that Illustrator 27.4 was available to me download this morning and GREAT NEWS!! The GPU problem appears to be resolved! I opened up 2 files that I know definitely did not work, and today I have both files open on my PC at the same time and they appear to be very solid - GPU acceleration all the way. The scrolling speed of the screen appears to be improved as well, very smooth! I'm not sure what you guys did in the background but this looks absolutely great now!!

Votes

Translate

Translate
Adobe
replies 116 Replies 116
New Here ,
Oct 13, 2022 Oct 13, 2022

Copy link to clipboard

Copied

re-install InDesign, worked for me. I'm on a macbook pro

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 13, 2022 Oct 13, 2022

Copy link to clipboard

Copied

Hello @Tycho26540364lqmx,

 

Glad to hear that you were able to resolve the problem. Feel free to reach out if you need further assistance in the future. We'd be happy to help.

 

Thanks,

Anubhav

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Looks like this problem is back with the v 27.0 update. I've tried a few things to fix it, but no luck. I hope this gets patched out in a future update 🤞

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

Yes, I see the exact same problem in Illustrator 27 as well. Previous documents that were in CMYK mode all of a sudden now are CPU preview only, even I try and make the document from scratch again at some point when the GPU load goes up from scrolling around on the screen it just gives up and loses GPU functionality. I found that converting your document to RGB fixes the problem but leaves you in the wrong color space.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

Have you tried keeping all of the pictures you use within the artwork in the same color profile? I noticed that if I place a picture that has a different color profile embedded that the one used in the document color settings, the GPU preview right away stops working. Converting the color profile of the picture to the same one as the document profile and just reopen the AI file fixes the issue. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

Thanks! I haven't tried that, but I appreciate the workaround. I did open the file in another program, export as PDF, and then open again in AI, which seems to do the trick. Just a bummer because it disrupts the work flow, and I prefer GPU preview as it looks much cleaner.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

Yeah, it's really frustrating. Sorry to hear you're also running into this issue. Hopefully it's patched out soon.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2022 Oct 25, 2022

Copy link to clipboard

Copied

Hi @MegaTorque-01 @sevenK @jschmed,

 

We are sorry for the trouble. Would it be possible for you to share a package zip file including all the links to the different colour profile images & Ai document? I tried on my end but couldn't replicate the issue. It would be really helpful for us to fix the issue if we are able to replicate the same behaviour you all are facing.

 

Also, would you mind confirming your system specs, GPU & monitor make & model as well?

 

I will be looking forward to your response.

 

Thanks & regards,
Anshul Saini 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 25, 2022 Oct 25, 2022

Copy link to clipboard

Copied

Good morning Anshul,
 
thnx for your reply. I did provide my system information before already. The problem occurs on a MacBook Air, 1,2 GHz Quad-Core Intel Core i7, Intel Iris Plus Graphics 1536 MB, 16 GB RAM. 
 
I uploaded a sample file which you can find in the link below. I did also include the color profiles I used, but noticed that the problem also occurs if I chose and include any other profile in the image and replace the one that is placed in the AI document. All you need to do is open the AI file, chose the image and replace it with the one named ISO at the end, it’ll right away switch off GPU preview and leaves you with the CPU preview. At least that’s what is happening on my Mac.
 
Thnx again for your help. 

 

Linked Files

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

I actually downloaded your file and opened it up and followed your instructions -- but my GPU was still enabled. It worked great on my PC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

You mean PC as for Windows PC? Maybe it‘s just a Mac issue? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Hi @sevenK,

 

Thanks for sharing the file. I tied but couldn't replicate the issue on M1 Max Macbook. Would it be possible for you to screen-record & demonstrate the issue? I will forward it to the team, and they will try replicating it on their Macs'. It would be really helpful for us.

 

Looking forward to it.

 

Reagrds,

Anshul Saini

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Good morning Anshul,

sure, no problem. Thnx again for your patience 🙏

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Maybe it‘s more like an Intel problem if you can‘t reproduce the issue on your M1-MBP? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

This is specifically an Intel Mac issue, the GPU has always worked perfectly on M1 devices.

Nick Wilcox-Brown

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

Hi Anshul,

I'm using a HP Windows PC, Windows 10 Pro 64bit, Intel Xeon CPU E3-1240 v5 @ 3.50GHz, 16 GB RAM,

GPU is NVIDIA Quadro K2200, Display HP ProDisplay P232 Monitor.

I've provided a link to a file that creates the issue for me below.

Linked File 

Thanks, I appreciate the help!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 12, 2022 Nov 12, 2022

Copy link to clipboard

Copied

Hi @sevenK @MegaTorque-01,

 

Thanks for sharing the files & screen recording. I was able to replicate the issue on a Windows machine with the file shared by @jschmed. However, on Intel Mac, I am unable to replicate the same with the file & by following the instruction in the screen recording shared by @sevenK. Please allow us some more time to investigate this further. I will get back to you.

 

Regards,

Anshul Saini

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

It does feels weird that the bug occurred on some version while i tested out on v25.2.1 it works normally then switch to v27 it starts to bug again and force my zooming to go CPU preview

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

I must say I haven’t had any issues regarding the GPU-preview lately. I only had the issue when I didn’t have the same ICC profile embedded in pictures I placed that didn’t match the current document settings. At the moment I’m on the latest version 27.3.1 and it just works fine.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2023 Mar 05, 2023

Copy link to clipboard

Copied

I know this is an old question but if you have a high performance graphics card this is what you do. FYI this is for windows and I don't know MacOS but you can use this as a reference.

 

go to settings, graphics settings, type 'adobe illustrator' in the search box, options, change your graphics preference to your high performance GPU. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 05, 2023 Mar 05, 2023

Copy link to clipboard

Copied

wow thanks man your suggestions does work for me😆

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 06, 2023 Mar 06, 2023

Copy link to clipboard

Copied

This is not a correct answer - it suggests that many dozens of people in this thread have no idea what they are doing; clearly an incorrect assumption.

There is a known and very long standing issue with GPU not being utilised correctly by Illustrator, going back many years on both Mac and PC. In many cases the GPUs in question are listed as supported, but still fail to operate. In some cases new Illustrator versions fix the issue and then a later version again cause a break. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 07, 2023 Mar 07, 2023

Copy link to clipboard

Copied

I also thought telling us that this would be the correct answer was kinda insulting our knowledge in AI, but didn’t want to say anything. 

 
For me the solution still lays in the color profile of the placed image. If an image has a profile embedded that does not correlate with the document settings, or also if you ignore the color settings and the profile is not the same as the profile in the application color settings, the GPU-preview is disabled immediately. It works fine if you have no profile embedded in the image, or use the same profile in the picture as you use within Illustrator for either the document or application. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 08, 2023 Mar 08, 2023

Copy link to clipboard

Copied

SevenK that's probably the best explanation I have seen of the problem -- I've managed to get around the issue by converting images into the same color profile as the document -- however, we should still keep hounding Adobe on this because this problem of the GPU cutting out only started after v26 and clearly the earlier versions had no problem handling documents with mixed profiles.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2023 Mar 08, 2023

Copy link to clipboard

Copied

 I see so its better to convert any image embed into the document to follow the color mode of the document itself by using Edit > Edit color > Convert to CMYK/RGB. Am I correct on this way or is there another workaround to directly adjust the placed image to follow the color profile of the document?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines