• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

GPU preview greyed out.

Community Beginner ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Hi,

I am having a problem with my gpu preview. It's greyed out and I can't enabled it. On the performance tab, it says gpu is compatible and available. I can check the box in gpu performance and animated zoom, but somehow I can't enabled it. This is not the 1st time that it happened. It happens every now and then and it happened again today. I decided to ask it here in the forum cause I'm really pissed that I can't use it again. My gpu drivers and illustrator are both updated.

I am using a dual screen. 1 is a monitor-tablet Huion gt-191 and the other 1 is just a normal 23" Samsung monitor.

Here's the specs of my pc:

CPU: Intel I5-6600

RAM: 8GB

GPU: Nvidia Gtx 1060 6gb

I hope you guys can help me. I really need to use my illustrator as I have work to do. I can't work without the GPU preview

Thanks!

PS. sorry for the bad english. Not my 1st language

Views

41.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 4 Correct answers

Explorer , Apr 03, 2019 Apr 03, 2019

This might be less of a solution and more of a workaround... but I have the same problem too and I figured out that this only happens when I open Illustrator by opening an illustrator file. So when Illustrator is not open and I open an illustrator file, GPU preview is not available. If I then close the file and open it again while Illustrator stays open, GPU preview works normally.

Hope that helps!

Votes

Translate

Translate
Participant , Apr 20, 2021 Apr 20, 2021

Similar issue in Illustrator 2021 (25.2.1) on macOS. In my case, the only workaround that is working for me so far is to only work with linked images. As soon as I embed an image 'View Using GPU' is greyed out and everything gets clunky and slow.

 

If I hit undo after embedding an image it doesn't fix the bug. Quitting or restarting the computer doesn't necessarily help either. All I need to do is save the file with linked images and re-open it for View Using GPU to work correctly.

Votes

Translate

Translate
Adobe Employee , Aug 08, 2022 Aug 08, 2022

Hi @Nick Wilcox-Brown,

 

Thanks for getting back to me. Illustrator supports all Macs & the GPUs that come preinstalled and the eGPU, which is supplied by Apple for Mac Pro. I have seen creating a new user profile has resolved the issue for some users. Just for testing, please Create a new admin user account. If it works, then we can further troubleshoot the issue. It can be a different cause for everyone. Generally, the user profile gets corrupted after macOS and CCDA updates. A fresh, clean install

...

Votes

Translate

Translate
Participant , Mar 23, 2023 Mar 23, 2023

Anshul, I noticed that Illustrator 27.4 was available to me download this morning and GREAT NEWS!! The GPU problem appears to be resolved! I opened up 2 files that I know definitely did not work, and today I have both files open on my PC at the same time and they appear to be very solid - GPU acceleration all the way. The scrolling speed of the screen appears to be improved as well, very smooth! I'm not sure what you guys did in the background but this looks absolutely great now!!

Votes

Translate

Translate
Adobe
replies 116 Replies 116
Community Beginner ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

The problem is back in version 26.1 (specifically not being able to go back to GPU preview after entering outline mode)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 16, 2021 Jul 16, 2021

Copy link to clipboard

Copied

this worked for me, thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

I work when only activate my GPU setting.

 

Ensure that GPU Performance is enabled (Preferences > Performance).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 15, 2021 Jun 15, 2021

Copy link to clipboard

Copied

We do assume with experiencing this problem we know that GPU Performance needs to be activated in the preference panel. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Go to preference> performance> check mark the gpu option...viola!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Nope ... of course the gpu option was/is enabled ... has nothing to do with that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

I had the same issue. The GPU preview option is greyed out in Illustrator for me.  I tried everything and didn't work untill I found this youtube video: https://www.youtube.com/watch?v=EUic90N5c1M

I didn't follow the whole thing, I only added the illustrator.exe and AIsniffer binder and from the options, select high performance. And my GPU option is back!

Hope this will work for you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

FOR GAMERS with MSI afterburner
Had same problem and comments down below did not work. I am also a gamer and i have afterburner, after completly closing it the problem was fixed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

Here we are in Dec 2021- it's still not fixed, but I discovered another workaround after trying all these ideas. Open a brand new, empty document, notice the "View Using GPU" is no longer greyed out. Now copy and paste all your artwork into the new empty canvas, and it should work. When will they fix this stupid bug?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

January 2022. This thread started 4 years ago and this is still an acute issue - this is a maxed iMac (no excuses about compatibility here) - working on Illustrator 26.0.2 is like wading very painfully through treacle.

 

Sadly the documents I'm working on are too complex, too mission critical to copy and paste as a workaround for broken software.

Zoom into a document - 200% 400% and next is 28,000%

Move a layer and it keeps on moving. Ghost in the machine? 

From memory the explanation for moving to CC subscriptions was that it would bring instant fixes, and regular new features. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

quote

this is a maxed iMac (no excuses about compatibility here)


By @Nick Wilcox-Brown

 

Compatibility is not about being "maxed", it's about one thing fitting into another one.

 

That said: the requirements are here https://helpx.adobe.com/illustrator/system-requirements.html

 

In order to have Adobe Tech staff take a look at the issue, please contact them at https://helpx.adobe.com/contact.html

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

@Monika Gause  appreciate the quick reply, thanks. 'maxed' refers to the fact that it was carefully optimised for graphics. As you know, Apple machines are very standardised, with limited options and Adobe work closely with Apple engineers to ensure compatibility. The  GPU was specifically chosen based on conversations with members of an Adobe dev team for another GPU intensive application. The big problem is that all the teams work independently. If an annual 'suggested specifications' was agreed between all the CC teams, life would be so much easier 'at the coalface'. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

If you have GPU Tuning Software like RivaTuner/ Afterburner / GpuTweak, you must shut it down first and then restart Illustrator.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Late to the party here, but one thing that seems to have worked for me on an M1Max Macbook Pro is to convert images (linked or embedded) to a different color profile. After converting images to sRGB in Photoshop, I am now able to switch to GPU preview.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Its not the colour profile Stephen - it is the hardware; my M1 Max laptop has 4 or 5x the performance of the other machine and as you say, allows full GPU preview. The big issue here is that Adobe are not supporting the same hardware across their product line. For PS / LR there is one standard (hence purchase on expensive GPU upgrade at PS team suggestion), for Illustrator another, despite all applications being GPU intensive.

 

A 'supported' / 'recommended' hardware list across all CC products would solve this issue, but currently it is anarchy and customers lose out.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Not quite the case, it does have something to do with the color profiles embeded in the pictures, cause when you change the profile in the pictures the GPU preview works fine again. The question here is not about the GPU preview not working at all but failing to work in some cases.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Hi @sevenK @Nick Wilcox-Brown @stephenmues,

 

We are sorry for the trouble. Illustrator is natively supported on Apple silicon devices. I would like to understand the issue you are facing. Would you mind sharing a few images sample which disables GPU in Illustrator? You can upload it to the Creative Cloud (https://helpx.adobe.com/in/creative-cloud/help/share.html) and share the download link here or via DM with me. We'll check at our end.

 

Converting images in Photoshop is a workaround which may not be a feasible option for everyone. I will investigate the issue and escalate it to the product team.

 

We are here to help. We just need more info.

 

Looking forward to your responses and images.

 

Thanks & Regards,

Anshul Siani

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Hi Anshul,

 

I appreciate your reply. This is not a problem with Apple Silicon, but the previous generation of Macs. Working on a book project earlier this year was nearly impossible on a top of the range iMac, equipped with an enhanced GPU, as suggested by the PS dev team (I work with LR / ACR / PS pre-release and beta teams). Bizarrely, it seems that the Illustrator team support different GPUs to the aforementioned, so a powerful (and expensive) machine could not utilise GPU preview and made working in Illustrator an experience similar to being back in the early 1990s. On the contrary, my 14" laptop with an M1 Pro chip was superfast, but hard to use (small screen) with large and complex Illustrator documents.

The problem is not yours, but evidenced by the length of this thread,  the Illustrator management team has clearly ignored this ongoing issue for far too long.

Thanks,

 

Nick.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

Hi @Nick Wilcox-Brown,

 

Thanks for getting back to me. Illustrator supports all Macs & the GPUs that come preinstalled and the eGPU, which is supplied by Apple for Mac Pro. I have seen creating a new user profile has resolved the issue for some users. Just for testing, please Create a new admin user account. If it works, then we can further troubleshoot the issue. It can be a different cause for everyone. Generally, the user profile gets corrupted after macOS and CCDA updates. A fresh, clean install of all the CC apps in a new user account fixes issues such as this and improves the performance as well.

 

I hope it helps!

 

Regards,

Anshul Saini

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 11, 2022 Aug 11, 2022

Copy link to clipboard

Copied

Thanks @Anshul_Saini  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

Creating a whole new macos user account? That's pretty much the same as a clean install of the hard drive. A pretty extreme measure. Would take days to set everything up again.

You haven't figured out what thing gets corrupted, so I could just fix the problem?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

quote

Creating a whole new macos user account?


By @Sveinbjorn Palsson

 

In troubleshooting this is just a test. If it works, then it shows where the issue is located. It can be a different cause for everyone causing this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 08, 2023 Dec 08, 2023

Copy link to clipboard

Copied

Yes, unfortunately Anshul failed to mention that part. Maybe he can edit that bit in, if he's still around.

I was googling instructions on how to fix the problem and it was presented as a fix, not a troubleshoot, so that was pretty demoralising to see.

I ended up solving it by just removing illustrator, and the beta. On reinstall it was gone. 

But I still don't know what caused it, I'd love to know.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2022 Sep 14, 2022

Copy link to clipboard

Copied

To those still struggling with this issue : Try turning off Overprint Preview

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Are you kidding us??

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines