• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

GPU preview greyed out.

Community Beginner ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Hi,

I am having a problem with my gpu preview. It's greyed out and I can't enabled it. On the performance tab, it says gpu is compatible and available. I can check the box in gpu performance and animated zoom, but somehow I can't enabled it. This is not the 1st time that it happened. It happens every now and then and it happened again today. I decided to ask it here in the forum cause I'm really pissed that I can't use it again. My gpu drivers and illustrator are both updated.

I am using a dual screen. 1 is a monitor-tablet Huion gt-191 and the other 1 is just a normal 23" Samsung monitor.

Here's the specs of my pc:

CPU: Intel I5-6600

RAM: 8GB

GPU: Nvidia Gtx 1060 6gb

I hope you guys can help me. I really need to use my illustrator as I have work to do. I can't work without the GPU preview

Thanks!

PS. sorry for the bad english. Not my 1st language

Views

26.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Participant , Apr 20, 2021 Apr 20, 2021

Similar issue in Illustrator 2021 (25.2.1) on macOS. In my case, the only workaround that is working for me so far is to only work with linked images. As soon as I embed an image 'View Using GPU' is greyed out and everything gets clunky and slow.

 

If I hit undo after embedding an image it doesn't fix the bug. Quitting or restarting the computer doesn't necessarily help either. All I need to do is save the file with linked images and re-open it for View Using GPU to work correctly.

Likes

Translate

Translate
Adobe Employee , Aug 08, 2022 Aug 08, 2022

Hi @Nick Wilcox-Brown,

 

Thanks for getting back to me. Illustrator supports all Macs & the GPUs which come preinstalled and the eGPU, which are supplied by Apple for Mac Pro. I have seen creating a new user profile has resolved the issue for some users. Generally, the user profile gets corrupted after macOS and CCDA updates. A fresh, clean install of all the CC apps in a new user account fixes issues such as this and improves the performance as well.

 

I hope it helps!

 

Regards,

Anshul Saini

Likes

Translate

Translate
Explorer ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

Have you tried keeping all of the pictures you use within the artwork in the same color profile? I noticed that if I place a picture that has a different color profile embedded that the one used in the document color settings, the GPU preview right away stops working. Converting the color profile of the picture to the same one as the document profile and just reopen the AI file fixes the issue. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

Thanks! I haven't tried that, but I appreciate the workaround. I did open the file in another program, export as PDF, and then open again in AI, which seems to do the trick. Just a bummer because it disrupts the work flow, and I prefer GPU preview as it looks much cleaner.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

Yeah, it's really frustrating. Sorry to hear you're also running into this issue. Hopefully it's patched out soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2022 Oct 25, 2022

Copy link to clipboard

Copied

Hi @MegaTorque-01 @sevenK @jschmed,

 

We are sorry for the trouble. Would it be possible for you to share a package zip file including all the links to the different colour profile images & Ai document? I tried on my end but couldn't replicate the issue. It would be really helpful for us to fix the issue if we are able to replicate the same behaviour you all are facing.

 

Also, would you mind confirming your system specs, GPU & monitor make & model as well?

 

I will be looking forward to your response.

 

Thanks & regards,
Anshul Saini 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2022 Oct 25, 2022

Copy link to clipboard

Copied

Good morning Anshul,
 
thnx for your reply. I did provide my system information before already. The problem occurs on a MacBook Air, 1,2 GHz Quad-Core Intel Core i7, Intel Iris Plus Graphics 1536 MB, 16 GB RAM. 
 
I uploaded a sample file which you can find in the link below. I did also include the color profiles I used, but noticed that the problem also occurs if I chose and include any other profile in the image and replace the one that is placed in the AI document. All you need to do is open the AI file, chose the image and replace it with the one named ISO at the end, it’ll right away switch off GPU preview and leaves you with the CPU preview. At least that’s what is happening on my Mac.
 
Thnx again for your help. 

 

Linked Files

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

I actually downloaded your file and opened it up and followed your instructions -- but my GPU was still enabled. It worked great on my PC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

You mean PC as for Windows PC? Maybe it‘s just a Mac issue? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Hi @sevenK,

 

Thanks for sharing the file. I tied but couldn't replicate the issue on M1 Max Macbook. Would it be possible for you to screen-record & demonstrate the issue? I will forward it to the team, and they will try replicating it on their Macs'. It would be really helpful for us.

 

Looking forward to it.

 

Reagrds,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Good morning Anshul,

sure, no problem. Thnx again for your patience 🙏

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Maybe it‘s more like an Intel problem if you can‘t reproduce the issue on your M1-MBP? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

This is specifically an Intel Mac issue, the GPU has always worked perfectly on M1 devices.

Nick Wilcox-Brown

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

Hi Anshul,

I'm using a HP Windows PC, Windows 10 Pro 64bit, Intel Xeon CPU E3-1240 v5 @ 3.50GHz, 16 GB RAM,

GPU is NVIDIA Quadro K2200, Display HP ProDisplay P232 Monitor.

I've provided a link to a file that creates the issue for me below.

Linked File 

Thanks, I appreciate the help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 12, 2022 Nov 12, 2022

Copy link to clipboard

Copied

LATEST

Hi @sevenK @MegaTorque-01,

 

Thanks for sharing the files & screen recording. I was able to replicate the issue on a Windows machine with the file shared by @jschmed. However, on Intel Mac, I am unable to replicate the same with the file & by following the instruction in the screen recording shared by @sevenK. Please allow us some more time to investigate this further. I will get back to you.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines