Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Illustrator CS6 Spacebar stops working seemingly randomly

Explorer ,
Jun 21, 2012 Jun 21, 2012

Copy link to clipboard

Copied

This is an infrequent issue I've had, but it has happened more than once in the last few weeks that I've been using CS6 on a regular basis:

On occasion, my spacebar will just stop working in Illustrator CS6, so I can't use the hand tool or zoom or… you know, type, basically making Illustrator unuseable. Now, I'm PRETTY sure it has nothing to do with my actual keyboard, because the spacebar will continue to work just fine in every other application even after it does this.

The only fix is restarting the computer. Just restarting the application doesn't do it. Deleting the preferences file and restarting doesn't fix it. It's really perplexing.

Now, I'm NOT certain about this, but I think it might occur after waking from sleep (but not immediately, so perhaps it's unrelated). If/when it happens next, I will attempt to see if I can reproduce the issue, but so far I have no idea why it happens; it just seems random.

I'm using a late 2008 MacBook Pro with 8GB of RAM, running Mac OSX 10.7.4 and Illustrator CS6 (16.0.0, in case people see this after an update has been released).

Views

128.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 104 Replies 104
Community Beginner ,
Sep 20, 2014 Sep 20, 2014

Copy link to clipboard

Copied

I had the same problem after installing Ai CC 2014.  Reading some post above someone suggested switching off Chrome.  I tried that and it worked.  Switch Chrome back on and seems to be ok.

Open AI first, then open Chrome.  Hope it works for you and keeps working for me

Btw, on Macbook pro Retina

g

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 24, 2014 Oct 24, 2014

Copy link to clipboard

Copied

In my case the conflict was with Parallels. Quit Parallels and my Illustrator shortcuts work again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2014 Oct 24, 2014

Copy link to clipboard

Copied

I had the exact same issues. Finally tracked it down to being logged into Squarespace. My zoom and grabber shortcuts would work fine until I logged in to Squarespace in Chrome. If I log out and keep Chrome open, I get my shortcuts back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 06, 2014 Nov 06, 2014

Copy link to clipboard

Copied

I just started having the same problem. Everything was fine, and then spacebar just stopped working. I narrowed it down to a conflict with Safari, but only when I've got Private Browsing on. Strange, because the only time I've had a problem with it previously is when Gmail wanted to access the Google Talk plugin.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 06, 2015 Jan 06, 2015

Copy link to clipboard

Copied

I had this same issue and a restart would NOT fix the problem, neither would reseting the prefs, or any of the other solutions mentioned in this post.  I discovered the problem to be the Terminal application was automatically opening on login, which had the "Secure Keyboard Entry" option enabled. (Terminal menu item->Secure Keyboard Entry (check marked))  If I quit Terminal without disabling "Secure Keyboard Entry", the spacebar in Adobe Illustrator/Photoshop would work as expected.  Although, if I restarted with Terminal still loading automatically with "Secure Keyboard Entry" enabled then the spacebar would NOT work until I quit the Terminal app.  The problem is that when the computer logs into the user account and starts the Terminal app it hides the keyboard entry from other applications.  Somehow Adobe products are now sensitive to this and the spacebar stops working as is should.  So, the solution is to either make sure Terminal is not to load automatically at login, or disable the "Secure Keyboard Entry" option in Terminal and only enable it as needed.  Be sure to disable it when your are no longer using the terminal.  I have never seen this before and have been using Adobe products on OS X since its release, but I have not always used the Terminal as I do now in such a secure way.  Thanks again governments and criminals for even further complicating our lives!

-Cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2015 Feb 02, 2015

Copy link to clipboard

Copied

I just experienced this spacebar hand tool shortcut not working for the second time in two days.  Quitting Chrome resolved the issue.  I relaunched Chrome and the Illustrator shortcut still seems to work.  Strange.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2015 Feb 25, 2015

Copy link to clipboard

Copied

Second time this has happened to me. Closed Chrome and issue resolved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 01, 2015 Mar 01, 2015

Copy link to clipboard

Copied

This helpful action fixed my similar problem with spacebar drag not working correctly

Hold down Command+Option+Shift while starting Illustrator to reset preferences. This should be the first troubleshooting step.

Fomr http://forums.macrumors.com/showthread.php?t=575744

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 17, 2015 Mar 17, 2015

Copy link to clipboard

Copied

Mac OS 10.8.5 - I recently lost modifier key function on ALL my Adobe programs. I followed every thread I could find. Tried everything to remedy this problem. I finally realized I had installed Webroot security and when I checked it, it has Secure Keyboard Entry (much like Terminal app as mentioned in another thread) enabled by default. When I turned this off I have my modifiers back.

Hope this helps others.

~jb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2015 Aug 27, 2015

Copy link to clipboard

Copied

You saved my day! Thank you good sir! This was the only thing that worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 10, 2015 Sep 10, 2015

Copy link to clipboard

Copied

This was it! IT had installed Webroot on my MAC a few weeks ago. Thanks for finding, JohnB8122!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 29, 2015 Dec 29, 2015

Copy link to clipboard

Copied

Worked for me! Thanks for the heads up!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 06, 2016 May 06, 2016

Copy link to clipboard

Copied

Disabled the Keyboard security in Webroot's RealTime Shield settings is the only thing that worked for me. Illustrator/CS6 OS X 10.11.4

Was not using Chrome, Firefox or password one. I quit Safari, it worked for a second and then stopped. Went into Webroot to disable RealTime Sheild and it worked, no matter when I opened Safari, Illustrator, or whether I had Creative Cloud running or not.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 12, 2016 May 12, 2016

Copy link to clipboard

Copied

I searched and do not see that application on my machine. Is this software specific to your machine or are you suggesting a universal solution?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 12, 2016 May 12, 2016

Copy link to clipboard

Copied

The software mentioned above is an individually installed Web security software, not a universal solution. Other browser addons or security/password control software is much more likely.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 16, 2017 May 16, 2017

Copy link to clipboard

Copied

Had this issue today. I'm with a new company and they use Webroot Secure and once I paused the Secure Keyboard Entry feature, I had my space bar working the way it should. Thank you! It would have otherwise taken me ages to figure that out, or give up.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2017 Jun 06, 2017

Copy link to clipboard

Copied

The same thing fixed for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 04, 2017 Jul 04, 2017

Copy link to clipboard

Copied

Love your share! It worked for me too

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2017 Oct 24, 2017

Copy link to clipboard

Copied

Awesome! That worked for me also! Webroot was the issue.

Thank you big time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 30, 2015 Mar 30, 2015

Copy link to clipboard

Copied

DISABLE 1 Password from Chrome Extensions, that worked for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2015 Jul 07, 2015

Copy link to clipboard

Copied

Simpler solution is to disable the space bar in Google Chrome.

Here's how to do it:

Install this extension (search for it in Google Extensions):  ShortKeys

Once activated go into it's settings and add the following rule:

type "space" (without quotes) into the key combo field.

Set the action drop down to Jump to tab or URL

Type "#" (without quotes) into the URL to match field.

Click save

Quit Chrome or refresh any open pages.

This effectively disables the space key from doing anything in Chrome.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2015 Jul 28, 2015

Copy link to clipboard

Copied

We are having the same problem and have narrowed it down to Microsoft Office for Mac, something about the office activation triggers the space bar hand tool shortcut to turn off.

I would like to override the shortcut in illustrators shortcut preferences but the spacebar doesn't register as a key stroke and only seems to accept letters or numbers. Any solutions would be very helpful.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 30, 2015 Sep 30, 2015

Copy link to clipboard

Copied

In my case, it was Webroot Antivirus causing conflict with the zoom shortcut in Photoshop. Shut it down and space bar started working again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

In my case conflict appears because a popup of iTunes was open asking for password.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 28, 2015 Oct 28, 2015

Copy link to clipboard

Copied

I'm having this issue for the second time. The first time I restarted Illustrator or my computer (don't remember) and it worked again. This time, restarting Illustrator didn't work, but closing Firefox did.

Plus, the problem comes back when Firefox is running again, goes away when I close it, etc.

CS6, iMac OSX 10.7.5

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines