• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
10

Object becomes pixelated when I apply grain texture

Community Beginner ,
Apr 29, 2018 Apr 29, 2018

Copy link to clipboard

Copied

When I apply the grain texture effect, the objects are super pixelated. Whether it be a gradient mask or a regular object, they always turn out pixely and not that stippled look it should be.  Below is an example...the left image was originally a blue rectangle before the texture was applied, and the right is a gradient with the texture applied.

What am I doing wrong? These aren't zoomed in really far or anything either.

Asset 2@3x.png

Views

18.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Apr 29, 2018 Apr 29, 2018

check the resolustion if it is set to High from

Effect-> Document Raster effects settings

Votes

Translate

Translate
Adobe
Community Expert ,
Apr 29, 2018 Apr 29, 2018

Copy link to clipboard

Copied

check the resolustion if it is set to High from

Effect-> Document Raster effects settings

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 30, 2018 Apr 30, 2018

Copy link to clipboard

Copied

Any effects in AI from Effects Panel in below section are raster effects. Did you add that texture from Effects Panel?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 30, 2018 Apr 30, 2018

Copy link to clipboard

Copied

Yes I applied from textures panel

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 30, 2018 Apr 30, 2018

Copy link to clipboard

Copied

Please show your original objects and your effects settings.

Also: how far you zoomed in?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

i changed the document raster effect settingd to high..still same problem..what do i do?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

It's a pixel based effect after all.

So when selecting a higher raster effect e´resolution you will get finer pixels, but still pixels.

 

So can you please show something and also tell us what you expect to happen?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 07, 2024 May 07, 2024

Copy link to clipboard

Copied

Thanks it worked!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 30, 2018 Apr 30, 2018

Copy link to clipboard

Copied

thanks! the resolution was not set to high. when i changed to high, it fixed the problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 22, 2020 Apr 22, 2020

Copy link to clipboard

Copied

Thank you! It was driving me nuts until I found your post.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 13, 2024 Feb 13, 2024

Copy link to clipboard

Copied

Hello, I have no idea if people are still having this problem, but none of the solutions below worked entirely for me. What did work: still go to Effects > Document Raster Effects Settings and under Resolution, even if its already 300 ppi and you're still having the pixilation issue, change it to anything on the Other setting (bottom of drop down), like say type in 600 ppi, and now it will load correctly. Not sure if this is a graphics card issue on my computer, but I'm sure someone else will have the same problem. Hope this helps!

adobe.JPG

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 13, 2024 Feb 13, 2024

Copy link to clipboard

Copied


@stephenb12860235  schrieb:

Hello, I have no idea if people are still having this problem, but none of the solutions below worked entirely for me. 


 

Everyone wrote the same as you did.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2024 Feb 14, 2024

Copy link to clipboard

Copied

The specific issue I had is that the raster effects were confiemed set to High 300 ppi, and when creating an effect it would look great, but after applying some sort of additional effect (blend mode change, opacity, etc.) or moving & scaling, it would automatically change and look low quality, even on export, still with the correct, High 300 ppi setting. I found that after it "breaks" like this, if I go back to the settings and change it to another high value (like 600 ppi) it would somehow "refresh" and the effect would look correct again. I could even change it back to 300 ppi after 600 ppi and it would look correct. I'm not sure if this is a new bug, or maybe an issue with my specific hardware, but I landed here after my issue, so I thought I'd share my fix in case any one else had the same issue. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2024 Mar 22, 2024

Copy link to clipboard

Copied

Same here.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 22, 2024 Mar 22, 2024

Copy link to clipboard

Copied


@Keller34138219fcoj  schrieb:

Same here.


 

Please show a screenshot that includes the grain settings, the document raster effects settings, the appearance panel and of course the object itself.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

Hello! 

I am having this problem too and tried all of the above and nothing is working! 

 

Been on going problem for a few months was hoping it was a bug that would get fixed but now I've come back to it again and it's still not working. 

 

I did an illustration at the beginning of the year when it worked fine, now im trying to do another and it seems to go pixulated when I move the gradient. It also seems to have a strange line through it with no grain and then the grain is all over rather than being in one spot.... sorry explained that badly but have included pictures so hopefully you can see what I mean!

 

Green one is the first illustration i did which is what i want it to look like!

 

Thanks 🙂 Screenshot 2024-05-02 at 15.07.06.pngScreenshot 2024-05-02 at 15.06.03.pngScreenshot 2024-05-02 at 15.06.18.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

It's a pixel based effect. So it will of course cause the object it has been applied to to become pixelated.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

Okay, How come it hasn't done the same to my previous illustration even though I followed the same steps? Is there a way to not have the grain all over? Thanks

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

Without even knowing what exactly you did, this is impossible to tell.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

Probably explained badly in my first post - I thought the images would do the talking! 

But I used a transparency mask following these steps - copy and pasting the element infront. Changing the colour. Then making a mask in the transparency window then un-clipping it. Then creating a shape over that, changing the fill to a gradient to determine where the grain is, then finally adding the grain ontop. 

 

It worked fine in the first illustration - I know it will always look pixulated. What I meant to say was that the pixels seem to get bigger like shown in the second image when I move the spot graident around or make any changes. Also cant seem to get an area of no grain like I have in first illustration - it's all over which wasn't happening before. 

 

Hope that makes more sense - Thanks 🙂 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

I'm sorry but no that doesn't make any sense.

And no, the images do not talk. Unless you show the layers panel, appearance panel, transparency panel for each of the affected objects. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

You could have Just asked me to show that if you actually wanted to help instead of being rude to me. Cheers for your help ...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2024 May 17, 2024

Copy link to clipboard

Copied

Having the same issue as you Lily, and knew exactly what you were talking about before you posted the pictures.

Stephen B said earlier in this thread that switching the Resolution in the Document Raster Effects Settings to something other than 300 and then back worked for them, and it did for me as well - but only until I try to move or edit the affected layer/object again. Not a very useful workaround, unfortunately. 

[Edited by moderator for abusive content]

Would love to hear if you've found a permanent solution!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 18, 2024 May 18, 2024

Copy link to clipboard

Copied

LATEST

 Aha glad you knew what I was on about, was starting to feel a little crazy! 

 

I managed to get it to work for me by lowering the resolution to 72 .... seemed to solve it for me! Rather than making it higher, My pages were set to A3 so not sure whether page size has something to do with it too. I'm not a professional only a beginner in illustrator so not sure on the technicals but once I lowered it was back to normal. 

 

I figured it out by going back to my first illustration and looking at the settings for that, so if you have other illustrations you've done a grain on, that may be helpful. 

 

Hope that helps! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 18, 2024 May 18, 2024

Copy link to clipboard

Copied

The crude pixelated display is on my machine caused by the GPU preview, changing to CPU preview and modifying a parameter shows a finer grain. 

The grain in the supposedly white/lightest areas can be removed by setting the Intensity percentage in the Grain effect to a value lower than 50%.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines