why is Illustrator flattening my export to photoshop?

Explorer ,
Apr 21, 2011 Apr 21, 2011

Copy link to clipboard

Copied

I have an index page, which I created in Illustrator that I am attempting to export to photoshop.  The problem is that when I open the Photoshop file, it has all been flattened into a single layer.  I made sure "flat image" is not selected in the export options.  Furthermore, I always get a pop up message that says "Some containers in the AI document have been flattened," every time I export.  The document is a single artboard with 9 layers (each layer representing a different element on the index page).

Any suggestions would be appreciated.

Also, if anyone is interested in assisting us with converting the Illustrator art to HTML and CSS, please email me at pcdavis@travelbrains.com.  Please only respond if you have a lot of experience with creating pixel perfect CSS and HTML from Illustrator.

Thanks,

Paul

Views

40.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 21, 2011 Apr 21, 2011

Copy link to clipboard

Copied

You have transparency on the layers (or at least the top layer) which Photoshop has to flatten to work with. Try moving the transparency to the bottom layer or adding some registration marks (small squares of color at top left and bottom right) and the export the layers individually . Then reassemble in Photoshop using the registration marks as guides.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 18, 2016 May 18, 2016

Copy link to clipboard

Copied

The registration marks should not be necessary when exporting with 'Use artboards' checked: in that case, all the layers will be the same size.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 22, 2011 Apr 22, 2011

Copy link to clipboard

Copied

Did you choose cmyk as the color model, the option for write layers is greyed out on rgb files?

Picture 3.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 22, 2011 Apr 22, 2011

Copy link to clipboard

Copied

One misunderstood feature is the export feature especially in this circumstance AI will attempt to write the layers butcannot always for various reasons and I do not believe transparency on its own is a reason to flatten.

You won't like this but in many cases you are better off opening or pasting or placing as smart object, if that does not serve your needs the old way around this is make a psd file with the amount of layers you require and paste  layer by layer, but if you do that and plan to revise in AI paste as smart objects if need be on a layer by layer basis or even object by object.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 06, 2013 Feb 06, 2013

Copy link to clipboard

Copied

The solution is not have more than three nested layer groups. Ungroup everything, and then put everything into no more than one top level group.

Also delete any hidden layers, and unlock locked.

Had this problem numerous times and this always works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 18, 2014 Feb 18, 2014

Copy link to clipboard

Copied

As usual dogmatic sweeping proclamations turn out to be wrong.

Nothing grouped in my file, no transparency, everything on its own layer, working in CMYK and attempting to export to CMYK, etc etc etc. I keep getting this OBNOXIOUS message. The worst thing about it is it can't even give you a clue. How hard can it be to have AI explain to you why it refuses to work? Not that I expect Adobe to ever get around to addressing fine points like this when they can't even deal with major issues plaguing their rental software.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 02, 2014 Apr 02, 2014

Copy link to clipboard

Copied

Took me a while to find this...but this did it for me....

http://fourshapes.com/articles/2007/07/29/some-containers-in-the-ai-document-have-been-flattened-ill...

Hope that helps...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2017 Jan 29, 2017

Copy link to clipboard

Copied

nothing in that url...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2017 Jan 29, 2017

Copy link to clipboard

Copied

You are replying to a 3 year old post which is linking a 10 year old blog article and you complain that this article is no longer there?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 22, 2014 Jul 22, 2014

Copy link to clipboard

Copied

This did work for me. Thanks, Brent! Just to be certain and clear for all skill levels, select all, then just keep hitting the command-shift-G until you hear that bump tone.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 10, 2017 Sep 10, 2017

Copy link to clipboard

Copied

Thanks very much!
You saved my day. You are right illustrator can't export grouped layers as a photoshop file(.PSD), when I ungrouped all layers everything gone fine.

For those who fight .psd file export problem in Adobe Illustrator just ungroup artworks and then try export.
Keyboard shortcuts Shift + Ctrl + G  or Shift + Command + G

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 13, 2017 Sep 13, 2017

Copy link to clipboard

Copied

Glad to be able to help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 18, 2016 May 18, 2016

Copy link to clipboard

Copied

Great solution! (Shouldn't be necessary though... 😉

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2017 Feb 08, 2017

Copy link to clipboard

Copied

Thanks alot Brent. I was stuck, This is really helpful

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 01, 2019 Jul 01, 2019

Copy link to clipboard

Copied

Works for me. I selected all layers and just go to Object>Ungroup two or three times to guarantee that there is no layer missing.

Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 17, 2020 May 17, 2020

Copy link to clipboard

Copied

Thanks
this worked for me. Nothing can be grouped and Text has to be rsterized.
No hidden files. BIG HUGE THanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 13, 2021 Feb 13, 2021

Copy link to clipboard

Copied

LATEST

THANK YOU

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2014 Apr 25, 2014

Copy link to clipboard

Copied

Hi paper1246,

I'm having the same problem. Exporting from CMYK to CMYK, keeping layers, no grouped elements... but Some elements in my file become flattened.

Unlike you, not all the elements become flattened, only some of them (well, several of them). I was trying to understand which was the criteria of the program for flattening some elements and some other not, I realised that flattened elements were those who have been cutted with a clipping mask. The other ones, that were drawn and not cutted, are kept in their layer.

Unfortunately I have still not a solution for that but perhaps your flattened objets are also cutted with clipping mask, in this case we can start to identify the problem.

Finally, the solution proposed by sparkyrose above, didn't work for me... Thank you anyway.

Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 26, 2014 Aug 26, 2014

Copy link to clipboard

Copied

I had the same issue recently. The workaround was to kill the layer effects on a type layer. Saved the file and opened in illustrator. All layers appeared.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2015 Nov 18, 2015

Copy link to clipboard

Copied

This worked for me. Had one small effect on an image mask and that resulted in the whole layer being flattened.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2017 Jan 11, 2017

Copy link to clipboard

Copied

I am having the same problem right now with CC 2015.5 I checked and none of my layers have any transparency, gradients etc. I removed layers that could cause problems just shapes and flat colors. Still flattens the file. I tried the crop marks trick worked on another file but not this one.

The screen shot is from my top layer in the file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 11, 2017 Jan 11, 2017

Copy link to clipboard

Copied

Can you post a copy of your file, with dropbox or similar?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2017 Sep 15, 2017

Copy link to clipboard

Copied

Hi everyone, i tried to export PSD from illustrator with different ways and these different methods are surly work for you.

(Method 3rd work for me with this attached preview file.)

METHOD 1:

All objects are in different groups and in contain in single layer. ** ITS NOT WORK FOR ME but you may try with your file.

1.jpg

-------------------------

METHOD 2:

and also i bring all the objects in layers with "Release to layer(Sequences)" and put all layer in single top layer. **STILL ITS NOT WORK FOR ME but you may try for your file.

2.jpg

-------------------------

Workable Solution for me

METHOD 3:

Select the object from the layer panel and go to Object > Resterize.. and follow the below instruction (user this method for all those objects which are not converted layers) and then Export > Select type PSD and save. Now open this PSD file to Photoshop and Boom! you just converted your AI file to PSD with layers.

3.jpg

I wish this will help for you! Cheers Designers!

Feel free to email: waleedmaalik@gmail.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2018 Aug 23, 2018

Copy link to clipboard

Copied

0down vote

I've wrestled with this problem a lot lately and sometimes I have no trouble, sometimes I do. At the moment I'm working on 18 Illustrator frames for an animation, so I need to export all of the layers to Photoshop for shading. All the frames are built the same way, in fact duplicates of each other in most cases. There's transparency, lots of groups, and clipping masks in each. The simplest frames exported just fine into Photoshop with the layers intact and with everything grouped, transparency and clipping masks ok. The more complex frames started to give me trouble, so I went through the options you all listed above. Copying and pasting the troublesome layers from Illustrator to Photoshop isn't an option since the elements have to stay in the same spot for animation. Bottom line: It was the clipping masks, not the grouping or transparency. At least this time!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines