• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Bug unter Mac OS Ventura: Color differences between GPU and software rendering

Explorer ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

Hey, there is a annoying bug unter InDesign 2022 and 2023 under Mac OS Ventura.

InDesign is rendering with GPU the colors unsaturated and wrong.

Only switching to the software renderer (shift+E) will render the colors correctly.

Is there any way to fix this?

 

I attached some examples.

 

Best

Sascha

 

TOPICS
Bug

Views

1.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Nov 08, 2022 Nov 08, 2022

Yes, Intel-Mode: Open Adobe Creative Cloud Manager, right-click InDesign and open it in Intel mode.

Likes

Translate

Translate

correct answers 1 Pinned Reply

Adobe Employee , Nov 07, 2022 Nov 07, 2022

Hi All,

 

We are aware of how annoying it could be. The team is looking into a known bug with Illustrator and InDesign. 

 

The workaround that has helped customers so far-

 

  • Open Adobe Creative Cloud Manager, right-click InDesign and open it in Intel mode.
  • Resolved by switching back to macOS Monterey.

 

Please try the workaround suggested and let us know if that works.

We'll keep you informed as soon as the problem is fixed.

 

Thanks,

Harshika

<Pinning the response to highlight>

Likes

Translate

Translate
Adobe Employee ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

Hi @Sascha Fronczek,

 

Thank you for reaching out, and sorry for the trouble you're experiencing issues with color rendering incorrectly on macOS Ventura. We are able to reproduce the issue at our end, and we'll go ahead and log a bug for it.

 

Could you please share the screenshot of "About this Mac" for better investigation?

 

We'll escalate the issue to the team for investigation.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Thank you Harshika,

Screenshot is attached. I fiured out, that under Intel-Mode, the issue is gone.

 

Best 

Sascha

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Thanks for the link.
But I have been working in GPU mode for years and there have never been different colors between software and GPU.
All colors are desaturated in InDesign as soon as GPU mode is used. You can't really work that way anymore. The software mode is very slow 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

I'm not really sure what I can do for you at this point.

Perhaps @rob day can help you out - he's very good with this sort of behaviour. 

 

I don't even know what Graphics Card you have - your OS - your RAM - or anything about your setup that can help you out. 

 

We need a lot more information from  yourself in order to help you. 

 

Can you please provide your system settings? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Thanks alot! 
I’m using a MacBook Pro 16" with a M1 Max and using Mac OS Ventura with Indesign 17.4 and 18.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Fun fact: When I open InDesign in Intel-Mode, the problem is gone.

But InDesign runs now on Rosetta 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Same here with Mac Studio M1 Ultra and InDesign 2022 / InDesign 2023.

Using software renderer or Rosetta will render correct colors, but this is extreme slow. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

BTW: Illustrator under Mac OS Ventura has the same issue. GPU wrong colors, CPU right colors.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Hello. I have the same issue on Illustrator 2023 and Indesign 2023 which I resolved by switching back to macOS Monterey. I'm on a Macbook M1 Max. Problem well related to MacOS Ventura update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Hello. I have the same issue on Illustrator 2023 and Indesign 2023 which I resolved by switching back to macOS Monterey. I'm on a Macbook M1 Max. Problem well related to MacOS Ventura update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 05, 2022 Nov 05, 2022

Copy link to clipboard

Copied

Hi, 

I have the same problem.
Do you have a simple/quick solution without having to format the mac to reinstall Monterey?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 05, 2022 Nov 05, 2022

Copy link to clipboard

Copied

Open your Adobe Creative Cloud Manager and right click on InDesign and open it in Intel mode. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 05, 2022 Nov 05, 2022

Copy link to clipboard

Copied

Yes I tested this method but it is much slower than with the GPU.
I finally opted to reinstall Mac OS Monterey, while waiting for an update for Ventura.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 07, 2022 Nov 07, 2022

Copy link to clipboard

Copied

Hi All,

 

We are aware of how annoying it could be. The team is looking into a known bug with Illustrator and InDesign. 

 

The workaround that has helped customers so far-

 

  • Open Adobe Creative Cloud Manager, right-click InDesign and open it in Intel mode.
  • Resolved by switching back to macOS Monterey.

 

Please try the workaround suggested and let us know if that works.

We'll keep you informed as soon as the problem is fixed.

 

Thanks,

Harshika

<Pinning the response to highlight>

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Hi, same problem here... Is ther any other solution than switching back to macOS Monterey ? 

Are you working on resolving this problem ? 

Thank you very much 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

Yes, Intel-Mode: Open Adobe Creative Cloud Manager, right-click InDesign and open it in Intel mode.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Thanks, ok. But they says that it will use Rosetta and slow photoshop, i don't want that 🙂

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Opening INDesign in Intel mode has nothing to do with photoshop.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Hello,

 

I got a new MBP and I'm having trouble getting my colors to show as RGB colors in the working space. The colors are washed out (in CYMK colors). I have already changed my Transparency Blend Space > Document RGB and it has not worked. I created my document as a Web doc and the Color Settings are correct as RGB: sRGB IEC61966-2.1 and CMYK: U.S. Web Coated (SWOP) v2. When exporting, the colors show up correctly, but I need to have the colors showing RGB in the working space as I work in the print and digital(web) space. I even restarted Indesign AND my MBP to see if things will update, but it didn't.

Can anyone help me on this? I'm on my wits end to get colors showing as RGB. I got RGB colors in the working space on my old MBP but duplicating the settings has not worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Hi @AlwaysSave,

 

Thank you for reaching out. If I heard you right, you're experiencing a similar issue reported here: https://community.adobe.com/t5/indesign-discussions/bug-unter-mac-os-ventura-color-differences-betwe....

 

If so, please try the suggested workaround and let us know. We will keep you posted on the bug update.

 

Thanks,

Harshika 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Hi Harsika,

 

Thank you! This solved the issue! Appreciate your help on this.

 

K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Awesome. Glad to hear you're able to resolve the issue by following the workaround. We'll keep you posted on the bug update.

 

Have a nice day!

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Same here with InDesign and Illustrator, after updating to Mac OS Ventura on a McBook Pro M1 16'' the colors are looking very dull. Under Monterey it was fine. Hoping a fix will com quickly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines