change hyphenation rules?

New Here ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

The settings for Dutch language hyphenation seem to include a rule that words containing a dash should not be hyphenated after the dash. That may be true for other languages, but not for Dutch (as confirmed by all major works on editing and spelling).

Up till now, I just added a discretionary hyphen and the word got hyphenated correctly (not adding a hyphen, but just putting the part of the word after the dash to the following line). Adding each instance to the hyphenation exception list is rather cumbersome (and not very useful, think for instance about names of married women).

But I wonder, is there a way to delete or bypass this rule altogether?

TOPICS
Feature request

Views

87

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Jul 28, 2022 Jul 28, 2022

Hi @Frits5C99 ,

 

Thanks for reaching out. I found a similar discussion which you can refer to here https://community.adobe.com/t5/indesign-discussions/hypnation-results-to-two-hyphens-in-one-word/m-p/12071624#M431048 

 

Let us know if this helps or if you need any further assistance.

 

Regards

Rishabh

Likes

Translate

Translate
Community Expert , Aug 10, 2022 Aug 10, 2022

Set a acharacter style to “No Language”.

Likes

Translate

Translate
Adobe Employee ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

Hi @Frits5C99 ,

 

Thanks for reaching out. I found a similar discussion which you can refer to here https://community.adobe.com/t5/indesign-discussions/hypnation-results-to-two-hyphens-in-one-word/m-p... 

 

Let us know if this helps or if you need any further assistance.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

Hi,

 

We would like to follow up on this issue, did the suggestions help?

 

Regards
Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

Sorry for reacting so late – an unexpected overload of work. Also, I didn't want to risk that a change in settings would ruin my work in progress.

The problem for me was not the doubling of hypens as in the example given:

   Oost-

   -Azië,

but in the fact that the words with a dash in it were not hyphenated at all at the spot of the dash. For instance, I got:

   Mrs. John-

   son-Peterson

instead of

   Mrs. Johnson-

   Peterson,

Even if the latter would produce a better composed paragraph.

Nevertheless, I changed hunspell to proximity and that seems also to do the trick in my case:

   We waren afgelopen jaar in

   Oost-Friesland op vakantie waar we

   veel plezier hadden.

became:

   We waren afgelopen jaar in Oost-

   Friesland op vakantie waar we

   veel plezier hadden.

which is exactly what I would want here.

However, with three book projects going and nearly finished, I feel a bit wary to do this. I don't know what the difference is between hunspell and proximity. (I even hardly know what they are.) Will changing this have other effects on ongoing projects, or on older, finished projects apart from things like I gave in the examples?

 

Also see my answer to Willi Adelberger below.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

Set a acharacter style to “No Language”.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

That does the trick as well and it is something I can be sure of it has no other unwanted results!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

LATEST

For anyone even worse with GREP searches than me: use [\u\l]+-[\u\l]+ (depending on your project with 'no style' as, sadly, you can't apply two styles to the same word) and change this to style 'no language'.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines