• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Help! New paragraph spacing system is causing problems

Participant ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

Adobe's new "space between paragraphs using same style" feature is really messing up my document. I would think it was a good idea, if they hadn't apparently destroyed the old paragraph spacing system in order to add it. I just tried to put some space after a paragraph that does not have a style applied to it, using the Paragraph palette window, and nothing happened. (I do not have the text aligned to a grid, or any interfering text wraps, or any character styles applied.) I now can't add any space after a paragraph unless I build a new style, and put amounts for both "space after" and "space between paragraphs"? I don't want to have to build a paragraph style every single time I want to add some space after a line; what a waste of time. Is there some preference I can adjust?? I can't see why they would have the "space after" option in the Paragraph window if it doesn't do anything, but how do I get it to work now? This issue totally screwed up my day today. I looked to see if Adobe had written out how best to use this new system, but found nothing.

Views

3.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 12, 2018 Dec 12, 2018

While it is a confusing feature, in my opinion it is actually one of the best enhancements to InDesign, mainly useful for numbered and bulleted lists.

For example, if you have a bulleted list paragraph style with a space before setting of p6 and a space after setting of p10, and you change Space between paragraphs to zero, the space before affects only the first paragraph in the list and the space after affects only the last paragraph in the list.

It's as if all the paragraphs in the list, which

...

Votes

Translate

Translate
LEGEND ,
Dec 12, 2018 Dec 12, 2018

Copy link to clipboard

Copied

The default value for Space Between Same Paragraphs is "Ignore". Check if you did not change that to "0mm" (or your local equivalent measurement unit). If it is set to "0", the feature appears to do exactly what it should.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 12, 2018 Dec 12, 2018

Copy link to clipboard

Copied

Thanks--I didn't understand the new symbol for the "space between" area, so I didn't see it. (I didn't actually put anything in there, so I'm not sure how the 0 got in there, but it wasn't set to "ignore.")

It would be helpful if InDesign made it easier to find explanations of these changes. I've searched the site, and found no tutorial or anything on this new feature. It's probably up there somewhere, but searching for the name of the feature doesn't bring it up.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 12, 2018 Dec 12, 2018

Copy link to clipboard

Copied

Another issue is that there's never been such a thing as "ignore" as a choice for those palette windows before, so I didn't know about it. I thought by leaving it blank, I had already set it to ignore. It seems that just clicking in there, maybe without realizing it, takes away the "ignore" and destroys it, even if you don't put a number in.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 12, 2018 Dec 12, 2018

Copy link to clipboard

Copied

Hi chrisuren ,

you are right. The input field for Space Between is a bit strange.

Once set to a number one cannot reset it to "Ignore" using the keyboard only.

The arrow keys ( up or down ) will never change the value, a digit, to the default "Ignore" state.

Even if you select the number and type in "Ignore" it would not change to "Ignore".

Instead you'll get an error message that the value you typed is out of range.

Regards,
Uwe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 12, 2018 Dec 12, 2018

Copy link to clipboard

Copied

While it is a confusing feature, in my opinion it is actually one of the best enhancements to InDesign, mainly useful for numbered and bulleted lists.

For example, if you have a bulleted list paragraph style with a space before setting of p6 and a space after setting of p10, and you change Space between paragraphs to zero, the space before affects only the first paragraph in the list and the space after affects only the last paragraph in the list.

It's as if all the paragraphs in the list, which all have the same paragraph style applied to them, have been grouped together and treated as if they were a single paragraph.

List with zero space between paragraphs:

In previous InDesign versions, this would have required 3 paragraph styles for the list paragraphs, now it only requires one.

The same list set to Ignore:

I wish that Adobe had implemented this feature in InDesign as elegantly as it was implemented in Adobe FrameMaker. But that does not take away from its usefulness.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 12, 2018 Dec 12, 2018

Copy link to clipboard

Copied

It would be helpful if InDesign made it easier to find explanations of these changes. I've searched the site, and found no tutorial or anything on this new feature. It's probably up there somewhere, but searching for the name of the feature doesn't bring it up.

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

I'm finding it an absolute pain in the A*.

I loved paragraph before and after and it worked just beautifully for me. Especially when setting typography initially, pre-paragraph styles.

I try using 'ignore' and I try setting it, and I try sticking to my usual 'before' and 'after'...

it isn't working as one would expect. It's fine IF I have paragraph settings defined, but I don't when I'm initially designing...

Is there any way to TURN that OFF? I'd prefer to work the way I have.


Ta

Ra

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

Hi RaCreate ,

it should be turned off (Ignore) by default. At least that's with my InDesign.

Deselect everything and see if it's turned on in the Paragraph Panel. And if it's turned on, turn it off.

Also check this when no document is open.

Regards,
Uwe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

Hi ya.

Ignore doesn't allow it to act as it used to though. As in, it doesn't my set space before and space after measures (after a HARD RETURN). ONLY works when I have a paragraph style set.

That's why it's 'doing my head in'.

So, ignore works the same way as it used to for you?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

RaCreate  wrote

… So, ignore works the same way as it used to for you?

Exactly.

Regards,
Uwe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 07, 2019 Mar 07, 2019

Copy link to clipboard

Copied

Okay. Ta so much.

Just did some testing and it was A.O.K, so I can only assume User Error. Perhaps I'd had a '0' as opposed to 'ignore'.

I'll be stoked if this has sorted it.

Ta.

Cheers,

Ra

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 21, 2023 Apr 21, 2023

Copy link to clipboard

Copied

Agreed. Space after should not be disabled. If it is, the dialog should be made null. 
Too many ways to do the same thing. 
Ultimately, the previous way was predictable and allowed me to achieve every possible or necessary. The new way has the same range of layout results, but with more fussing and dead end UI pathways.     

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 21, 2023 Apr 21, 2023

Copy link to clipboard

Copied

LATEST

Well, this is a fairly zombie thread (4-5 years old) and the feature is no longer exactly new.

 

All imagined problems are also completely avoidable by simply never setting Space Between to anything but 'Ignore.'

 

I concur with the experts of the near past, though: it's an extremely flexible way to manage spacing for all sorts of in-text lists. Unfortunately, it doesn't export to EPUB, so the three-style method is still needed for that. Which is, IMVHO, a real problem.


╟─ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ─╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines