• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

InDesign applies 'title case' on its own

Explorer ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

I am editing text in an existing document. As I continue typing, InDesign CC 2017 sometimes decides to change the letter of the earlier just-typed words to a capital. This doesn't always happen, but once it starts it continues until I move somewhere else in the document. (It may or may not happen in the new location as well.) Paragraph style is set to Normal case.

How can I stop this from happening?!

Views

3.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 12, 2016 Dec 12, 2016

Barbara is correct, as you know—I was out most of yesterday and did not get back to this. When I looked it up, I saw that I am (was) one of many who thought incorrectly that there was a character style for this.

More questions, though:

• Does it do this in all documents or just this document?

• Have you reset preferences?

https://helpx.adobe.com/indesign/using/setting-preferences.html

Likes

Translate

Translate
Mentor ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

Most likely, Autocorrect is ON. Check Preferences > Autocorrect > Autocorrect Capitalization Errors

autocorrect.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

Thanks — sounds like a good work-around.

But autocorrect of capitalization errors is there because it can be useful — what's not useful is when InDesign suddenly, unpredictably decides that every word should be capitalized for no reason at all.  Sounds like a bug needs attention.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

I strongly doubt ID 'decides' itself to correct your writing. It must be active Autocorrect, or maybe you accidentally turn on Title Case (may it have some custom kb shortcut assigned? May it be Style settings?). It's hard to tell without seeing actual doc on actual machine.

Basically, I prefer text editors (like Word) for entering and spelling bigger amounts of text, and keep ID's Autocorrect OFF. InDesign is for design.

Edit: additionally, you can check Spelling tab in Preferences. Word capitalization is involved there, too...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

My thoughts are much the same. Word is a weird app with many undesirable & unpredictable behaviors, but there aren't many alternatives for editing large volumes of text where paragraph & character styles are involved. (In fact, the text in this document was created in Word.)

But I can be making two corrections in the same paragraph, only to find that one is fine, while each word in the other correction (in the same paragraph) has an initial cap applied.

If I watch the screen, it does look like an autocorrect in that it happens as soon as I add a space after the word — but what is it correcting?  On what basis is capitalizing words in the middle of a paragraph a valid 'autocorrect'?

I am not aware of any way to 'trigger' Title Case with a keyboard shortcut. I can create a shortcut for Type/Change Case/Title Case, but that only works if text is selected before it is invoked. (It does not change case for the next word typed.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

Did you create this document yourself, or did someone else?

The two of you have covered all of the usual suspects, and while there is a default keyboard shortcut to assign title case, it's only to the selection, and doesn't stay on (as you stated). Could there be a GREP style on the paragraph?

InDesign CCss_004.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

Watch both your Paragraph and Character panels. If a Character style is applied manually, it will be highlighted. Notice that this panel says "None". But when a Character style is applied automatically (Drop Cap, GREP, Nested Styles), the Character Style will be at the bottom. That's where this panel says "Bold".

Does your Character panel say that a style is being applied?

It could be any of the above reasons, so tell us more, or post a screen shot.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

jane-e—I can'f figure out how title case can be assigned via a character style... what am I missing?

InDesign CCss_006.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

No character style is active in my document — and as BarbBinder notes, character styles don't provide a 'Title Case' option.  Just like ¶ styles, the only options are for normal, all caps, small caps.  the only title case option of which I'm aware is in the Type menu [Type/Change Case/Title Case], and it applies only to selected text.  If there's a mode that makes everything title case, I've never seen or heard of it.

It is true that there's a spelling preference to check uncapitalized words, but that obviously does not mean that every word should be capitalized — and, as noted, it's an intermittent problem.

There are no nested styles in this document, no GREP styles.

So it seems to me that InDesign has a bug that causes it — sometimes — to 'correct' a word by capitalizing the first letter, even when there is no reason to do so.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

Ok, I think you've approached this very systematically, eliminating the possible suspects.

The next step is to report it to Adobe:

Wishform - Adobe InDesign

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 12, 2016 Dec 12, 2016

Copy link to clipboard

Copied

Barbara is correct, as you know—I was out most of yesterday and did not get back to this. When I looked it up, I saw that I am (was) one of many who thought incorrectly that there was a character style for this.

More questions, though:

• Does it do this in all documents or just this document?

• Have you reset preferences?

https://helpx.adobe.com/indesign/using/setting-preferences.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 12, 2016 Dec 12, 2016

Copy link to clipboard

Copied

jane-e —  

The problem seems to come and go for no reason that I can discern, so I will have to do some more checking to be sure of this. 

The document in question is the first new document since updating to CC 2017. (Most of the documents I've been working on were created in CC 2016.)  A total reset of preferences might help, especially if some old setting was treated incorrectly during the update. 

I'll post another response to this thread if I have anything new....

Peter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 13, 2016 Dec 13, 2016

Copy link to clipboard

Copied

Thanks!

It doesn't explain why or how it happened, but after I trashed the preferences and recreated them all, the problem appears to be corrected.  [So far, at least — If it starts up again, I'll add to this.]

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 13, 2016 Dec 13, 2016

Copy link to clipboard

Copied

When InDesign acts flaky, the best thing to do is to trash preferences. It doesn't happen often, but it does happen, and this usually takes care of it. Do post again if it comes back, but let's hope it's gone forever!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 20, 2017 Jul 20, 2017

Copy link to clipboard

Copied

I also have this issue on occasion. I am starting to wonder if it has to do with a file that is edited by multiple people -- some on Mac and some on PC? That is my best guess at this point. And no, I do not have a fix. It's driving me batty.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2022 Aug 24, 2022

Copy link to clipboard

Copied

I was having the same issue and discovered that my F3 was inadvertently clicked ON. F3 capitalizes words. The problem was solved when I pushed F3 (duh!). 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2022 Aug 24, 2022

Copy link to clipboard

Copied

Oops! F3 was apparently not the problem. I copied the problem sentences and replaced the original sentences and now the problem seems to be solved. Hopefully. We'll see...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2022 Aug 24, 2022

Copy link to clipboard

Copied

LATEST

Oops again! An Adobe agent suggested I update InDesign, which I did. NOW the problem appears to have gone away. Maybe. Forget about the F3 stuff...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines