• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

InDesign Opening Files As Read Only - Preventing Saving

New Here ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

We are experiencing an issue with Adobe InDesign in which it opens files with only read permissions, so when the user tries to save the file it errors and the user is forced to use Save As and use a new file name.

 

Details:

Software: Adobe InDesign 2024 (19.4.0.63)

Device: macOS 13.5.2 (22G91) (Build 22G91)

Storage: Files stored on Shared Drive (SMB)

 

We have checked on the server where the files are stored, and Computer Manager confirms that the user has the file open in "Read" mode instead of "Write+Read". We have verified that the user has Full Control permissions to the file and that no other user is trying to access the same file at the same time.

 

Any help is appreciated, thanks.

TOPICS
Bug , Sync and storage

Views

421

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

Hi @163773218923cn , This seems to be an ongoing problem with certain server configurations, see this thread:

 

https://community.adobe.com/t5/indesign-discussions/indesign-2023-makes-a-read-only-file/m-p/1463237...

 

Can you confirm that the Save As has to be to a new file name—you can’t overwrite the open file with a Save As to the same name?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

System Preferences -> Security & Privacy -> Accessibility -> Unlock in lower left -> Add Adobe Softwares -> Make sure they are checked. Next, scroll in the left column to "Full Disk Access" -> Add Adobe Software -> Make sure they are checked. Click the lock in the lower left.

If open, InDesign will need to be restarted for changes to take effect.

Mike Witherell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

The other thread has 253 replies and 37,000 views, so it is an ongoing problem. Early in the thread I thought the problem was with fies converted from earlier versions, but it is clearly a server problem Adobe has not been able to fully solve.

 

If @Mike Witherell ’s security fix doesn’t work for you, another scripting approach would be a Save As to a temp file, Save As back to the original, and delete the temp. I’ve never actually experienced the problem, so it is difficult for me to test, but you could try this script and see if it makes the file writeable:

 

 

 

var d = app.activeDocument;
var fn = d.fullName
var fp = d.filePath;
var n = d.name;
var tp = fp + "/Temp-" + n;
d.save (File(tp));
d.save (File(fn));
File(tp).remove()

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 31, 2024 May 31, 2024

Copy link to clipboard

Copied

Thank you both the the replies and suggestions.

 

I will try the setting change to 'Full Disk Access' and see if the issue keeps happening or not, and then try the script to see if that helps.

 

Regarding the first reply, unfortunately, I can confirm that we can't use Save As then then use this to overwrite the original, getting the following error:

Screenshot 2024-05-30 163235.png 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 31, 2024 May 31, 2024

Copy link to clipboard

Copied

Did you try the script or is the script triggering the error message?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 31, 2024 May 31, 2024

Copy link to clipboard

Copied

Here’s a compiled version, which you can copy to your Scripts panel folder:

 

https://www.dropbox.com/scl/fo/m25obb4y46ux830sz4poz/AMrs6mNDpXODOPlWZYCxur0?rlkey=xeiri0z4xa9mcc4f5...

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 20, 2024 Jun 20, 2024

Copy link to clipboard

Copied

I've the same problems with InDesign-Files opening in just "read only". My PC is running windows 10. 

Simple solution: Klick the file with right mouse click and choose from the pop up menue "Open with" > choose InDesign.

With this methode all files open in "read and write" modus again.

I know it should work with just a doublklicking on the files, but who cares 🙂

Hope that helps and works for you, too.

free your mind

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2024 Jul 09, 2024

Copy link to clipboard

Copied

LATEST

It seems that the file size has also an impact on creating this problem. The before mentioned "right mouse click"-method does not work with big files (2 GB and more). Here it is helpfull to wait a few seconds (at least 10 seconds) after you selected your InDesign-document. Give your system the time to "preload" all date it needs before doubleclicking to open your file. Its more cost effective, than to try again and again, till the file finally opens in "read and write". Its not the solution in solving this problem, but less stressfull.

free your mind

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines