pdf

New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Hello,
We are a Publishing House and we have noticed three serious problems with pdf files created from Adobe InDesign (version 16.4)
1. Although most of the soft hyphens appear correctly, occasionally a soft hyphen appears in the pdf as a hyphen superimposed over a letter.
As we are preparing books for printing, this a very serious problem for us.
2. Also, when working in InDesign, the program often 'loses' whole lines and paragraphs, and when the pdf is created, these lines and paragraphs are missing. Again, this is a very serious problem for us in preparing books.
3. Another problem is that, when working with a pdf, when we try to select the final word of a line, the first word of that line is also selected.
As a result of these problems, we can never be sure, when we close a pdf and send it to the printers, that the file is as we expect it to be.

Is there anyway that we can solve these?

TOPICS
Bug

Views

332

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Participant , Mar 16, 2022 Mar 16, 2022
Hey I downloaded your file and figured it out. It is an issue with the Adobe Garamond font you are using. It includes extended hyphenated glyphs. Just retype "consent" out to include a hard hyphen ( con-   sent ) of your liking and boom. It's not common but there you go.

Likes

Translate

Translate
Participant , Mar 16, 2022 Mar 16, 2022
You're welcome! It seems as many Garamond fonts are like this, but try this first: Under Windows / Type / Paragraph settings, click the three line breadcrumb icon on the top right of that window - Select: " Adobe Paragraph Composer ", and try exporting a PDF to see - I got the prebaked ligatures to go away.

Likes

Translate

Translate
Adobe Community Professional ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

This could be cause by many things, but high among them is fonts, particularly multiple versions of the same font name (activated through both Google fonts and Creative cloud, for example).

 

You might also want to check using the newest version of InDesign (make a copy of your file, don't use the existing file as there may be other unexpected changes, including text reflow).

 

It would help in diagnosis if you told us your OS and hardware configuration.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Regarding using the newest version of InDesign, it seems that, unfortunately, the logitech craft keyboard that I use is not compatible...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

What makes you say that?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

1. Happens when the world composer instead of the paragraph composer is used in combinatiuon with tagged file export.

2. THis is a known failure. As far as I know the Adobe team is working on it. But I would suggest to submit a bug report, to show the urgency. But it can also happening like in nr 1.

3. ? I do not know it, I have never seen it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

You haven’t told us how you’re creating these PDFs (what are your export settings?) nor have you told us how you're checking them. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Thank you all for the replies!

1. I am uploading a sample page of the file that the error occurs both in pdf and indd format.

Regarding the suggestion to use the current version of InDesign I will try it.

I work both on a Macbook air 2017 Mojave 10.14.6 and on an iMac 2018 Big Sur 11.5.1.

2. I have reported many times that issue.

Regarding the question how I am creating the PDFs, I use the standard presets:

Adobe PDF Print, Press Quality.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Try PDFX/4

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

With PDF 4 it seems fine. However, I tried also exporting the file with Press Quality preset again and now the bug does not appear...

How can I be sure that I will send a pdf to the printers and this superimposed hyphen will not appear?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

If there's a problem, any competent printer will let you know.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Hey I downloaded your file and figured it out. It is an issue with the Adobe Garamond font you are using. It includes extended hyphenated glyphs. Just retype "consent" out to include a hard hyphen ( con-   sent ) of your liking and boom. It's not common but there you go.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Thank you. Could you propose a font that does not have such problems?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

You're welcome! 

It seems as many Garamond fonts are like this, but try this first:

 

Under Windows / Type / Paragraph settings, click the three line breadcrumb icon on the top right of that window - Select: " Adobe Paragraph Composer ", and try exporting a PDF to see - I got the prebaked ligatures to go away.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Thank you.

The bug does not appear. However, when I am trying the previous way it does not appear as well.

I think that this is a bug and it has to be fixed when we are talking of printing books of over 500 pages.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

I would keep the Adobe Paragraph Composer selected for that document, create the PDF to proof before it hits the printer - and just to make sure, I'd print a few pages just to make sure. I was able to make the ligatures display correctly using that method.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

Hi sister Photini,

Willi is right, I think!

 

You see a well known bug that I already can trace back to InDesign CS6 version 8 that never was fixed.

The cause of the issue is the used paragraph composer: Adobe World-Ready Composer in combination with other formatting properties I cannot really pin-point.

 

SymptomsShowing-CharacterOverHyphen-PDF-X-4-TagsEnabled.PNG

 

Solution 1 ( preferred 😞

Use the Adobe Paragraph Composer instead.

 

Solution 2 ( barely acceptable )

Do not use the option "Tagged PDF" in the PDF export setting.

 

Tested both solutions with your InDesign document:

InDesign 2021 version 16.4.0.55 on Windows 10. Download the test files from my Dropbox account:

https://www.dropbox.com/s/v3mqabm4frpqas1/CharacterOverHyphen-Tests-by-Uwe-Laubender.zip?dl=1

 

Here one other discussion about the same issue we had last year in the forum:

 

Automatic hyphens randomly have letters in them
bracewell4213, Jul 20, 2021

https://community.adobe.com/t5/indesign-discussions/automatic-hyphens-randomly-have-letters-in-them/...

 

 

Please support the following bug report at InDesign UserVoice and vote for fixing the issue:

 

PDF Hyphenation Bug when line has cross-reference, hyphenated word, and option is to create Tagged PDF
Sonny Rafael, February 13, 2019

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs/suggestions/36835285-pdf-hyphenatio...

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 19, 2022 Mar 19, 2022

Copy link to clipboard

Copied

Thank you for your time!

I will try from now on Adobe Paragraph Composer. I hope that this will be all right with language Greek-Polytonic(ancient greek) that we use for our books in Greek.

Regarding using the current version of InDesign, I use the Logitech Craft keyboard, and I found that it is not compatible with the latest version of ID. Do you know anything about this? Will there be any update that will make Logitech Craft keyboad working with the latest versions?

Thank you ery much!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 19, 2022 Mar 19, 2022

Copy link to clipboard

Copied

Any update of that sort would need to come from Logitech, I think. Have you checked with them?

I find it a bit surprising that a keyboard that works with version 16 does not work with 17. A quick search of the issue turned up this thread: https://community.adobe.com/t5/creative-cloud-services-discussions/logitech-craft-keyboard-crown-fun... which is from last year, but maybe still relevant, and it links to https://www.sir-apfelot.de/en/geloest-logitech-craft-drehrad-funktioniert-nicht-mehr-in-photoshop-31... which has the instructions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 19, 2022 Mar 19, 2022

Copy link to clipboard

Copied

LATEST

The Adobe Paragraph Composer is good for any text with Left-To-Right (LTR) text. The world composer should only be used when RTL text comes into a paragraph, or Asian or Indic languages you need to use one of the World Composers. But for LTR-only text never, as it will also cause a non optimal hyphenation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines