Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Random character superimposed on hyphen

Explorer ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Dear Sir, dear Madam,

I am really sorry but the last release of InDesign (16.0.1.x64 on Windows 10) is full of new bugs and making me mad.

After the impossibility to create several files (see my previous post on this forum), I have now the following crazy problem.

When I export my book in PDF, many hyphens are superimposed by other characters. On a book of 232 pages, this happens 45 (forty five!!!) times, i.e. a good third oh hyphens. Please note that I have suppressed all manual word breaks, so that the hyphens are only generated by my settings (at least 8 characters in the word, 4 at the end 4 at the beginning of the next line).
I did not have this problem in the former release of InDesign.

To be clearer, I attach two screenshots of the same page 52 in InDesign and the result in Acrobat DC. In the first hyphen of the page (within a red ellipse), a letter "M" is added??????? Then two other hyphens are OK (green).

Page 52 (InDesign).pngPage 52 (Acrobat).png

Thank you for your help: I am stuck ad I must deliver my work next Monday...
Regards

TOPICS
Import and export

Views

277

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jan 29, 2021 Jan 29, 2021
Est-ce que cela se produit sur tous les fichiers ou juste un seul ? Est-ce que cela se produit avec une autre police ? Dans un premier temps, je vous suggère d'exporter le fichier en idml et de le rouvrir. On peut aussi réinitialiser les préférences : il faut relancer l'application tout en appuyant simultanément sur Maj, Ctrl, Alt [Windows] jusqu'à l'apparition du message demandant confirmation.

Likes

Translate

Translate
Adobe Community Professional ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Est-ce que cela se produit sur tous les fichiers ou juste un seul ? Est-ce que cela se produit avec une autre police ?

Dans un premier temps, je vous suggère d'exporter le fichier en idml et de le rouvrir. On peut aussi réinitialiser les préférences : il faut relancer l'application tout en appuyant simultanément sur Maj, Ctrl, Alt [Windows] jusqu'à l'apparition du message demandant confirmation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Merci beaucoup pour votre réponse.

J'ai investigué et j'ai en effet compris que cela venait d'une police dont je n'avais pas la licence. Je l'ai remplacée par celles que j'avais achetées sur le site de Monotype myfonts.com (Adobe Garamond Pro) et tout est rentré dans l'ordre.

Merci pour votre conseil très avisé !

Cordialement

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Tant mieux si le problème est résolu, mais vous écrivez : « J’ai investigué et j’ai en effet compris que cela venait d'une police dont je n’avais pas la licence ». Le fait que vous déteniez une licence ou non n’a aucune incidence sur l’export PDF et de manière générale n’a aucune incidence technique. La police que vous utilisiez était peut-être soit corrompue, soit mal codée. Par curiosité, de quelle police s’agissait-il ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Et si je peux me permettre, on met des espaces fines (insécables évidemment) devant les points d’interrogation et d’exclamation, pas des fortes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

I have the same problem, but the solution does not work for me, I do not think there is any problem with font licenses (if that is what jmlevy said; my French is not that good, sorry!). I also tried the fix suggested here: https://answers.acrobatusers.com/When-I-print-Adobe-PDF-strange-symbols-document-q1929.aspx - no success either. This is a major problem, does anyone have more ideas what to do? I have InDesign 16.1x64 on Win10. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

I have the same problem, but the solution does not work for me, 

Which solution? No solution has been given, except that the OP said that he choosed another font, because he thought (and he was wrong) that he was using a font which was not properly licenced.

I do not think there is any problem with font licenses (if that is what jmlevy said; my French is not that good, sorry!).

At the contrary, I explained him that the issue was not relative to any licence problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 23, 2021 Apr 23, 2021

Copy link to clipboard

Copied

Thanks for the clarification, then I really misunderstood!

Still, the problem remains, I have hundreds of pages of text, into which InDesign inserts roughly five or six random letters. If I have to find those manually before handing in the pdfs I will go crazy! What can I do? I've worked with CS5.5 for years, which used to insert blank pages occasionally; that was mildly irritating, but easy to see and fix. I was hoping to get rid of that with the update, but now I want it back ...

One thing I noticed already: If I use Acrobat to search for "-" in the pdf, it does not find the hyphens from (correct) automatic hyphenation, but the ones with the superimposed letters are found. Also, new deatil: I just noticed that the problem goes away if I export with the "Press quality" and "smallest file" presets. It must be something in the "High quality print" settings, but I have no idea what it could be.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 23, 2021 Apr 23, 2021

Copy link to clipboard

Copied

I just noticed that the problem goes away if I export with the "Press quality" and "smallest file" presets. It must be something in the "High quality print" settings, but I have no idea what it could be.

Ask the Acrobat forum, maybe?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 06, 2021 May 06, 2021

Copy link to clipboard

Copied

Short update, in case somebody else encounters the issue: The problem seems to be pfd tags. If I export without the option to create PDF tags, everything seems to be fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

I had the same issue and by unchecking the pdf tags I could get rid of the problem! Thanks so much to "defaultevdyl28fcq77"! This rescues my day 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

Elena said: "I had the same issue and by unchecking the pdf tags I could get rid of the problem!"

 

Hi Elena,

thanks for sharing, that's interesting!

 

Because there are other bugs with text composition that can be solved only if this option is enabled.

Some issues with the start of text in tables and others with registering text on baseline. Example where disabling of PDF Tags will get you the issue and enabling PDF Tags is the workaround:

 

Some text in tables is shifted to the right after the PDF export
Peter Sauseng, April 26, 2021

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs/suggestions/43283988-some-text-in-t...

 

What PDF Export Preset did you use exactly?

Is there a small sample InDesign document you could share?

If yes, please put it on Dropbox or a similar service and post the link.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

LATEST

Hi Pascal,

please check if you have the "Adobe World-Ready Composer" applied to the text.

You find this setting in the applied paragraph style or the paragraph settings when text is selected.

 

The source of the issue could be a bug in the "Adobe World-Ready Composer".

See this discussion for more details:

 

Automatic hyphens randomly have letters in them
bracewell4213, 2 hours ago
https://community.adobe.com/t5/indesign/automatic-hyphens-randomly-have-letters-in-them/td-p/1218946...

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines