Style mapping and "local" formatting

Community Beginner ,
Jun 25, 2022 Jun 25, 2022

Copy link to clipboard

Copied

It looks to me that ID does not override Word completely. It does so partially, so the text is all turqoise when I use the local formatting button and the defined style has a plus next to it. If I override without  alt, there might be separate words and phrases in the paragraph also with local formatting, though it has just been converted. So, I'd have to alt click the whole text and add italics/bold back manually? Also, it does not take any styles for footnotes. There are like multiple fonts, though in Word there is only one. If I change the hyperlink manually, it will have a pink highlight behind it.

I saw a thread on that, biut am wondering if it can be fixed centrally?

 

ID also defines styles of things already deleted from the word file, like the ToC. 

Just in case, I also put the whole text into Times New Roman and black, but it still defines the colour of the heading marker which used to be blue. Or defines the style for red  highlighted part which is no longer there. 

It looks to me that my Word file is too corrupt or powerful or sth, but ID should get rid of all the extra stuff, right? The last book I did 3 months ago, had no problem with that. Can Adobe people help maybe?

TOPICS
Bug , How to , Import and export

Views

105

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 25, 2022 Jun 25, 2022

Copy link to clipboard

Copied

  1. In Word I apply to all italics, bold, etc. a character style.
  2. I import the Word document
  3. Select all > Paragraph Style Panel Menu > Remove Overrides.
  4. I delete all word styles and replace them, if the styling is needed with my InDesign style, others, which are not needed with no style.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

Thank you for your response! 

I do not usually apply chatracter styles in Word, but I may give it a try. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 25, 2022 Jun 25, 2022

Copy link to clipboard

Copied

I just ran into this with a large book import, and had it confirmed by another user. It's a new(ish) bug in that the import will assign all the correct styles but not override the Word formatting—if you have turquoise italics in Word and map them to a red bold style in ID, the "RedBold" character format will be applied, but the text will remain overridden as turquoise italics.

 

My solution was to do a search and replace of paragraph returns, by style, and reapply the paragraph format to each. A little tedious, but it worked.

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

Thank you for your response!  

What do you mean by "do a search and replace of paragraph returns, by style"

The whole text is turqoise, as if "local" after style mapping. 

Also, what to do with the pink background (as if highlight) when I manually apply character styles? 

 

Kind regards

Kersti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 25, 2022 Jun 25, 2022

Copy link to clipboard

Copied

Yes, this is a long-standing bug with InDesign's import/place utility.

 

InDesign's import filter leaves residual formatting code crud in the file, even if you map Word styles to InDesign styles. Here are a couple of scenarios we use at our studio.

 

1. If the Word author has used Word's styles to format the file (I know this is Utopia, but we have trained many clients to do this):

  • File / Place and check Show Import Options.
  • At the Options dialogue, select Preserve Styles and Formatting (mid-way down the dialogue) and the Customize Style Import / Style Mapping.
  • In the Style Mapping dialogue, choose how you want to handle each Word style found by InDesign: choose an existing InDesign style in your layout, [New Paragraph Style] automatically creates a new style based on the Word style's formatting, or New Paragraph Style... (at the bottom) lets you define a new style on the fly.
  • Note that this utility will "see" more styles in Word than were actually used in the .DOCX file. If the author, at any time during the doc's creation (even years ago in an earlier edition), selected a Word style but then formatted the text differently, residual code crud in Word still says that style is in use and it's picked up by InDesign's import utility. Just ignore them; we find they're harmless and rarely actually end up being carried into the InDesign layout. We set each of these phantom styles to [New Paragraph Style]: if the style truly was used, you'll get a new style in InDesign's Paragraph/Character styles panel and you can then deal with it. If it's Word's residual code crud, it's usually not imported into your layout at all.
     
  • The gotchas you'll have to correct:
    • If a character style was applied in Word (such as red italics), it most likely will still have red italics applied to it in your layout as a manual override, even if you mapped the Word character style to an InDesign character style (such as blue bold). With the text tool, Select All and click to remove the manual overrides. You'll now see your intended InDesign character style on that text. *** This is an InDesign bug that Adobe should correct.
    • The Character styles panel will show a handful of empty character styles pulled in from Word. They are Word crud that was carried into InDesign. (Word sometimes blends character styles into paragraph styles which causes this problem.) *** This is an InDesign bug that Adobe should correct.

 

2. If the Word author manually formatted the entire Word.docx file:

  • Strip the file clean using InDesign's import options.
  • File / Place and check Show Import Options.
  • At the Options dialogue, select Remove Styles and Formatting from Text and Tables (at the top of that section) and UNcheck Preserve Local Overrides.
  • You should end up with plain unformatted text in the layout that you can now style with your own Paragraph and Character styles.
     
  • The gotchas you'll have to correct:
    • We often find some residual manual formatting left on the text, so with the text tool, Select All and click to remove the manual overrides. You'll now have cleaned text. *** This is an InDesign bug that Adobe should correct.

 

Final note: You'll always have better text coming into the layout if you control what comes in with Show Import Options.  Choose either method to get rid of all Word formatting crud. 

 

Hope this helps.

 

 

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

Thank you for your lengthy response. 

So very disappointed with Adobe. As I can see from the reponses, no option is anything but time-consuming. 

The excess styles... I have them all carried to Indesign. I guess they are harmless as you say. 

Why does it apply a pink background (highlight) to any changes that I apply from Character Styles? Where can I turn it off? a+ does not fix it.

Kind regards

Kersti

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

Pink background means that the font is missing for that particular portion of highlighted text.

Use Type / Find Fonts to find the missing font and replace it with a valid font (or weight of the font).

 

One easy 2-second fix that might solve the problem is:

  • With the text tool, Select All (Edit/Select All or command/control A). This selects the entire threaded story.
  • Click the Clear Overrides button to remove the manual overrides. It's at the bottom of the Paragraph Styles panel.
  • You'll now see your intended InDesign character style on that text.

Clear manual overrides on the selected text.Clear manual overrides on the selected text.

 

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

Thanks again!

Kersti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

I must have done something wrong on this book import; as noted above, when I did this first time round, it cleared too many things I wanted. I just did a recheck and yep, select-all, clear overrides does exactly what's needed, and no more.

 

Checks "learned something" box for the day. 🙂

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

LATEST

Lucky you, @James Gifford—NitroPress!

 

The trick to clear the residucal crud from MS Word imports is to do a  "plain" click on the clear overrides button. That is, just click it.

 

If you opt to do an Alt-Click or any other variation the tooltip suggests, you'll clear too deeply and could even remove the character style itself.

 

I teach this trick to my students in my classes.

  1. Always control the import of text into InDesign via Import Options.
  2. Either don't let any formatting in whatsoever, or map the styles as described above.
  3. Flow the text into the layout.
  4. Select All, and click Clear Overrides before doing anything else.
  5. Then proceed with the layout and design of the project.

 

Of course, rinse and repeat on your next project.

 

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines