• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Text disappears when typing in text box

New Here ,
Jan 04, 2022 Jan 04, 2022

Copy link to clipboard

Copied

I'm having the same issue as many others: when making any changes to text within a text box, like typing within it, cutting/pasteing, editing, etc. the text disappears. Sometimes it'll come back if I click out of the text box. Sometimes it comes back if I switch between normal and preview mode.

 

It doesn't happen every time, but often enough to be incredibly annoying.

 

I'm running:

  • Mac OS 12.0.1
  • Macbook Air M1 2020
  • InDesign 17.0.1
TOPICS
Performance

Views

623

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jan 04, 2022 Jan 04, 2022

Try turning off the GPU Performance in the InDesign settings.

Votes

Translate

Translate
Community Expert ,
Jan 04, 2022 Jan 04, 2022

Copy link to clipboard

Copied

Try turning off the GPU Performance in the InDesign settings.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 04, 2022 Jan 04, 2022

Copy link to clipboard

Copied

Hi there,

 

Sorry about the trouble. The team is aware of the issue. I would like to know if the steps suggested by @Eugene Tyson worked for you? If not, I will request you to share a few more details it will help us investigate the issue further:

    • Screenshot of "About This Mac." (both Overview and Displays tab)
    • Are you using an external monitor(s)? If yes, with which port and cable combination it is connected.
    • What is the scaled resolution of your screen & Monitor(s)?
      Anshul_Saini_0-1641339294439.png
    • Does setting the scaled Display resolution as 1920 x 1080 or below from the System Preferences help resolve the issue?

We will be looking forward to your response.

 

Thanks & Regards,

Anshul Saini

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 04, 2022 Jan 04, 2022

Copy link to clipboard

Copied

Hi Anshul,

 

Thankyou for your reply,

 

First of all turning off GPU mode seems to be working, although performance seems to be worsened.

Ive attached the screenshots below. About the mac, display settings

I occasionally use a secondary display but the issue persists regardless of whether it's connected, so irrelevant which ports im using.

I have my display set to default resolution.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Thanks for sharing the details. As turning off GPU resolves the issue, I would suggest you turn on GPU performance and, as a workaround, toggle shift + e command whenever text disappears. Also, your default resolution is 2560 x 1600. So, I would request you to please check if using scaled resolution 1920 x 1080 or below helps or not.
Note: You have to hover your cursor over the scaled resolution to see the exact resolution as highlighted by the red rectangle in the attached screenshot.

Anshul_Saini_0-1641415196332.png

 

I will be looking forward to your response.

 

Regards,

Anshul Saini

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 20, 2023 Sep 20, 2023

Copy link to clipboard

Copied

I am having a similar problem.  When I try to type text on a page which has a graphic master nothing shows. I can draw a frame, but I can't put any text in it. If I drag a text box from one page to another all the text disappears. Can't seem to find GPU settings in Preferences. Any suggestions??? I am running Windows 11 and the latest version of Indesign.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 21, 2023 Sep 21, 2023

Copy link to clipboard

Copied

Hi @Pamela99,

 

Sorry to hear about the trouble. Can you share a few more details like:

 

-The exact version of InDesign & Windows 11.

-Is this happening on a specific file or multiple files?

-Is there any pattern that leads to this issue?

-Have you updated the graphics card drivers? If you still need to, please ensure you have the latest build per the manufacturer's website.

 

We're here to help, just need more information.


Thanks

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 21, 2023 Sep 21, 2023

Copy link to clipboard

Copied

LATEST

It seems that the problem comes from text wrap. Select the text frame, go to the text frame options (Ctrl B) and check the “Ignore text wrap” checkbox.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines