Highlighted

InDesign CC - Spell check not working.

New Here ,
Sep 03, 2013

Copy link to clipboard

Copied

I can purposefully type a misspelled word in InDesign and the Spell Check doesn't catch it. In fact it doesn't seem to work at all.

As is often the case, the answer is simple. I find a lot of people jump to things like entering code in the terminal and the like. I had the problem and someone posted that You simply have to be in preview mode. "w" (when your cursor is not typing text, otherwise escape then w) will bring it up. Presto, dynamic spell check is working.

TOPICS
Performance

Views

38.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

InDesign CC - Spell check not working.

New Here ,
Sep 03, 2013

Copy link to clipboard

Copied

I can purposefully type a misspelled word in InDesign and the Spell Check doesn't catch it. In fact it doesn't seem to work at all.

As is often the case, the answer is simple. I find a lot of people jump to things like entering code in the terminal and the like. I had the problem and someone posted that You simply have to be in preview mode. "w" (when your cursor is not typing text, otherwise escape then w) will bring it up. Presto, dynamic spell check is working.

TOPICS
Performance

Views

38.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 03, 2013 0
Most Valuable Participant ,
Sep 03, 2013

Copy link to clipboard

Copied

Is there a language assigned to it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 03, 2013 0
Community Beginner ,
Feb 03, 2014

Copy link to clipboard

Copied

And if the right language is assigned....?

Ever since I upgraded to the most recent Indesign CC, spell check will not work. Help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2014 2
Adobe Community Professional ,
Feb 03, 2014

Copy link to clipboard

Copied

If the correct language is assigned in the Character or Control panel, it should be spell-checked by that dictionary.

Try restoring your preferences. Here's how:

Trash, Replace, Reset, or Restore the application Preferences

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2014 0
Community Beginner ,
Feb 03, 2014

Copy link to clipboard

Copied

Arrg. That worked for a little bit. Now: spell check works for two files. Two other files I have open it will not work. And any new doc created it will not work.

I didn't change any preferences at all.

What else could it be/can I do???? Resetting preferences every few hours would be rediculous.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2014 0
Adobe Employee ,
Feb 03, 2014

Copy link to clipboard

Copied

Hi

Can you check the language of your application in No Doc state. Please try following steps

1.) Launch ID and do not open any document (No doc state).

2.) Open Character panel (Ctrl/Cmd+T)

3.) Check the Language in the language dropdown.

4.) If Language set as  "NoLanguage" then change it to "English: USA"

Now open a new document and verify whether spell check works for you or not.

Spell.PNG

Thanks

Dinesh Kukreja

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2014 4
Community Beginner ,
Feb 04, 2014

Copy link to clipboard

Copied

Nope. That didn't work either. Tried a few other languages just for kicks. They don't work either.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2014 0
Community Beginner ,
Feb 04, 2014

Copy link to clipboard

Copied

Re-tried trashing the preferences again opening a new doc, checking the language: English USA. Popped in some lorem ipsum.

Spell Check will not work.

At this point I think it's a Program error, since it started from the last time I upgraded CC.

Since there isn't a new upgrade that I see yet I am thinking uninstalling and reinstalling ID will not do anything different.

Anyone else have any other suggestions?

Adobe could you check into another ID CC upgrade perhaps?

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2014 0
Explorer ,
Feb 04, 2014

Copy link to clipboard

Copied

There is a good chance your language preferences are coming from your Paragraph Styles.  Paragraph styles override all other document preferences when applied to text. 

To check if this is the problem, open your paragraph styles panel (F11) and double-click any of the styles (i.e. [basic paragraph]).  Click the 'Advanced Character Formats' tab on the left navigation menu; verify that Language is set to your preferred language (e.g. English: USA). 

Do this for all listed styles, then save your document.  Run spell check again and your problem should be solved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2014 3
Community Beginner ,
Feb 05, 2014

Copy link to clipboard

Copied

Nope. that's not it either.

Brand new file created, no styles at all, and the Basic Paragraph is set on English USA.

Spell check will not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 05, 2014 0
New Here ,
Feb 11, 2014

Copy link to clipboard

Copied

Experiencing the same problem here, including "Ignore All" not working and picking up the same word within the same paragraph (so same style, same language). Only have one master, one language setting. Stopped working after latest CC update.

Have trashed preferences and there are no updates available.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 11, 2014 0
Engaged ,
Feb 27, 2014

Copy link to clipboard

Copied

I, too, can't get the latest version of InDesign to spellcheck. This is terrible. I'm going to have to start using Quark again if this keeps up. I need to be able to spell check my files!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2014 0
Engaged ,
Feb 28, 2014

Copy link to clipboard

Copied

Can you provide more detail on your workflow, Julie?

A few screenshots of what you are seeing would be helpful as well.

Thanks,

Amy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 28, 2014 0
Engaged ,
Mar 04, 2014

Copy link to clipboard

Copied

Sure. I'm using Adobe Indesign CC v 9.2 on an iMac running OS X v. 10.9.2. When I try to spellcheck, the palette pops up, but if memory serves... the check mark at the top left SHOULD turn green when it's ready to spellcheck. It never does. I click on "Start" and it does nothing. No error messages or anything indicating a problem (other than the green check mark isn't green). For a long while I thought it was spellchecking and not finding any misspellings. It wasn't until a client pointed out somthing was mispelled that I realized it wasn't working. screenshot.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2014 0
Community Beginner ,
Mar 04, 2014

Copy link to clipboard

Copied

This is exactly what my InDesign is doing. Even after I reset all preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2014 1
Adobe Employee ,
Mar 05, 2014

Copy link to clipboard

Copied

Hi

Could you please provide the following information which could help in reproducing the issue at my end.

- Please provide screen shot of the dictionary preferences from following location.

   Mac : Indesign->Preferences->Dictionary

   Win : Edit->Preferences->Dictionary

- Please confirm whether this issue is also happening with new documents? Can you attach an .indd document with some misspelled words which ID spell check is not able to find. 

- Do you have previous version of InDesign installed on your machine ? IF yes, can you tell me which all older version of InDesign are installed on your machine ?

- Please confirm whether Spell check was working fine for you in previous version i.e. in Version 9.1 and issue started when you updated to latest version i.e. ID 9.2.

I really appreciate your cooperation on this.

Thanks & Regards

Dinesh Kukreja

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 05, 2014 0
Adobe Employee ,
Mar 13, 2014

Copy link to clipboard

Copied

I have tried to re-produce this issue in house and also worked with Julie who was facing this issue. I could not find out any obvious reason why spell check should not work after updating to ID 9.2. I suspected that there could be some installation issue which resulted in this issue. So i suggested Julie to uninstall then Indesign and re-install from the Creative Cloud and this has worked for her and Spell check is working now.

Please try this out and see whether this works for others  who are facing the similar issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2014 0
New Here ,
Mar 14, 2014

Copy link to clipboard

Copied

Dinesh, we just tested this in our office and the problem is still persisting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 14, 2014 0
New Here ,
Apr 10, 2014

Copy link to clipboard

Copied

the only thing that helped was un-install and re-installing via the CC updater.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2014 0
New Here ,
Apr 10, 2014

Copy link to clipboard

Copied

An update regarding spell check. We had originally un-installed, re-installed and nothing changed. After running an update yesterday through CC, spell check partially works now: it will pick up misspelled words, however, 'Change All' and 'Ignore All' still do not work - not even when the same word is in the exact same paragraph using the exact same style. 'Ignore All' is available to click on, but doesn't actually ignore. 'Change All' is greyed out and the same word gets picked up over and over.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2014 0
Explorer ,
Mar 31, 2015

Copy link to clipboard

Copied

Same issue happening here… though I only realized it when a client pointed out some typos *after* I knew I had run spellcheck…

Running the latest ID 10.0.0.70 on a Mac running the latest 10.10.2. Everything in the document (selected type), styles and prefs are set to US English, the Hunspell thing is selected and it finds nothing whatsoever to fix, even very obvious typos… I guess I'll try adding my own dictionary as mentioned above to see if it helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2015 0
LEGEND ,
Apr 01, 2015

Copy link to clipboard

Copied

Running the latest ID 10.0.0.70 on a Mac running the latest 10.10.2.

That's not the latest build of ID. Quit the Desktop App using the gear icon, restart it and then update ID.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 01, 2015 0
New Here ,
Mar 01, 2016

Copy link to clipboard

Copied

I'm having the exact same problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 01, 2016 0
New Here ,
Apr 12, 2017

Copy link to clipboard

Copied

This works. Select all and change to English.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2017 0
New Here ,
Jul 21, 2017

Copy link to clipboard

Copied

THANK YOU!  I just suddenly had this spelling issue occur for a single document and tried everything else. I got to your advice, and hey presto, my main para style had somehow changed itself to Japanese!  No idea why! Changed it back and since other styles based on it, they switched too, and now spellcheck is working fine.

THANK YOU THANK YOU I hope you're still around to know you saved the day for me. You're my hero. THANK YOU.

Terry

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 21, 2017 0
New Here ,
May 29, 2014

Copy link to clipboard

Copied

I too was having the same problem after updating to CC. This is what worked for me: Preferences, Dictionary, Spelling-Hunspell. It was set to Proximity by default. My language always had English: USA, so that wasn't my issue. Hopefully this will work for others with the same problem. Good luck!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 29, 2014 12
Community Beginner ,
Jan 27, 2015

Copy link to clipboard

Copied

Once I also changed Preferences, Dictionary, Hyphenation to Hunspell this worked for me.

I had already done the noted steps about checking and fixing Language under Paragraph and Character styles. A bunch of the character styles were indeed not set to a language even through overall preferences were. However until I also changed to Hunspell for both Spelling and Hyphenation under Dictionary dynamic spelling did not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 27, 2015 2
New Here ,
Mar 18, 2020

Copy link to clipboard

Copied

Thank you - you legend ... that has been bugging me for ages 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2020 1
New Here ,
Mar 20, 2020

Copy link to clipboard

Copied

This worked for me - thanks 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2020 0
New Here ,
Mar 31, 2020

Copy link to clipboard

Copied

You're a genius. I'm writing a book that this really messed me up. Your fix worked!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2020 0
New Here ,
Oct 01, 2017

Copy link to clipboard

Copied

This worked for me years later, thank you !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2017 0
New Here ,
Apr 05, 2020

Copy link to clipboard

Copied

Bingo! Mine too stopped working after latest upgrade. Tried all other suggestions and this worked - thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 05, 2020 0
Community Beginner ,
Apr 08, 2020

Copy link to clipboard

Copied

Thanks!! This worked for me. For some documents, my spell-checker window just sat there and did nothing no matter how many times I clicked 'Start'. Once I changed hypenation and spelling to Hunspell (from the default Proximity), the spell-checker instantly went back to working as expected.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2020 0
New Here ,
Apr 20, 2020

Copy link to clipboard

Copied

This has also worked for me – thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2020 0
New Here ,
Apr 20, 2020

Copy link to clipboard

Copied

This was the answer to my problem as well... (Well changing both Hyphenation & Spelling to "HUNSPELL") I have an office 15 designers and we where all stumped... for like weeks! Thank you. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2020 0
New Here ,
Apr 21, 2020

Copy link to clipboard

Copied

Changing hyphenation and spelling to Hunspell fixed my issue as well. However, I needed to fix this within each individual documents that I was collaborating with. New documents on my system had it set to Hunspell properly. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2020 0
Explorer ,
Nov 18, 2014

Copy link to clipboard

Copied

I had the same problem too, ever since InDesign CS6 was first installed on my MBP laptop (OS X, late-2008 model).

I just fixed the issue by replacing two of the original en-US dictionary files with ones I downloaded from OpenOffice.  Here are the directions that I followed to accomplish this -- Add or remove Hunspell dictionaries | CC, CS6.  And this is the file I downloaded to replace the AFF and DIC files -- http://extensions.openoffice.org/en/project/us-english-spell-checking-dictionary.

I hope this helps.  Cheers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2014 2
New Here ,
May 05, 2018

Copy link to clipboard

Copied

maiyo8  schreef

I had the same problem too, ever since InDesign CS6 was first installed on my MBP laptop (OS X, late-2008 model).

I just fixed the issue by replacing two of the original en-US dictionary files with ones I downloaded from OpenOffice.  Here are the directions that I followed to accomplish this -- Add or remove Hunspell dictionaries | CC, CS6.  And this is the file I downloaded to replace the AFF and DIC files -- http://extensions.openoffice.org/en/project/us-english-spell-checking-dictionary.

I hope this helps.  Cheers!

Thank you maiyo8! This is the only thing that worked for me (after a recent InDesign CC update I could not get the spell check working, even after trying everything else posted here). Replacing the Hunspell dictionaries finally worked! More than 3 years later and Adobe is still not able to fix this problem??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 05, 2018 0
New Here ,
Apr 30, 2015

Copy link to clipboard

Copied

I too was having the same problem with my brand-new copy of Indesign, just downloaded last week. Spellcheck completely failed to work. I checked all the preferences recommended here, still nothing. But what HAS worked was the advice from maiyo8: downloading the English dictionaries from OpenOffice (aiff & dic) and replacing the ones that came with the software. Restarted Indesign and bingo: spellcheck works now. Thanks so very much, maiyo8! You have saved my reputation as a graphic designer who always checks to make sure my layouts are delivered to the client spelling-error free. Although I have yet to find a fix for the errors a client makes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 30, 2015 0
Community Beginner ,
Jun 15, 2015

Copy link to clipboard

Copied

I just cleared overrides in the paragraph styles panel and it works. Hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2015 0