Photoshop missing in "edit with" context menu for images

Engaged ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

I am using Indesign cc 2017. My "edit with" right click menu does not have Photoshop listed. I have to click "other" and then locate photoshop.exe everytime I want to edit my image in photoshop. What should I do so that photoshop is always listed in my "edit with" context menu?edit with photoshop missing.jpg

Views

5.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

I noticed in the past, that if I start Adobe Bridge it starts the connectors and links all the applications together. It might be easier to try that first, then you will have to move to purging your cache and preferences before considering reinstalling Photoshop

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

Thanks a lot. I started Adobe Bridge. Then fiddled with opening some psd files and indd files through it. Indesign was still missing the photoshop option. I restarted InDesign and got what I wanted. But this is true for only pdf files linked in Indesign. I am still missing photoshop for jpegs and png files. The following screenshot is for a pdf file page. I trashed my preferences but still have the issue. How do I purge my cache? I regularly use Ccleaner to clean temp files and system cache. That hasn't helped me ever for this issue.

for pdfs.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

In Bridge > Preferences > File Type Associations, what do you have for PS, JPEG, and PNG? Change it in Bridge Preferences and it should work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

jane-e  wrote

In Bridge > Preferences > File Type Associations, what do you have for PS, JPEG, and PNG? Change it in Bridge Preferences and it should work.

I have all of them set up as Adobe Photoshop only.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 06, 2017 May 06, 2017

Copy link to clipboard

Copied

I always thought this was handled by Bridge, not Windows/Mac or by InDesign. In one place I teach the IT somehow removed all of the File Type Associations inside of Bridge, and it destroyed the Edit With for InDesign. The staff put them back in manually and then the Edit With worked again.

Have you deleted Preferences for Bridge?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 07, 2017 May 07, 2017

Copy link to clipboard

Copied

jane-e  wrote

I always thought this was handled by Bridge, not Windows/Mac or by InDesign. In one place I teach the IT somehow removed all of the File Type Associations inside of Bridge, and it destroyed the Edit With for InDesign. The staff put them back in manually and then the Edit With worked again.

Have you deleted Preferences for Bridge?

Yes I did delete them by pressing Ctrl + Alt + Shift. The issue still persists. I have bridge cs6 version installed but I don't have any photoshop, illustrator or indesign cs6 installed on my machine. From CS6 I only have Adobe premiere pro. I don't have any cc version of bridge on my machine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2017 May 07, 2017

Copy link to clipboard

Copied

arjun2  wrote

Have you deleted Preferences for Bridge?

Yes I did delete them by pressing Ctrl + Alt + Shift. The issue still persists. I have bridge cs6 version installed but I don't have any photoshop, illustrator or indesign cs6 installed on my machine. From CS6 I only have Adobe premiere pro. I don't have any cc version of bridge on my machine.

Now I'm confused! The original question (that I thought we were trying to answer) is that you are using InDesign CC 2017 and Photoshop does not show up under "Edit with".

What software do you have, then? I think I am missing something?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 07, 2017 May 07, 2017

Copy link to clipboard

Copied

That's right. I have Indesign CC 2017 installed and Bridge CS6 installed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2017 May 07, 2017

Copy link to clipboard

Copied

I think that Bridge CS6 may be too old and not "make the connections" correctly with the much newer InDesign CC 2017. If  you have a Creative Cloud subscription (as opposed to an InDesign CC subscription), you should be able to download the newer Bridge CC 2017.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2017 May 07, 2017

Copy link to clipboard

Copied

Looking back at your screen capture, Arjun2, I see that your other applications are also CC 2017. In the Creative Cloud desktop app (task bar in Windows), look for the section called FIND ADDITIONAL APPS, and see if you see Bridge CC 2017.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

I think that Bridge CS6 may be too old and not "make the connections" correctly with the much newer InDesign CC 2017. If  you have a Creative Cloud subscription (as opposed to an InDesign CC subscription), you should be able to download the newer Bridge CC 2017

I installed Bridge CC 2017 and restarted my PC. Still the same old problem. Now what should I do?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

I'm getting the idea that whatever is happening on your system is pretty unique to your system. I don't really know. I'm just guessing. It's not a problem I have heard of before.

After installing Bridge CC 2017, I'd try restoring its preferences. Hold down Ctrl + Alt + Shift immediately after launching. (That's because it could be pulling some settings from your old version of Bridge.) You should have a clean copy of Bridge CC 2017.

Then restart your computer, and restore your preferences in InDesign.

I don't have the answer, I'm just imagining how I would approach it if I had the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

Another idea: Uninstall Photoshop CC 2017, then reinstall it again. The process of installing after instalilng the new version of Bridge CC 2017 might make it click in.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

https://forums.adobe.com/people/Steve+Werner  wrote

Another idea: Uninstall Photoshop CC 2017, then reinstall it again. The process of installing after instalilng the new version of Bridge CC 2017 might make it click in.

I uninstalled my photoshop. Restarted my PC. Installed photoshop again, reset my bridge cc 2017 preferences. Reset my InDesign preferences, still no progress. I am still facing the same issue. Now what should I do?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

Wild guess - but maybe Windows Default Programs manages this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 06, 2017 May 06, 2017

Copy link to clipboard

Copied

No it does not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 06, 2017 May 06, 2017

Copy link to clipboard

Copied

Wild guess - but maybe Windows Default Programs manages this?

No it does not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 09, 2017 May 09, 2017

Copy link to clipboard

Copied

Windows does handle this. It is a function of the operating system. What happens if you choose edit original?

What type of file was this? What happens when you try to open one from Windows Explorer?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 09, 2017 May 09, 2017

Copy link to clipboard

Copied

Windows does handle this. It is a function of the operating system. What happens if you choose edit original?

What type of file was this? What happens when you try to open one from Windows Explorer?

It opens up in Picasa photo viewer which I"ve set for default when it comes to opening jpeg files in windows.

The file type is .indd having a few jpeg images and text. The behaviour reamains the same in all .indd files.

The jpeg image upon clicking in windows explorer opens, as expected in picasa photo viewer since that's the default application I"ve set up. If I'd set MS paint then they'd open up in it by default and after clicking "edit original" button in Adobe InDesign context menu.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 09, 2017 May 09, 2017

Copy link to clipboard

Copied

Try setting Photoshop as the default in Windows. Afterward change it back and see if you get the choice of Photoshop in the Edit with command.

What version of Windows are you using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 09, 2017 May 09, 2017

Copy link to clipboard

Copied

OKay. I'll set it to Photoshop and revert back. I'm using Windows 10-64 bit.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 11, 2018 May 11, 2018

Copy link to clipboard

Copied

I came here having the exact same issue and figured out what was causing it (at least for me anyway).

The issue for me was that it was a jpeg that somehow did not have the .jpeg extension at the end of the filename (sent to me by a contributor via cell phone). Adding the extension made it so that Photoshop appeared as an option. It is weird because I have been working with similar photos on a PC and never had this issue, only just started having it once I FINALLY got my work to upgrade me to a Mac. lol

Doubt this will be of any use to op since it was a year ago, but hoping this might help some poor sap in the future.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 06, 2017 May 06, 2017

Copy link to clipboard

Copied

You can delete Bridge preferences by holding down Cmd/Ctrl + Option/Alt + Shift immediately after launching.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 06, 2017 May 06, 2017

Copy link to clipboard

Copied

Also, (yay!) if you launch an application first you can hold down the keys and then go to File > Browse in Bridge (even if you are in Windows which usually doesn't let you hold down the keys first.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines