• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

P: Map module will not load Google Maps

Community Beginner ,
May 22, 2023 May 22, 2023

Copy link to clipboard

Copied

The map module in Adobe Lightroom Classic v12.3 will not load Google Maps correctly. Error message: "See the JavaScript console for technical details." 

Bug Fixed
TOPICS
macOS , Windows

Views

1.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Pinned Replies

Adobe Employee , May 23, 2023 May 23, 2023

We are investigating this issue. Thank you for the report!

Status Investigating

Votes

Translate

Translate
Adobe Employee , Dec 13, 2023 Dec 13, 2023

Greetings all,

 

Updates for the Adobe Photography Products have been released.  The December 2023 updates contain an update for this issue. 

If you do not see the update in your Creative Cloud Application, you can refresh it by hitting [Ctrl/Cmd]+[Alt/Opt]+[ R ].

Note: It may take up to 24 hours for your update to be available in your Creative Cloud app.

 

Thank you for your patience.

Status Fixed

Votes

Translate

Translate
12 Comments
Community Beginner ,
May 22, 2023 May 22, 2023

Copy link to clipboard

Copied

The map module in Adobe Lightroom Classic v12.3 will not load Google Maps correctly. Error message: "See the JavaScript console for technical details." 

Lightroom Classic version: 12.3 [ 202304101834-a085245c ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Home Premium Edition
Version: 10.0.19045

Graphics Processor Info:
DirectX: NVIDIA Quadro M4000 (27.21.14.5257)
Init State: GPU for Image Processing supported by default with custom export support

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 23, 2023 May 23, 2023

Copy link to clipboard

Copied

We are investigating this issue. Thank you for the report!

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Investigating

Votes

Translate

Translate

Report

Report
New Here ,
Aug 06, 2023 Aug 06, 2023

Copy link to clipboard

Copied

Hi

I got the same error with Lightroom Classic v 12.4

It occured after a reboot due to Windows BSOD while LRC was  geotagging a photo on Map panel (dragged with mouse)  .

Votes

Translate

Translate

Report

Report
New Here ,
Sep 21, 2023 Sep 21, 2023

Copy link to clipboard

Copied

I have the same problem with Lightroom Classic V12.5. In Dutch I get the message: 'Cannot connect to Adobe servers. The Map Module is not working'. No other error message. By the way, my PC (Windows 10) works fine and I have no trouble reaching other servers.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 09, 2023 Oct 09, 2023

Copy link to clipboard

Copied

I just recieved the same error in Lightroom Classic 12.5.  I was updating some geotags and Lightroom hung up.  I've restarted Lightroom and rebooted the PC with no success. 

Votes

Translate

Translate

Report

Report
Engaged ,
Nov 12, 2023 Nov 12, 2023

Copy link to clipboard

Copied

Same happening here. Google Maps is very unstable on Lightroom Classic. I also Have ACdsee and PhotoMechanic and don't have this issue in those programs

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 13, 2023 Dec 13, 2023

Copy link to clipboard

Copied

Greetings all,

 

Updates for the Adobe Photography Products have been released.  The December 2023 updates contain an update for this issue. 

If you do not see the update in your Creative Cloud Application, you can refresh it by hitting [Ctrl/Cmd]+[Alt/Opt]+[ R ].

Note: It may take up to 24 hours for your update to be available in your Creative Cloud app.

 

Thank you for your patience.

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Fixed

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 06, 2024 Jan 06, 2024

Copy link to clipboard

Copied

I run Lightroom Classic 9.4 on OSX 10.13.6 and everything has been working fine, but after the latest update in December 2023, I can no longer get the map to show up. Nothing happens, I just see a gray field.
Everything else seems to be working as usual as far as I can tell.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 06, 2024 Jan 06, 2024

Copy link to clipboard

Copied

@Fjellfotografen, you likely are experiencing a different issue than the bug reported (and fixed) in this thread, given that you're on a very old version of LR and Mac OS anbd you're observing different symptoms.

 

"Nothing happens, I just see a gray field."

 

1. In a Web browser, verify that maps.google.com works.

 

2. In LR, go to the Library module. Then exit LR, restart LR, and go back to the Map module. (Exiting LR directly from the Map module can cause your symptoms.)

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 08, 2024 Jan 08, 2024

Copy link to clipboard

Copied

Thank's John, maps.google.com works fine. But exiting in library mode doesn't help, I still get no map.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 08, 2024 Jan 08, 2024

Copy link to clipboard

Copied

"maps.google.com works fine. But exiting in library mode doesn't help, I still get no map."

 

Hmm. Given you're on a four-year-old version of LR, which Adobe no longer supports, I don't think Adobe would be of much help on this.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 30, 2024 Jan 30, 2024

Copy link to clipboard

Copied

LATEST

I still have that problem in LR Classic version 13.1 I get the message: "Oops! Something went wrong. This page didn't load Google Maps correctly. See the JavaScript console for technical details."

Votes

Translate

Translate

Report

Report