P: Very important sentence dropped from "The Lightroom Classic Programmers Guide"

0 Votes
LEGEND ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

Though there were otherwise just cosmetic changes made to the SDK version 11 "Lightroom Classic Programmers Guide", there was one serious mistake. On page 9, as part of changing occurrences of "Lightroom" to "Lightroom Classic", this sentence from previous versions was deleted:

 

"Lightroom 5 uses version 5.1.4 of the Lua language."

 

That sentence should be retained and edited to say:

 

"Lightroom Classic uses version 5.1.4 of the Lua Language"

 

It's very important to tell plugin developers which version the SDK uses because:

 

- The mainstream Lua release is now Lua 5.4.3 and there are significant differences between 5.1.4 (the version LR uses) and 5.4.3.

- Most programmers coming to the SDK aren't familiar with Lua and will get confused when they read documentation for the wrong version.

 

 

Bug Acknowledged
TOPICS
macOS , SDK , Windows

Views

273

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 11, 2021 Nov 11, 2021
setting status
Status Acknowledged

Votes

Translate

Translate
3 Comments
Adobe Employee ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

setting status

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Bug Acknowledged

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

@Rikk Flohr: Photography, this was fixed in the LR SDK 11.2, thanks.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

LATEST

Settings status to fixed

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report