• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Slow preview generation - M1 Pro

Community Beginner ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

I'm having an issue with very slow preview generation on my new M1 Pro MacBook. The app its self feels very fluid when editing, but generating previews is taking a lot longer than I'm used to.

 

I render standard previews after making batch changes, and it seems like it's only doing one at a time. I've checked the settings to ensure parallel processing is on and it is. I've also checked that GPU renering is on. 

 

Has anyone else had an issue with this? I'm using the latest version of Lightroom Classic and a 14" M1 Pro MacBook.

 

TOPICS
macOS

Views

160

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

"I've checked the settings to ensure parallel processing is on and it is."

 

I assume you're referring to the option Preferences > Performance > Generate Previews In Parallel:

johnrellis_0-1645321671916.png

 

Try resetting LR's preferences:
https://www.lightroomqueen.com/articles-page/how-do-i-reset-lightrooms-preferences/


LR sometimes soils its preferences file, and resetting it can fix all sorts of wonky behavior. That article explains how to restore the old preferences if resetting doesn't help.

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

Thanks for the reply. Unfortunbately junking the preferences did not fix the issue, it's still mega slow to generate standard previews. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

The app its self feels very fluid when editing, but generating previews is taking a lot longer than I'm used to.

 

So, what are you comparing the M1 Pro to?

 

What are the specs for your M1 Pro and what are the specs for the computer you're comparing it to?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

Trust me, its slow. I get what you're trying to say but 25 seconds per
preview in single file is slow compared to just a out anything.

--

Chris



Top Table Photography

(PII removed by moderator)




Have we exceeded your expectations? Please consider reviewing us on Google.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied


@defaultbw6w30w9pcdq wrote:

Trust me, its slow. I get what you're trying to say but 25 seconds per
preview in single file is slow compared to just a out anything.



That is indeed ridiculously slow. It should not take more than one or two seconds. Your previews cache may be corrupted, so try the following: Move the 'catalogname previews.lrdata' file out of the catalog folder and start Lightroom. Initially you will not see any previews at all, but then Lightroom starts to rebuild the previews one by one, this time hopefully much faster.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

Try deselecting "Generate Previews in Parallel ", and see if that helps.

https://community.adobe.com/t5/lightroom-classic-discussions/quick-tips-optimize-lrc-preferences-for...

 

 

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.7.1 BigSur,; LrC 12.0.1, Lr 6.0, Ps 24.0, ACR 15.0,; Camera OM-D E-M1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

This appears to be worse, if anything. Thnaks for the suggestion though. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 22, 2022 May 22, 2022

Copy link to clipboard

Copied

LATEST

Did you ever solve this issue? I just got the 14 in M1 MBP and am shocked at how long it takes to load previews in LR... and this is comparing to my 10 year old MBP 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines