• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Lightroom is freezing with a lot of presets on M1 Macbook

Community Beginner ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

I have the latest Lightroom 5.4 on M1 Pro macOS Monterey 12.4 and bought some presets recently. I realized with lots of presets (around 400 grouped under 10-15 groups) Lightroom starts to freeze (loading is shown) when moving between photos. It generally takes around 5-8 seconds for it to go back to normal. When I disable the presets from the "Manage Presets" screen, things go back to normal.

 

These presets are working/rendering fine on my iPad Mini but lagging on M1, so I assume this is a software issue.

 

Did anyone had an issue like this?

TOPICS
macOS

Views

205

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

Could a moderator move this to bugs? I realized I opened this to the wrong place.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

There isn't sufficient information to classify this as a bug currently. 

 

Reproducible steps, system specifications and  a sample preset that exhibits the issue would go a long way towards confirming a bug. 

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

Hello, I am sharing a video and a system information. Let me know if anything else would help. I think I cannot share a sample preset as it would be illegal. The presets are RNI presets, but even if they are not selected/applied it causes issues. Just opening the presets once is enough for me to experience this, even after I close the tab the issue is there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

I've got RNI presets installed and can't reproduce the issue on M1 Mac Mini, so there may be something else involved here. 

-------------------------------------
The Lightroom Queen - Author of the Lightroom Missing FAQ & Edit Like a Pro books.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

@Rikk Flohr: Photography Is there any other log I can collect or something that I can do? The app is simply not usable for me on my two Macbook's. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

LATEST

@Rikk Flohr: Photography 
Ciao Rikk, I can confirm the issue on two of my machines. The application is unsuable for me. Really. Thanks to this forum and the tipp of @Kaan25178877ox3g to disable the presents, I at least have a workaround.

Maybe its worth to note, that RNI 5 uses a "profile based" approach, where RNI 4 uses an "adjustment based" approach.

 

This issue came up recently (using the same version of RNI) - but new update of lightroom.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

I have a similar problem. I have a bunch of presets in folders. I would need to take count, but > 400 sounds about right. I purchased most of them at once, but did not see performance problems right away. It took weeks of importing new photos and editing before I noticed any performance issues.

Indeed, disabling the presets brings back performance to normal. If I re-enable the presets, instantly performance slows to a crawl with 100% cpu spikes again.

fwiw I bought this https://www.presetpro.com/product/creative-flow-beautiful-lightroom-presets-and-brushes/ and installed all the presets as instructed. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

I'll add, that this performance bug with a large number of presets does not exist using the latest lightroom classic. If this isn't a bug, then we have a taken a step backwards in expected usability.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

I confirm the very same on my M1 Air and M1 Pro. Since the last version, navigating from picture to picture takes ages - including spinning wheel mouse coursor. It is almost unusable now.

I also have installed RNI (https://reallyniceimages.com/) Version 5.

Thanks a tousand @Kaan25178877ox3g for the tipp with disabling the presents! This really made my day!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines