Store Locally keeps getting stuck (downloading originals not smart previews)

Community Beginner ,
Oct 20, 2020

Copy link to clipboard

Copied

With recent updates to the Lightroom for iPad app, the "Store Locally" have started to become glitchy for me, specifically it stalls all the time on syncing albums.

 

I want to store originals locally so that I can edit on the go, without having to pull huge amounts of data via cellular data or be dependent on WiFi availability. I have to storage to keep most of my catalouge on the iPad.

 

If I toggle on "Only Download Smart Previews" the sync will switch to download smart previews and seem not to get stuck - but when I switch back it resumes from where I was and often will remain stuck.

If I keep toggling on and off, it will sometimes go past the point it got stuck at last - but then only download another 10-20 images before becoming stuck again.

 

As I typically have thousands of originals stored locally, this is totally unworkable for me.

 

Any and all help will be much appreciated.

TOPICS
Bug, Crash or freeze, iOS, Problem or error, Sync

Views

224

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Oct 20, 2020

Copy link to clipboard

Copied

Hi, 

toggling the button might not be a good way to solve the issue.
Turning the Only Download Smart Previews will trigger a download of Originals.
That can be a lot of data, and the stalling might be connected to your connection.
Especially if you are working with RAWs.

For us to verify if you have an issue, please send us a diagnostic log to follow up on.
You can trigger it by going to:
1. Settings
2. Help & Support
3. Long press on Acces our Support Forum

Thanks,
Ignacio 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
micdah AUTHOR
Community Beginner ,
Oct 21, 2020

Copy link to clipboard

Copied

Hi Ignacio,

 

Thank you for the quick reply - I have generated the log as requested and uploaded the resulting content here:

[Removed by moderator]

 

Please ensure to download it within 7 days, as the Dropbox transfer link will expire by then. 

 

Indeed toggling "Only download smart previews" is not something I am trying as a "fix", just a curiosity that it somehow gets it going for a bit again, each time. I do indeed want the RAW's stored locally and not the smart previews.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Oct 21, 2020

Copy link to clipboard

Copied

I got the log, and got it removed since it contains personal information.

Thanks,
Ignacio

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Oct 21, 2020

Copy link to clipboard

Copied

I looked at the log, not seeing anything strange.
If you have waited a long time for anything to download (like hours), it might help to log out and log in again.

But please, tap on the cloud icon and verify that:
1. Nothing is still importing
2. Nothing is still being processed (if you use the Lr app camera)

If you do have anything in 1 or 2, please wait for them to finish before logging out.

thanks,
Ignacio

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
micdah AUTHOR
Community Beginner ,
Oct 21, 2020

Copy link to clipboard

Copied

Hi Ignacio,

 

I have tried logging out and back in again - sadly this didn't resolve the issue, as it is still stuck.

 

I have also tried entirely deleting the app and re-installing from App Store, then toggling albums to "Store locally" after disabling "Only download smart previews", and it just gets stuck again.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 23, 2020

Copy link to clipboard

Copied

@micdah and @Ignacio Barrientos I have noticed the same behavior with the latest vs of lightroom mobile.  The only way I'm able to get my raw files to download is the toggle the smart preview option.  Once the smart previews are downloaded I then toggle back to download original and only then does it work.  

 

I've noticed this behavior when only trying to download 4 files (60mb raw).  It seems to affect both my iPhone and iPad.

 

Cheers,

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
micdah AUTHOR
Community Beginner ,
Oct 27, 2020

Copy link to clipboard

Copied

Hi Ignacio,

 

I have tried your suggestion of logging out and back in again - and it sadly didn't work.

 

What do we try now?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
micdah AUTHOR
Community Beginner ,
Jan 25, 2021

Copy link to clipboard

Copied

@Ignacio Barrientos The issue still persist for me, any word on a fix og something I can try out?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Jan 25, 2021

Copy link to clipboard

Copied

Hi,

thanks for confirming that a logout and login didn't help.
It does sound as if you are hitting a bug here.

The images that you are trying to download, do you know how they were uploaded?

thanks,
Ignacio

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
micdah AUTHOR
Community Beginner ,
Jan 25, 2021

Copy link to clipboard

Copied

Really good question - I upload from a mix of either directly from my iPad or sometimes from my MacBook.

 

So I would guess it is a mix of the two, I would have a hard time saying exactly which as the files are unaltered from the camera, just directly added to lightroom and uploaded regardless of which device I use to upload.

 

Any way I can inspect the files in Lightroom to better answer your question?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Jan 25, 2021

Copy link to clipboard

Copied

OK, when you say MacBook; do you mean Lightroom Classic or Lightroom?
The reason why I ask is that images uploaded from Classic normally doesn't upload a Original.
That might be the trigger.

It would be great if you could add some of the images that you have a problem with to an album named 
forDebug. That way we can check look at the meta data in the backend where they come from.

thanks,
Ignacio

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
micdah AUTHOR
Community Beginner ,
Jan 26, 2021

Copy link to clipboard

Copied

I meant Lightroom non-classic on the MacBook.

 

I have tried to find albums which exhibited this behaviour still - and to my excitement I have not been able to reproduce it anymore. Which would suggest whichever bug I was encountering has been fixed in the interim.

 

Just to be absolutely sure, I have also tried entirely uninstalling the app from my iPad, reinstalling and tried storing a large number of albums I know for a fact had trouble before - and after more than 100GB worth of images, still no issues.

 

So I am very excited now, to not having to deal with this issue anymore. :☜(⌒▽⌒)☞

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Jan 26, 2021

Copy link to clipboard

Copied

Ok, I understand.

You will always "solve" the issue by uninstalling the app.
Please let us know if you would run into the issue again.

thanks,
Ignacio

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
micdah AUTHOR
Community Beginner ,
Jan 26, 2021

Copy link to clipboard

Copied

Hi @Ignacio Barrientos ,

 

No, uninstalling did not solve the issue previously - as I mentioned before I had tried entirely uninstalling the app and reinstalling, then trying to store albums locally - which back then still resulted in the same error.

 

But as of now, this no longer occurrs. Just to be precise, when configured to store originals and not smart previews.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Jan 26, 2021

Copy link to clipboard

Copied

Got it, so whenever this issue occurred it is now fixed in the 6.1 version.

Thanks,
Ignacio

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more