• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

P: 'Open as Smart Object' using PDF scale issue

0 Votes
Community Beginner ,
Nov 15, 2022 Nov 15, 2022

Copy link to clipboard

Copied

I use Photoshop to color architectural drawings, exported from AutoCAD as PDF-files. I usually choose the 'open as smart object' with the crop-to-media setting to import the drawing in the correct scale.

Lately, when i do this, Photoshop opens the smartobject scaled and distorted in the wrong canvas-size, which poses a huge problem for the drawing-scale if not discovered before the graphic work has been executed.

Is this a bug, or is there a work-around?

Bug Acknowledged
TOPICS
macOS , Windows

Views

141

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 18, 2022 Nov 18, 2022

Hi,
Before going the preference route, can you try opening the PDF (not using "...as Smart Object") so you get the Image Size options. Then make sure they are the dimensions and proportions you expect, before opening. Does that look right? Close the document without saving, and try opening again as Smart Object.

regards, steve
 

Votes

Translate

Translate
5 Comments
Adobe Employee ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Can you share the file you're having trouble opening as a Smart Object? Post a URL to the file using CC files or dropbox, or something similar to share the file.

 

It would also be valuable to get screenshots of the settings in the open dialogs.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

Hi Jeffrey,

 

The file-link is here: https://acrobat.adobe.com/link/review?uri=urn:aaid:scds:US:5a70c4ae-3716-3c92-af91-26d513e2e413 

 

Below comes screenshots of the opening dialogue in correct order:

1.png

2.png3.png4.png

 

 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

Weird. Here's what I see when I open your file as a smart object: 

JeffreyTranberry_0-1668809129707.png

It doesn't get squished like yours. I'll play around some more.

 

I'm wondering if there's some pref that's different between our setups.

Try restoring your preferences using this manual method:
https://helpx.adobe.com/photoshop/using/preferences.html#Manually
If that doesn't solve it, you can quit Photoshop and put the Settings folder back


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

Hi,
Before going the preference route, can you try opening the PDF (not using "...as Smart Object") so you get the Image Size options. Then make sure they are the dimensions and proportions you expect, before opening. Does that look right? Close the document without saving, and try opening again as Smart Object.

regards, steve
 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 21, 2022 Nov 21, 2022

Copy link to clipboard

Copied

LATEST

Thank you Steve, that worked beautifully!

I checked 'Constrain Proportions' in the PDF import dialogue box (using the regular 'open' function), opened the PDF and closed it without saving. Afterwards i was able to 'open as smart object' in the right proportions.

Votes

Translate

Translate

Report

Report