P: Tool shortcuts resetting to default tool (E.g. L = selects freehand lasso instead of magnetic)

15 Votes
LEGEND ,
Dec 18, 2015 Dec 18, 2015

Copy link to clipboard

Copied

Photoshop CC 2015: I'm not sure how to explain this articulately, but bear with me:

I always have my (L) tool set to polygonal lasso, always my (C) tool set to slice selector. I press L or C, or whatever tool shortcut, and I get my last-used tool out of that variety (e.g. C = 1. Crop Tool, 2. Perspective crop tool, 3. Slice tool, 4. Slice select tool)

Since the last update, whenever I'm using a different tool and then press L/C on my keyboard, it will select the default (first in the line of) tool, instead of the one I was last using, so L selects the freehand lasso, or C selects the crop tool, meaning I have to manually select/shift+L to get back around to the tool I wanted.

Has the latest update removed the 'last-used' functionality? Is there any way to get around this?

Thanks.

Bug Fixed
TOPICS
macOS , Windows

Views

178

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Aug 08, 2016 Aug 08, 2016
Please install the CC 2015.5.1 update that was released tonight to correct this issue: http://blogs.adobe.com/crawlspace/2016/08/photoshop-cc-2015-5-1-update-now-available.html

Votes

Translate

Translate
38 Comments
LEGEND ,
Dec 18, 2015 Dec 18, 2015

Copy link to clipboard

Copied

Same here. I use "A" and "G" a lot for the vector anchor selector tool and solid fill tool, and it keeps defaulting me to the black vector shape selector tool and the gradient fill tool which has been super frustrating.

Votes

Translate

Translate

Report

Report
Guide ,
Dec 18, 2015 Dec 18, 2015

Copy link to clipboard

Copied

i've been noticing this as well... and sometimes simply switching from one open doc to another will change tools too.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 07, 2016 Jan 07, 2016

Copy link to clipboard

Copied

This is also happening to me, which is extremely frustrating, I'm glad i'm not the only one....

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 07, 2016 Jan 07, 2016

Copy link to clipboard

Copied

Since 2015.1 photoshop has new toolbar feature: http://petapixel.com/2015/12/01/adobe...
Maybe it is related.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 07, 2016 Jan 07, 2016

Copy link to clipboard

Copied

same here with the magic wand(w) and the healing brush (j)

Votes

Translate

Translate

Report

Report
New Here ,
Jan 07, 2016 Jan 07, 2016

Copy link to clipboard

Copied

ok, looks like customizing the toolbar order fixes the issue. at least it fixed it after one closing and reopening of photoshop.

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 08, 2016 Jan 08, 2016

Copy link to clipboard

Copied

I have the same frustrating issue. I understood adding customization for toolbar, but why it cost changing deafault functionality as it was for ages leaving last selected tool after PS restart?

But have more radical solution. I returned to CC2014 not also by this "feature" but a lot of other frustrating changes in UI for no reason. Giving new functions as a additional to apply by user is good, but changing thinks that worked for ages is the wrong way Adobe...

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 08, 2016 Jan 08, 2016

Copy link to clipboard

Copied



This bug is very iritating becouse since CC2015 all works normal in all previous versions of PS

For example. I use in Photoshop Magic Wand, then I close PS. So far normal. But when I open again PS i have Magic Wand on tools panel, but when i press keyboard shortcut (W) to use Magic Wand it reset to Quick Selection. And this bug take place on all tools in panelk tools. As far I have opened PS its normal taking tool via shortcut, but when close PS and open it again taking tool via shortcut reset it to first tool on list.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 14, 2016 Feb 14, 2016

Copy link to clipboard

Copied

This is actively slowing down my workflow. I need Healing tool on the 2nd option (healing brush, not spot healing) most of the time. After using other tools, L takes me to Spot Healing. I have to break my flow, check the tool, shift-L to get the one I need. Every. Time. Please fix urgently.

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 14, 2016 Feb 14, 2016

Copy link to clipboard

Copied

There is some simmilar bug solved in 2015.1.2 http://blogs.adobe.com/crawlspace/2016/01/photoshop-cc-2015-1-2-update-now-available.html Which version do you have? Did you try rearange tools positions in custom toolbar settings as workaround?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 14, 2016 Feb 14, 2016

Copy link to clipboard

Copied

Similar, but not the same, bug - the one I'm describing is triggered not by closing and reopening photoshop, but just by selecting different tools after each other. So say I've used the marquee tool, then the sharpening tool, when I press J instead of getting the Healing tool I want, the tool resets as I press J and I'm left with the Spot Healing tool. I then have to press another Shift-J to cycle the tool to the one it had previously been left on. This might sound like a minor glitch, but I pay handsomely for this software, and it shouldn't have any glitches. And at the speed I edit, it does make a difference.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 14, 2016 Feb 14, 2016

Copy link to clipboard

Copied

I've tried the workaround, but that doesn't help. Thank for for the suggestion though.

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 15, 2016 Feb 15, 2016

Copy link to clipboard

Copied

Josh Katz said: ok, looks like customizing the toolbar order fixes the issue. at least it fixed it after one closing and reopening of photoshop.

Another workaround is assign one letter to one tool. I didn't noticed this bug in my Photoshop. I am not sure what could be reason.

Maybe reseting everything in Photoshop could solve this? If you are holding alt+ctrl+shift during the start Phothop you will see dialog for reset settings. (make backup before, because every settings and presets will be lost)

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 24, 2016 Jun 24, 2016

Copy link to clipboard

Copied

Sorry. We thought this was fixed by another change to retaining the state of the toolbar between launches with the start screen. We have a bug logged for this variation with KBSC and sub-tools.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community Expert ,
Jul 05, 2016 Jul 05, 2016

Copy link to clipboard

Copied



Just discovered this last night. Latest Photoshop CC, fully updated OS X, Intuos 3 tablet.

If I have the Healing Brush selected and use another feature, switching back reverts to the Spot Healing Brush. I have the pen buttons on my Wacom mapped to J and S and Shift key is required to change tools. Usually I go back to Healing with the pen button, not keyboard.

I've seen this using Frequency Separation, as an example. Have Healing Brush selected, switch to Lasso and select an area, apply the Median filter, deselect, then press the pen button and I'm switched to Spot Healing Brush. Expected to go to Healing Brush.

Please test this and let me know if its a known issue. I can test it on Windows 7/PS CC at work if needed.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 19, 2016 Jul 19, 2016

Copy link to clipboard

Copied

This is an issue for me as of 2015.5, but had not been an issue prior. Really hoping for a fix on this soon

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 22, 2016 Jul 22, 2016

Copy link to clipboard

Copied

Howdy Walt,

We have a fix for this -- expect to see it soon.

Thanks,
David

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jul 22, 2016 Jul 22, 2016

Copy link to clipboard

Copied

It seems to be fixed in my 2015.5. Why inconsistent experiences for different users?

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 22, 2016 Jul 22, 2016

Copy link to clipboard

Copied

You should be seeing the same thing as Walt in 2015.5.  

There are actually four different bugs that crept in here, all of which should be fixed soon.  So, whether it's your default tool, your last used tool, or if you quit the app and come back, the behavior will be consistent.

Thanks,
David

Votes

Translate

Translate

Report

Report
Engaged ,
Jul 22, 2016 Jul 22, 2016

Copy link to clipboard

Copied

Is this also responsible for Direct Select Tool NOT remembering 'Constrain Path Dragging', or is that yet another of the myriad examples of Abobe "CC" era of excellence?

Seriously guys, come on with this kind of sh*t already, your driving everyone mad.

Votes

Translate

Translate

Report

Report
Community Expert ,
Jul 23, 2016 Jul 23, 2016

Copy link to clipboard

Copied

There are actually four different bugs that crept in here, all of which should be fixed soon. 
It is appreciated that you give such frank feedback. 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 23, 2016 Jul 23, 2016

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 23, 2016 Jul 23, 2016

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 23, 2016 Jul 23, 2016

Copy link to clipboard

Copied

He is Indian Tajmahal

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jul 23, 2016 Jul 23, 2016

Copy link to clipboard

Copied

admin, please block this dude

Votes

Translate

Translate

Report

Report

Save time with Adobe Express quick actions