P: With rulers show, brushstroke creates a straight line as if Shift was held down (macOS)

8 Votes
Community Beginner ,
Nov 16, 2018 Nov 16, 2018

Copy link to clipboard

Copied

Updated to the latest OSX Mojave, and now the first brush stroke after picking a color(Option hotkey pressed and released before painting) on the canvas is not working properly, it does a straight line as if Shift was held down.

The problem was there before i updated to 20.0.1 and only had updated to Mojave 




Tested in Photoshop 18 and Autodesk sketchbook, no problem. 

Hope there is a fix for it soon.

Bug Acknowledged
TOPICS
macOS

Views

13

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 16, 2018 Nov 16, 2018
Hi Jesper,

I can repro the problem. Thanks for raising it.  Here's a temporary workaround until we fix it - turn Rulers off.   With Rulers off, you shouldn't run into this.  Let me know if you still do.

Thanks,
Chad

Votes

Translate

Translate
13 Comments
Adobe Employee ,
Nov 16, 2018 Nov 16, 2018

Copy link to clipboard

Copied

Hi Jesper,

I can repro the problem. Thanks for raising it.  Here's a temporary workaround until we fix it - turn Rulers off.   With Rulers off, you shouldn't run into this.  Let me know if you still do.

Thanks,
Chad

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 17, 2018 Nov 17, 2018

Copy link to clipboard

Copied

Hi Chad
Yes that works, thank you very much 🙂

Cheers 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 28, 2018 Nov 28, 2018

Copy link to clipboard

Copied

Hi Jesper,

Have you updated to Mac OS to 10.14.1?  I have not been able to repro this on 10.14.1.  Please let me know if you still can.  

Thanks,
Chad

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 29, 2018 Nov 29, 2018

Copy link to clipboard

Copied

"Have you updated to Mac OS to 10.14.1?  I have not been able to repro this on 10.14.1.  Please let me know if you still can." 

Just tired on 10.14.1 and the problem still remains.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 04, 2019 Jan 04, 2019

Copy link to clipboard

Copied



Hi !

Sorry for my English 😛

I have a problem with my new graphic tablet Huion New 1060Plus. The pen does strokes between some of my letters for example when I write, on Photoshop. I did some screenshots (the names of the brushes are in French, but we can clearly see the problem here, whenever I raise my pen, it makes a stroke with my next point ... hope you understand :p) :

RackMultipart20190102106685een-5e91cdc8-a413-43dc-939f-fb9c8bbfdd82-1161081671.png
RackMultipart2019010225214365j-6b5e09d2-4e54-449b-94a5-4502af8a0eca-375570490.png
RackMultipart201901029564014bx-3dbefaa9-4aa5-4fa3-91f6-8ef9be53b994-998074593.png
RackMultipart20190102317401kff-7c289cb1-2a54-486a-9a15-d8382cfb0020-1300962900.png
RackMultipart2019010258233o0ve-61917b8d-5a0b-4937-b61d-d6dedf0f5729-1559103825.png

To show the problem only seems to happen in Photoshop :

RackMultipart201901027831hf78k-3a4730a6-8c53-417e-815c-a43ebe31aa8e-4886404.png

I hope someone can help me 😞

PS : I'm on MacOS Mojave 10.14, Photoshop CC 2019, my Huion driver version is v13.6.8.170714

Votes

Translate

Translate

Report

Report
New Here ,
Jan 05, 2019 Jan 05, 2019

Copy link to clipboard

Copied

Finally I see someone else describing this problem - I have the same issue with clone-stamp in Photoshop - CC2019 - new (few weeks ago) iMac with Mojave; Wacom InutosPro 451 - never had this trouble before with CC2018 and Wacom 451 - source-click to clone and then when placing cursor onto destination-and-click it creates a straight-connecting-clone-line-from-the-source-to-destination point instead of, as usually, simply stamping only the sourced spot - need to double-click on source twice to sample the source and not get the connecting-stamp-line, or cmmnd-z undo and stamp twice... or...   ??    as of yet have not figured out any consistent kind of cure to fix the behaviour  - 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 05, 2019 Jan 05, 2019

Copy link to clipboard

Copied

Yes, I have this problem too. I am on the latest Mojave, the latest photoshop CC and the latest driver for the Wacom. It's driving me nuts.

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 23, 2019 Jan 23, 2019

Copy link to clipboard

Copied



RackMultipart2019012356303dybu-df552378-b231-4fca-8493-558f1354c858-238919740.png

When I draw with an erodible tip brush, every time I touch my tablet, it draws a straight line from the previous position, just like when I hold Shift.

It doesn't happen to any other kind of brush tip, so I'm sure it's not my Shift key gets stuck. It's not just annoying but makes erodible tips completely unusable. 

Photoshop version: 20.0.2

Votes

Translate

Translate

Report

Report
Contributor ,
Jan 23, 2020 Jan 23, 2020

Copy link to clipboard

Copied



clone stamp and healing brush with Wacom Intuos tablet sometimes freeze after Opt+Click, then a straight line shows up between the frozen clone source abd the brush cursor. here is a video showing the problem: https://www.youtube.com/watch?v=jAwl97_aXZw&feature=youtu.be

The issue is resolved only by turning off the ruler. 

I have experienced it on MacPro 2013 running 10.14 Mojave and on brand new MacBook Pro 16, 10.15.2 Catalina, only running latest Photoshop 21.0.2 and latest Wacom Driver 6.3.38-2. Nothing else yet installed.

The problem doesn't exist on MacPro 2013 running 10.12.6 Sierra.

Also testes with Wacom Intuos 4 XL (PTK-1240) and Intuos Pro M (PTH-651)

I'm aware that there were some issues with the ruler, but thought that thew are resolved in the last version. Adobe please, this is a serious issue. It is not possible to work like this.

Many thanks!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 23, 2020 Jan 23, 2020

Copy link to clipboard

Copied

Thank you so much ! The problem has never been solved since my post one year ago, I just received your answer and it worked ! Of course that's an issue Adobe needs to resolve, but at least I can finally use my tablet correctly now. Thanks again ! And I hope it will be resolved soon !

Votes

Translate

Translate

Report

Report
New Here ,
Jan 23, 2020 Jan 23, 2020

Copy link to clipboard

Copied



Ever since updating to Photoshop CC 20.0.2 I've been noticing this problem. It becomes specially visible when using the stamp tool. Whenever I do the alt+click - stroke fast enough the stroke gets all messed up. It draws a line from top to bottom instead of the intended direction whatever it may be. If it happens when I'm holding the stroke for longer the problem shows by not doing anything and the source sign, the cross won't move at all while I'm painting. 

Sometimes it will happen with the brush. Some strokes won't work at all, randomly.

I'm using an intuous wacom tablet. Drivers are up to date.

I still keep a copy of photoshop cc 2015 installed in my computer. Mac os X 10.14.2 by the way. And the problem doesn't happen in photoshop cc 2015. Anybody else has encountered this issue?? Thanks.

Votes

Translate

Translate

Report

Report
Community Expert ,
Jan 23, 2020 Jan 23, 2020

Copy link to clipboard

Copied

I've seen this issue on and off for years with Wacom tablets. Its rare on my Macs but for a while with Windows 7 was happening all the time. I have never seen it with a mouse.

Votes

Translate

Translate

Report

Report
Community Expert ,
Jan 24, 2020 Jan 24, 2020

Copy link to clipboard

Copied

LATEST
I did a Screen Recording of the Clone Stamp Tool misbehaviour (as happens intermittently with the rulers visible) and when scrolling through it slowly I noticed that after picking the source by alt-clicking 
• the next initially clicked point itself is honored 
• but the tool then seems to shoot in the direction of the position of the clone source instead of following the visible cursor and 
• the + indicating the source position does not move synchronous to the cursor. 

So the actual cursor position appears to be displayed on screen correctly but be disregarded as far as the Tool’s effect is concerned. 

(Adobe Photoshop Version: 21.0.3, Mac OS 10.15.2, Intuos4 XL)

Votes

Translate

Translate

Report

Report