• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Image/Canvas not visible - Photoshop 2024 25.4 MacOS Sonoma, M2 Max Studio

Explorer ,
Feb 02, 2024 Feb 02, 2024

Copy link to clipboard

Copied

I just updated to PS 25.4. When I open a file, I get a new tab or window for the document, scroll bars, layers visible in the pallete, etc... but the document is invisible. There are no canvas boundaries visible. Obviously, this renders the application entirely unusable.

 

I'm going to try and downgrade for now.

TOPICS
macOS

Views

411

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
Explorer ,
Feb 02, 2024 Feb 02, 2024

Copy link to clipboard

Copied

Downgraded to 25.3.1 and everything seems to work as before.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 02, 2024 Feb 02, 2024

Copy link to clipboard

Copied

Just going to add: 25.3.1 does have some really annoying display glitches, and I was sincerely hoping this update would address them. The biggest issue is that the display of layer masks break at different zoom levels. Huge, random blocks of stuff that should be masked out will nonetheless be displayed. The masks themselves are intact, but the display is incorrect. Often zooming several steps in our out will show the effect of the mask as it should be displayed, but it doesn't repair the view at the zoom level you wish to work at. I've made several adjustments based on other reports here, but its still a consistent issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 02, 2024 Feb 02, 2024

Copy link to clipboard

Copied

@MarshalSerna try going to Settings/Technology Preview and check "Deactivate Native Canvas". Relaunch PS. The other thing to try is under Performance uncheck "Use Mulithtreaded Compositing". Both have shown positive results with Mac Sonoma.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

LATEST

Thank you @kevin stohlmeyer . I was having this same problem and misunderstood your first instruction. I unchecked Deactivate Native Canvas. My Use Multithreaded Compositing was already unchecked. When I quit and reopened Photoshop 2024 Version 25.6.0, I was able to see my image. So, having them both unchecked seemed to do the trick.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 02, 2024 Feb 02, 2024

Copy link to clipboard

Copied

Oh god that sounds horrible! I don't have a Mac Studio, but let me see if I can replicate it on my MacBook 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 04, 2024 Feb 04, 2024

Copy link to clipboard

Copied

Thanks for the suggestions. I've downgraded to 25.3.1 for while a so that I can wrap a project. It's been working as before. Assuming the settings remained intact from 25.3.1 to 25.4 and back, it appears I already had "Deactivate Native Canvas" selected in Technology Preview settings. I've now unchecked "Use Mulithtreaded Compositing" in Performance to see if that resolves the mask display issues in 25.3.1. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 06, 2024 Feb 06, 2024

Copy link to clipboard

Copied

@kevin stohlmeyer I'm still on this project, and continuing to use 25.3.1. I just wanted to report that neither "Deactivate Native Canvas" nor unchecking "Use Mulithtreaded Compositing" resolves the mask display issues for me in this version.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

I'm having the same issue. So far the only solution that works for me is to go to Preferences>Performance uncheck "use graphics processor."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2024 Feb 14, 2024

Copy link to clipboard

Copied

Same. When searching for this problem online one can see that it has probably been around since at least 2019...  


Downgrade to old version doesn't help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines