• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

Layer FX won't stay consistent in frames of animation

Participant ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

I'm creating gifs that have text with a drop shadow. The text appears on each frame of the gif and has a drop shadow with a 120º angle. But the shadow FX is only correct in whatever frame is active as I work. Every other frame has a different angle. I have FX linked to be consistent through the entire animation but it's not doing it. I have to manually go to each frame and correct the angle to be the same throughout. It's very time consuming. I'm new to CC so maybe there's an option to select to help but I can't find it.

I also try selecting all the frames and THEN pasting the FX setting but it doesn't work either.

Views

2.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

I had a similar problem yesterday. I changed the Layer FX on a file that already had multiple frames established for the animation. I went into each frame invidually and changed the FX, but it didn't stick. I ended up deleting the original animated frames, keeping just the first frame with the new FX and then I duplicated frames out from there and recreated the animation.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

I'm adding text to an existing gif that's part of a filmed sequence so I can't recreate the animation, I'm just adding to it. Just can't get the FX to stay the same throughout! Seems like a glitch since everything else is selected that should make it do so.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

It really sounds to me like you are experiencing the same glitch I found yesterday. I understand frame animation. What I set up should have worked. Weirdly the layer FX would initially show and then it would switch back to the original state. It only stuck on the first frame in the animation and that is why I started over by duplicating frames from there. They did fix my issue. I'm wondering if it might have to do with working in the most recent version of Photoshop CC, on a file that was create several versions back.

What version of Photoshop are you using? Did the file originate from an earlier version?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

I'm using CC and it's a brand new file I created in it. I've had this issue since my last version of Photoshop (which was 5). I could fix it by selecting the Unify FX box, or by selecting each frame and pasting the correct FX on to the layer. But for some reason my quick fixes aren't working any more. And it does sound like your issue. Everything is right in frame 1 (or whichever frame happens to be selected at the time as I work). But any FX additions or changes aren't apples to the other frames even though Unify is selected (which it what it should do).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

Well I guess there is some comfort in know that our struggles are shared by others, but I'm sorry that I can offer any more help then that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

A frame in a frame animations is the composite of some number of layers in the layers stack.  Move the text layer with the layer style to the top of the layer stack. So other layers will not overlays the text layer style effect.

JJMack

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

My text layer is at the top of my later stack so it appears on top of everything else in my animation. But the FX still doesn't stick correctly to each frame.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

If it not proprietary can you upload the PSD and post a link to it? Did you try deleting the layer then add a new layer that show in all frames?

JJMack

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 11, 2017 Jan 11, 2017

Copy link to clipboard

Copied

I'm afraid I can't share it publicly. I'm adding text to an existing gif so each new layer I add to it is "new" I suppose. But I always have the problem of the FX not being unified across the animation.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

Have you tried checking Use Global Light on all of them?

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

Yup, Global Light is selected for each frame but it's still different for each frame. For example, 120º for the correct setting on 1 frame, 90º on every other frame.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 10, 2017 Jan 10, 2017

Copy link to clipboard

Copied

Are you sure you only have one text layer with the layer style in the layer stack?

JJMack

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2020 Apr 07, 2020

Copy link to clipboard

Copied

I had this issue as well, and tried all the same fixes. I ended up just grouping and rasterizing all my layers with effects. Its kind of a destructive way of editing but for a one off/quick fix solution its worked 🙂 would love to know the reason behind this so I dont have to rasterize the layes all the time!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 26, 2020 Aug 26, 2020

Copy link to clipboard

Copied

I know this was years ago, but I found that TURNING OFF global light is what worked for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 28, 2022 Mar 28, 2022

Copy link to clipboard

Copied

Thank you! I had this issue and it was driving me crazy!  The Layer Style shadows were moving around during the animation. Turning off "Use Global Light" fixed it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 29, 2022 Jul 29, 2022

Copy link to clipboard

Copied

THANK YOU!!! This solved the problem for me... took me a LONG time to find this solution.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 29, 2022 Jul 29, 2022

Copy link to clipboard

Copied

I love it when old threads help people out.  It's a pity that the forum's search facility is less than stellar.  For what it is worth, you'll probably get better results using Google with:

 

site: https://community.adobe.com shadow angle

 

Or

 

site: https://community.adobe.com "shadow" "angle"

 

...to force results with all of your search words or phrases (you'd obviously enclose the entire phrase with quote marks i.e. "shadow angle" )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

LATEST

I found that I had added the drop shadow while it was on a specific frame in the timeline - so it would only flash on when it hit that frame. I went back to the first frame, check marked the drop shadow option and it held/carried on through the animation frames. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines