Photoshop CC 2018 Brush lag

Community Beginner ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

Hi,

I updated PS yesterday and everytjing was fine, but today suddenly I got big brush lags. With smoothing on or off, no difference.

Lag gets even worse while zooming above 50%.

I've restarted preferences and PC and nothing happens.

I'm losing half a day trying to figure it out and its really nervous situation. Any ideas how to fix it?


Windows 7, 16 GB RAM, GTX 970, Intel i5 4570

Views

174.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 218 Replies 218
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

doesn't work for me
non of the previous suggestions work for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

Yeah I spoke too soon. The problem is back. Its NOT the "Enabled Preserve Details 2.0 Upscale" option. I'm out of ideas. And yes, I too am using a tablet and from what I'm reading, it ONLY affects tablet users.

So this is what I did:

My workflow consist of Lr > Ps > Lr. Normally I send three photos over from Lr to Ps to work on at the same time. So I reduced that to just one photo and that wasn't the problem.

Normally I would keep Lr opened in the BG while I work. So I closed Lr and only worked in Ps and that wasn't the problem.

Then I tried a combination of both those methods and that wasn't the problem.

Here is what I saw as a problem; When I used the Healing tools, in the Activity Monitor, while all other applications were closed, Photoshop and only Photoshop was taking a lot of resources getting it done. A hell of a lot more than it should. It jumped to 200.xx+ on the CPU %.

So now I'm convinced that the problem is Photoshop itself.

UPDATE # 1

Remember when I said that it wasn't giving me problems at any zoom level under 50%? Well now it is! What ever usefulness Photoshop had left is now gone.

Update # 2

I have uninstalled and re-installed Photoshop and even that doesn't help, so this HAS to be something that must be taken care of with a patch update because like I said, this is ONLY affecting tablet users. I have reverted back to using a mouse for my retouching projects and it just simply not as nearly precise as a tablet.

So here is hoping for a quick and simple fix.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

Juan: have you tried disabling Rulers (cmd-R) if you have them showing? That seems to help with most of the reported cases.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

Never had it on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

I just tried the "turn off rulers" and that seemed to improve it a lot.

The lag was making it unusable with the rulers on. With them off, the lag is down to being just annoying. It is definitely slowing down the retouching.

This is on an imac late 2015, maxed ram and an egpu.

Adobe, please fix this!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 23, 2018 Dec 23, 2018

Copy link to clipboard

Copied

I right clicked put hardness to zero and that took care of it, additional settings flow 15% opacity 100 smoothing zero and i unchecked the act like airbrush picture next to flow on the right side icon looks like an airbrush gun. I'm using a mouse

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

Yes I'm nrcoing this thread.

January 29th TWO THOUSAND AND NINETEEEN and this is still going on.

I have, quite literally, tried every solution in this thread and - at best - the stuttering disappears for a minute or two. Most of the time: no change.

This is TERRIBLE. PHOTOSHOP 2019 and I can barely color for a few seconds without everything just locking up for several seconds. Are you kidding me? I'm just trying to color something in red, with smoothing off, no rulers, performance > advanced set to basic, deleted settings, new install, new drive, new install, 16GB of extra memory ... what have i got to do here? sacrifice a small city to Dagon????

This is literally UNUSABLE.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2019 Feb 28, 2019

Copy link to clipboard

Copied

Yes, it's still broken. Adobe still taking your money and making stuff worse, adding a tonne of stuff no one wants or uses. Hey, tell you what, release a version that's stripped down AND WORKS without all the fluff, sack your useless dev. team and employ whoever used to work for you before this application was ruined.

I cannot work with this cr@p any longer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2019 Feb 28, 2019

Copy link to clipboard

Copied

And.. I've been using this application longer than most of your team have been able to walk! I used to love Photoshop. I hate it now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2019 Mar 21, 2019

Copy link to clipboard

Copied

Want stripped down and usable? Try Procreate.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 04, 2019 Mar 04, 2019

Copy link to clipboard

Copied

I've tried all the different preference settings and couldnt get this to work. Other drawing software, for example Krita, works fine in comparison. Neither GPU or CPU goes up abnormaly high when using any kind of brush except the normal hard/soft ones. If I switched to some of the default watercolour or oilpaint-brushes it lags incredibly much. Dont have rulers active either. Decreasing smoothing to 0% didnt change anything. BUT! If I lowered the resolution to as low as 300 dpi all the brushes is working way better. This should only be a workaround until Adobe actually fixes whatever bug has been infesting their software for like 1½ year.

My computer should be able to show the brushstrokes correctly though, its not a lousy one, even though its not a supercomputer anymore.

Modell: Asos RoG G750jz

RAM: 16GB

256GB SSD-drive (and a SATA, but PS is installed on SSD)

Graphicscard: GTX 880M 

OS: Win10, 1803

Processor: i7-4700HQ

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 05, 2019 Mar 05, 2019

Copy link to clipboard

Copied

It's incredibly frustrating, as a professional depending on tools for my work, to have tools that are just not stable.

Rulers make it slow. Smoothing makes it slow. Oh wait, perhaps it's the Wacom? Try using a mouse, lol.

Ah but have you tried deleting all your preferences to see if that works? It probably won't do s**t actually but won't that be fun?

What about a clean install and the subsequent hours and hours re-installing and re-configuring everything before you're able to get back to work.

Meanwhile deadlines approach, clients want updates, and my monthly subscription to Adobe ticks over.

Welcome to 2019 everybody.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 01, 2019 Apr 01, 2019

Copy link to clipboard

Copied

This change worked for me after months waiting for an update that could fix my problem.

First I increased softness (1-20% depending on your CPU) while brush was selected to activate options in the engine icon. After that I checked second and third options of engine softness icon (config). After that everything changed, now I can use CC 2019 almost 7 months later  ... I hope this can help someone else. Attached file to explain (Spanish version) Captura de pantalla 2019-04-01 a la(s) 4.20.32 p. m..png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 01, 2019 Apr 01, 2019

Copy link to clipboard

Copied

Thank you misterandrew2015!! I will definitely try it! I saw a number of suggestions to turn softness/smoothing off (or put to 0%) and mine was already at that setting and not working. I must have missed this suggestion! Thanks for taking to write down what worked for you. Going to try it now!

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

Nothing ever worked for me, every version of CC has suffered from this bug when used with a Wacom tablet.

Mac OS version and CC version, driver versions are irrelevant. It happens with every configuration. I've even bought a brand new iMac Pro with a clean install of Mac OS and only Photoshop CC and this brush lag bug still cripples Photoshop. I've tried all the fixes and workarounds. They are all temporary and not long term solutions. I've even invited an Adobe tech to visit my studio so they can monitor the bug in person.

There must be someone at Adobe who knows how to fix this. I would rather have no new features added to Photoshop and just focus on stability and fixes. Photoshop feels so fragile and glitchy now, and it used to be so robust. It's a real shame how this app has lost its stability and reliability - going back to an old version or to Affinity Photo really shows you how unreliable Photoshop has become.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 02, 2019 Apr 02, 2019

Copy link to clipboard

Copied

I am not using a Wacom, but I have the same problem and did the same thing, I got a new Mac, clean installs of everything, have 64 GB of RAM, followed Adobe's suggestion for performance settings, I have a ton of scratch disk space, but when I use the brush or eraser tool, the whole application goes to a halt. I get other slow-downs with other tools, but the brush tool is the worst. I do work with really big files, but even a 300 MB should be adjusted easily with 64 GB of RAM. I have been using Photoshop 6 - it works better than any new Creative Cloud release. I will try this latest tip, but nothing has worked for me either. I did buy Affinity Photo too as a backup.

I would so much rather have the brush work instead of having 3D Rendering or any other new tools. I feel stupid paying for Creative Suite when it doesn't even work. I occasionally need InDesign, Illustrator, Acrobat Pro...I need to find alternatives to those and I might quit Creative Suite.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 05, 2019 May 05, 2019

Copy link to clipboard

Copied

I’m not sure how you figured this out, but misterandre2015’s solution seems to be working for me up until now. Thank you!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2019 Jun 06, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2019 Jul 08, 2019

Copy link to clipboard

Copied

well i m facing the almost same situation, i have gaming Laptop Asus Rog Strix GL702vm with 12 gb ram ,128 ssd, GTX 1060 6gb and with this machine i m using wacom intous pro Large with photoshop cc19 and i m facing big brush lag while drawing  and painting and also facing undo lag when ever i try to undo my work it doesn't work it feels like time freeze in this situation i have to quickly press Alt+Tab to move on another program and then back to photoshop for undo the work and then its work but i have to perform this action everytime  i m sickoff  it please help thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines